cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
744
Views
3
Helpful
6
Replies

Ebgp between ios and ios xr

TaimurKhan
Level 1
Level 1

hello all

I am new to ios xr and after some study i started building a small lab

the lab is to bring eBgp neighborship between one regular ios and ios xr. they are connected directly

cisco ios xr  interface ip is 192.168.15.1/24

cisco ios interface ip is 192.168.15.2/24

they both can ping each others. 

My configs is below.

================================================
ios XR

================================================
interface GigabitEthernet0/0/0/1
ipv4 address 192.168.15.1 255.255.255.0
no shut
!
route-policy PASS
pass
end-policy
!
router bgp 1
address-family ipv4 unicast
!
neighbor 192.168.15.2
remote-as 5
address-family ipv4 unicast
route-policy PASS in
route-policy PASS out
!
================================================
Regular IOS
================================================

!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!

!
interface FastEthernet2/0
ip address 192.168.15.2 255.255.255.0
no shut

!
router bgp 5
bgp log-neighbor-changes
redistribute connected
neighbor 192.168.15.1 remote-as 1
!

================================================

 

with this config i am unable to bring the neighborship up.

please check.

 

 

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @TaimurKhan ,

Normally, XR should set the BGP router ID automatically if there is at least one ipv4 address configured locally. It looks like it might not be able to do so in your case for some reason. Try forcing the router ID with the following command:

router bgp 1

 bgp router-id 192.168.15.1

By the way, it is a best practice to set the BGP router ID explicitly, rather than let BGP pick one automatically.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

6 Replies 6

balaji.bandi
Hall of Fame
Hall of Fame

The question confusing here ? heading says EIGRP and Content is BGP

Are you Looking BPG config - can you able to ping each other Routers ?

Advise -  use source interface and on IOS activate command.

check below guide can help you :

https://community.cisco.com/t5/networking-knowledge-base/bgp-basic-configuration-on-ios-xr-ibgp-and-ebgp/ta-p/3145638

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

thanks for the reply

heading of the topic is Ebgp not eigrp

i have gone through that full article document and followed it but it is not coming up. although i am able to make eigrp neighborship up.

 

 

Harold Ritter
Cisco Employee
Cisco Employee

Hi @TaimurKhan ,

Normally, XR should set the BGP router ID automatically if there is at least one ipv4 address configured locally. It looks like it might not be able to do so in your case for some reason. Try forcing the router ID with the following command:

router bgp 1

 bgp router-id 192.168.15.1

By the way, it is a best practice to set the BGP router ID explicitly, rather than let BGP pick one automatically.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

thanks alot

I have spent hours on fixing this issue. now it is up. thanks once again.

 

You are very welcome @TaimurKhan . There is a few ways you could have gone for troubleshooting this issue.

1. show bgp ipv4 unicast neighbor x.x.x.x detail (as mentioned by @tkarnani )

2. debug bgp (after configuring "logging console debug"). This a good option for lab testing, but need to use it with caution if it is for a production network.

Regards, 

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

tkarnani
Cisco Employee
Cisco Employee

on XR

show bgp ipv4 unicast neighbor x.x.x.x detail << this output usually gives some clue as to why its down