cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2028
Views
10
Helpful
4
Replies
lomonaco
Beginner

Verify if the IOS-XR image installed is using encryption (k9) or not

Hi Guys,

     I wanna upgrade an ASR 9010 from IOS-XR 4.1 to IOS-XR 4.2 and I don't know how to determine if the actual image is

     ASR9K-iosxr-p-4.1.0.tar or ASR9K-iosxr-p-k9-4.1.0.tar.

     What's the better way to find if the image used in a previous installation in ASR 9010 have encryption (k9) or not ??

      My Best Regards,

      Andre Gustavo Lomonaco

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Aby,

You do not require a seperate license to install/activate the sec PIE.

Example: i you are running IOS-XR release 5.1.1, you just need to download asr9k-k9sec-px-5.1.1 PIE and install/activate the same. Post this you should be able to configure and use sec features like SSH, SFTP, etc.

Regards,

View solution in original post

4 REPLIES 4
mdebraba
Cisco Employee

Use 'show install active summary', if you see the 'k9sec' package listed that means it is active on your router, and only the

ASR9K-iosxr-p-k9-4.1.0.tar will contain that package.

Is a separate license required to add and enable security package . We have package with out Sec pie installed currently and We will be adding the sec- pie soon . Wondering is there any additional license required to enable Security Package.

if any one is aware please reply

Thanks!

 


 

Hi Aby,

You do not require a seperate license to install/activate the sec PIE.

Example: i you are running IOS-XR release 5.1.1, you just need to download asr9k-k9sec-px-5.1.1 PIE and install/activate the same. Post this you should be able to configure and use sec features like SSH, SFTP, etc.

Regards,

Thanks a lot for your reply.