Showing results for 
Search instead for 
Did you mean: 

Jabber for Windows 9.1 get message could not be delivered.

Level 1
Level 1

Everytime I message a co-worker for the first time every day I get this error


Then when he responds it doesn't have his name listed. i.e. (his responce is "just once")

To which I said hrm!!

Very odd. It seems that he is the only person that this happens to.

We have rebuilt his cisco framework softphone. (Razor blade icon)

I deleted my win 7 profile cache in both local and roaming.

22 Replies 22

Muhammad Maqsood Mushtaq
Cisco Employee
Cisco Employee


If this is cloud deployment (WebEx) and you see following statements in log file for the failed message, then it is a known issue:

DEBUG [0x000024c8]  [\imp\handlers\IMP2PResultHandler.cpp(41)]  [csf-unified.imp.presenceadapter.imp2presulthandler]  [IMP2PResultHandler::execute] - Jid: Result: SUCCESS


DEBUG [0x000024c8]  [\imp\handlers\IMP2PResultHandler.cpp(41)]  [csf-unified.imp.presenceadapter.imp2presulthandler]  [IMP2PResultHandler::execute] - Result: FAILURE

If it is On-Prem (CUP) deployment, this will need further investigation via a TAC case.



This is on prem cup deployment. Only seems to happen with this user.

We were able to test an upcoming version in our shop for Cisco and it seems to correct this problem.  Hopefully will release right after Xmas.  I believe the 9.1.2 release.

I am running 9.1.2 Jabber and still get this issue with an On-prem deployment....8.6.4 CUPS...

Any Ideas? IT isn't consistent.....


Did you use David's fix above? Worked great for me.

Level 1
Level 1

I am seeing the same issue as Christopher.  Upgraded to Jabber 9.1.2 with on-prem deployment 8.6.4 CUPS.  Any other ideas?

This is actually a bug in CUPS. It has to do with the IM forking that happens if you have multiple devices using chat.(Iphone, ipad and windows clients for instance) once you reply to the mesage then the chat is unicast to the one specific device and the issue dissapears. The current workaround is stopping the SIP Proxy service on your CUPS server. The only thing this affects is web based stuff in the administration pages. This is supposed to be fixed in v8.6.5 CUPS.

Hi All,

We're seeing this bug on 9.1.1, is there a bug id for this issue?


Chris Deren
Hall of Fame
Hall of Fame

I just noticed this on new IMP 9.1 deployment with J4W 9.1.3, always occurs on new conversation and goes away after initial reply, very frustrating.


We ran into the same issue with one individual user, we were able to resolved it by going to Call Manager and remove the user license capability and re-enable it. 

Hi Hao Tran,

I got the same issue and your solution worked for. Thanking you

Joshua Sandi
Level 1
Level 1

Hi there,

I would recommend you through a CLI run the command "utils service list" and see if the following services are running:

Cisco SIP Proxy
Cisco Sync Agent
Cisco XCP Authentication Service
Cisco XCP Connection Manager
Cisco Presence Engine

Also some times this can be related to the "Persistent Chat" being enabled, you might be able to check that in CUPS under Messaging > Group Chat and Persistent Chat Settings, if you're not using it you might want to disable it.


Is anyone getting this on CUPS 9.1 specifically in HA with user assignment set to Balanced mode vs. using the secondary node as a hot standby?  I seem to only see this issue between users that are not on the same node, and TAC gave me some dodgy reasoning around assigning all users to a single node that I didn't really buy into.

All I had to do was go to Call Manager and remove the user license capability and re-enable it per Hao above.  That fixed the issue.