Showing results for 
Search instead for 
Did you mean: 

Cannot Delete "New Folder" and "New Folder 1" from Script Repository

Level 1
Level 1

Good Evening,

I've noticed a series of numerically titled "New Folder"s in the Script Repository of UCCX 8.5.  The creator is Null and last update date 01/01/1970  quite clearly these have been orphaned in the database.  However when I try to rename or delete these directories I just get an error message saying operation failed.

As this is a development server I've restarted the UCCX Engine Service and have stretched as far as rebooting the whole server, however these DB entries are still present.

Any suggestions for how to remove them?  I considered using the CLI run sql command but don't know anything about the backend DB structure and don't really want to 'play'.

Any assistance would be gratefully received.



21 Replies 21

I have the same bug with UCCX 11.0,

And it happens automatically every time my system shuts down unexpectedly,

One difference, all the new folders created are just called "New Folder", no numeric reference.

It looks like a corrupted db, but other then being annoying it doesn't seem to be doing much else.

Hope they got it fixed in 11.5.

just hit the same in 12.5.


Did you ever get a fix for this?

It appears that you can delete the folder, however it goes NO WHERE. It appears to be cosmetic because if you try to refresh the folder, you receive an error that the folder does not exist. I was able to upload a script to the "New Folder" and it created another folder that was last modified by me, instead of Null. I was able to delete this folder but the original New Folder remained.

Has anyone found a solution from TAC?

Did you ever find a solution to this issue? I am experiencing the same problem with A co-worked hit the "Create New Folder" button under the CCX Editor and now they show up in CCX Web Admin. I try to delete and it appears to be successful, but the folder never deletes.

Ditto here.


Also was due to folders created accidentally in CCX Editor (using the current CCX Editor installed from the existing UCCX system's plug-ins page) - running 64bit Win 7 and 64bit Win 8.

It annoys me no end as there's 5 or so of them sitting there when navigating to Script Management.

Is there a Cisco rep on here that can offer maybe some CLI solution or create a bug?

Has anyone logged this issue with TAC? I haven't yet but will do so eventually.

If so, what was the outcome?


Level 1
Level 1

I had this same exact problem.  Tried to create folders in the editor and now they can't be removed from the server.  Opened a TAC case and the engineer had to manually run some delete commands agains the informix database to remove them.  If you have this issue I would suggest contacting TAC, they should be able to fix it.



Level 3
Level 3

I made the mistake of clicking the "New Folder" button when you use the "Cisco Unified CCX Editor" "Open Script" window and had this exact same issue.  Looks like it's existed for about 10 years.  I have a UCCX HA Pair running 12.5.1 SU1, so their latest/greatest version still supports this bug.  TAC had to delete the folders from the Informix database.