Showing results for 
Search instead for 
Did you mean: 

Cisco Supervisor Desktop resetting

Andrew Skelly
Level 7
Level 7

I'm running CSD 6.6(1) Premium w/ CCX 7.0 on a machine that is configured as a mail relay server.  This machine is on all the time as is CSD, so that email alerts related to queue levels can be sent to appropriate management.  However after a period of inactivity, the CSD "resets" itself.  By reset, I mean that if I have Team A up to view its stats, after a period of inactivity, it will revert back to "Select Team" from the drop down.  This is causing email alerts to not be sent out unless I come back to it and choose a team, then a flood of alerts come out (if any are required).  I've tried closing and restarting the app as well as restarting the machine but to no avail.  The machine is not hibernating or on standby.  Has anybody else encountered this issue?  If so, were you able to resolve it and how?

Please rate helpful posts by clicking the thumbs up!
13 Replies 13

Anthony Holloway
Cisco Employee
Cisco Employee

I'm curious, the CSD stats reset at midnight every night.  I wonder if that is when you are seeing this behavior.  If so, it's probably working as designed?  But not sure.  For product feature/function questions you could try the colloboration community:

I think you might have to be a partner to view.  If you are not, let me know and I'll post the question on your behalf.


No, this is not related to stats reset.  This is happening in the middle of the day, repeatedly in the same day.  To clarify, the stats themselves are not resetting, just the view.  In other words, the view is going from seeing a team view (agents, stats, etc.) to the view you have when you first log in to CSD ("Select a team" in the drop down box).  If I choose a team, the stats for the day show, and any queue that has active calls over threshold limits sends out email alerts.  However having this "reset" (or re-login might be more precise?) happening constantly through out the day is throwing off the systems ability to send email alerts real time as soon as the threshold is met.

Please rate helpful posts by clicking the thumbs up!

Level 1
Level 1

I'm having exactly the same issue on my UCCX 8 installation and its driving me crazy!

You literally select the team to view and with 10 to 15 minutes its reverted back to "Select Team'. The strange this i only have this issue with one user, other supervisors can view the same team with any issue from their machines (once the team is selected at the beginning of the day it stays selected!)

With this in mind i'm thinking its got to be something to do with this particular users machine, in your case is it affecting 1 user or multiple users?

The problem supervisor also does not display the agents, but it shows all the queues!

Did you ever figure this out?  I'm having the same problem with one location - where the supervisor can't see the agent assigned to their queues.

Thanks Jim

The issue seems to have resolved on its own.  I've had the machine up and running for several weeks now and suddenly in the past few days, it is no longer "resetting"/"logging back in" every X period of time.  I have made no changes to the machine's settings in any way nor have I made any changes to my user settings.  I'm sorry I don't have an answer for this because next time it happens (and it will I can guarantee, probably when I restart it again) I will be back to square one for God knows how long until it hopefully resolves itself again.

Please rate helpful posts by clicking the thumbs up!


Sent from my iPad

I removed all the agents along with the associated CSQ's from the team settings.  After reassigning them back into their respective areas, the supervisor was able to see agents assign to them.  Not sure why this worked.


I removed all the Agents and CSQ's associated with the team having problems, waited several minutes and then reapplied them - now the supervisors are able to view them... Not sure why this worked, also help with agents bouncing in and out.


Level 1
Level 1

In my case I found the problem was being caused by the windows firewall blocking various elements of the supervisor software. As soon as I enabled them again the resetting stopped and all the agents were visible!

Sent from Cisco Technical Support iPhone App

Can you share what you changed in the firewall settings.  I have an exception set for both the CSD and CAD, but still have this

problem with the Supervisor Desktop where it goes back to the Select Team option now and then and they just lose the team view.

Did you put specific Ports in the Firewall Exception or soemthing else?


I ticked the following exceptions...

Cisco Agent Desktop

Cisco Desktop Administrator (Administrator.exe)

Cisco Desktop Administrator (Splkviewer.exe)

Cisco Supervisor Desktop

Cisco Supervisor Record Viewer

Cisco Supervisor Workflow Administrator

(Pretty much everything!)

Group policy is also set to No

My machine does not have Windows Firewall running, so it wasn't a firewall issue.  The only thing that I can possibly think of that may have changed with my PC prior to this working again was I had unplugged the network cable from the NIC card to connect a laptop to the corporate LAN.  It was unplugged for maybe about 20 minutes.  That's the only thing that I did with the machine.  Not sure if that would have resolved the issue, but thought I'd share, in case it might help somebody else.

Please rate helpful posts by clicking the thumbs up!

I know this thread is old, but I ran into this on UCCX 9. Just wanted to add a possible solution.

I virtualize Windows in vbox, and I'd experience the same issue with the default intel driver on a bridged network connection.

I switched to RH's virtio driver, bridged network, no more issues. Not sure what the equivelent would be if you're virtualizing on a Windows PC instead of Linux, but there should be another driver alternative.