cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1248
Views
0
Helpful
5
Replies

Device Target Abort Indication=2 on ICM Call Router

HI,

We have an UCCE comprehensive setup with version 8.0 and here is the call flow

PSTN->VG->CUSP->CVP->ICM call get completed the vxml treatment and transfered to the live agent.Here i have problem, agent getting reserved in CTI tool kit but did not get a call on his phone and later pushed agen to not ready mode which happens intermittently(not all the time).Later its working fine with the same agent,extension without making any changes.

From the logs we understand that the reservation timer on the call routed to the agent has  expired. When the router selects an agent to send a call to, it also sends a Pre Route indicator telling the PG that the agent should be receiving a call.  If the call does not arrive within the reservation timer, the PIM generates DtAborts (Device target abort) when the reservation timer expires.  If it happens twice in a row(by default) ICM puts agent into not ready.

Please advise me where we need to increase the DtAborts reservation timer (by default 2) settings and what causes this ?

Relevant logs has been attached.

cucm pim logs:-

RouterCallKey=(150588/111633)  21:36:29:091 PG1B-pim1 Trace: ProcessReservedTimeout:  No call arrived to match PreCall message. netTargID=100475 Ext=400121 AgentID=52687 RTRCallKey=150588.111633 DtAborts=2

rtr logs:-

Line 21999: 21:37:55:154 ra-rtr Trace: DEVICE_TARGET_ABORT_IND message received from Peripheral(5000) CRSCallID(Date 150588 ,ID 111633), NetworkTarget(-1),MRDomain(1), AgentSkillTargetID(-1)

Regards,

Srinivasan

Everyone's tags (4)
5 REPLIES 5
Cisco Employee

Re: Device Target Abort Indication=2 on ICM Call Router

Hi,

I would suggest, we need to find out what happened to the Call sent to CVP with the Connect Label instead of increasing the timer

You get the Pre Call Indicator at the time 21:35:59:107 and TimeOut happens at 21:36:29:091. PG waits for 30 seconds here for the call arrival. That DtAborts=2 is number of time this happened.

From the Router perspective, i could see you send the connect message with the Label 400121. Can you check in you CVP, do you have proper routes Configured ? Do you have proper CSS/Partition assigned in CUCM side (for all trunks)

Check why there is a delay for the message sent to CVP

Regards,

Senthil

Re: Device Target Abort Indication=2 on ICM Call Router

Hi Senthil,

Thanks for the revert first.

Confirmed there is no issue with call routing, CSS/Partition, since the same was working immediately after some minutes.

I am looking for the CVP logs as you mentioned and will update the status ASAP.

Regards,

Srinivasan

Beginner

Hello Srinivasan, Did you

Hello Srinivasan,

 

Did you solve this issue? At this moment we are experiencing this behavior.

 

Thank you and Regards.

 

JMorales

 

 

Highlighted
Beginner

Hi,

Hi,

I'm having the same problem... any solution to this?

Thank you.

Beginner

Re: Device Target Abort Indication=2 on ICM Call Router

We are experiencing same issue, any resolution ?

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards