Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Error in logger machine

I got the following error at logger machine. When i am opening the Computer management -> Event Viewer -> Application

Error Deiscription :

The config checksum received from the partner did not match. This logger rows: 17921. Partner logger rows: 17920. This logger bytes: 7680289. Partner logger bytes 7680281. This logger checksum: 450670663. Partner logger checksum 450670340.. Use the ICMDBA tool to synchronize the logger databases.

Waht shall i do? How to resolve this issue?

Chris Deren
Hall of Fame Master

Just as the description says use the ICMDBA to synchronize the dbs. Simply type icmdba from run on the server to get to the tool.




If anyone can guide me. I am having an error while trying to save configuration in AW "failed to update database" "Another user has changed the object ". In logger process it also shows the cofig error "Another user has canged the object. You need to reresh and make your change again".

Screen shots are attached.

What version of UCCE/ICM?


ICM 7.2.1.

Go for the router registry and set the DBMaintenance key to 1, that would avoid any config changes, then on the logger go to ICMDBA and do a synch.

Then put the registry key back at 0.

This should do it,


I am using ICM in a duplex mode so need to change that key on both side one by one and then synch both logger databases ?

otherwise it'll impact the call centre calls?

The key needs to be changed only on one system it will apply to the entire ICM.

The impact is that no config changes are allowed while the DB is in maintenance mode.



Following steps has taken

1. change kep to 1 on logger sideB

2. stop both logger services and synch sideB logger DB to sideA logger DB.

3. Chenge key to "0" again and then try to save config in icm AW.

Result : same error "Failed to update database". Another user has changed the object

The key is on the ICM CallRouter.

Second point the error you got from the AW has nothing to see with the config being up to date or not.

The UpdateAW process is failing because it is not able to open the Logger database.

This is usually caused by a permissions problem.

Check on the user you have on that AW wherever it is still in the domain or not, try updating from another AW.



Hi Sheeraz,

I've seen similar issue in the past and what riccardo has written below is right.

AW's points to Loggers and when we make changes in the configuration manager, AW will go to AD and authenticate the SQL user account and when there is some issue in the communication, it will not allow you to make changes and it will throw the same error which you are getting.

To verify this just got Logger's SQL enterprise Manager -->> expands local -->> goto Security-->> logins-->> check SQL server login-->> try to browse the domain..

Or alternatively try to add new user under login to check if you can successfully add new user?

If you are failing to do the above steps then there is issue in communicating Logger SQL service with AD.

Just check Windows Browser Service in services.msc, If this service is stopped then also you wont able to communicate with AD.

After you can verify the sucessful communication with AD then you can run ICMDBA utility

Attached is the steps to make loggers sync using icmdba

Hope this helps!!

Let us know if you have issues.



PS: Rate the helpful posts

Content for Community-Ad

Spotlight Awards 2021