cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1625
Views
3
Helpful
17
Replies

Jabber Auto Answer & Whisper Greeting Issue with UCCE

westbrook1972
Level 1
Level 1

Hi, 

When a call arrives to an agent, they get an audible 'ping' and then either a whisper message.

Where is the notification generated from and can it be deactivated? Some users are reporting not hearing the notification on every call.

What attributes controls this notification and are there any settings/parameters that can be checked.

1 Accepted Solution

Accepted Solutions

I am guessing you are referring to a tone that agents hear when call is auto answered. If so, then as @bill.king1 stated, you should have auto answer set on CUCM also - "if an agent is set to auto answer in CCE, if you then set them in UCM to be auto answer they'll hear the beep."

Also as @Carlo Poggiarelli suggested, you can adjust tone settings - "You could adjust the duration of notifications as a complete ring by adjusting the Auto Answer Timer in service parameter Callmanager. By default is set to 1 that’s why they hear just a “chime”"

Please check these settings and see if it suffices your requirement.

Thanks.

Piyush

BLOG

 

View solution in original post

17 Replies 17

Hi,

He/She's probably part of a call pickup group that notifies that a call is arriving to a usrer of the same Pickup Group.

Go to the Phone configuration on CUCM Admin Page, than select the associated Directory Number and scroll down and search "Call Pickup Group" and see if he has something selected there.

 

Please let me know

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

westbrook1972
Level 1
Level 1

Thanks Carlo - the call with notification is an agent call via UCCE into Jabber. The  agent is using auto answer and receives a 'chime' noise once the call is presented to the agent.

Hi, so there are a couple different sounds an agent might be configured to hear:
-notification tone from UCM having auto answer
-whisper message played to them configured per call flow in CCE
-agent greeting message (agent records their greeting like "Hi, this is ____, how can I help you?") that is configured per call flow in CCE.
You could potentially be set up to play all 3 on every inbound call, but typically it is the agent greeting and/or whisper.
If agent X report they only get it on certain inbound calls (Sales but not Service say) then you'd need to look at the CCE script to see what is configured to be played as far as whisper/which agent greeting is used.

Thanks for jumping in Bill. Does the UCM auto-answer tone play even if it’s ICM that triggered the auto-answer action via the PG/JTAPI instead of the DN config in UCM?

Yes, if an agent is set to auto answer in CCE, if you then set them in UCM to be auto answer they'll hear the beep. So I'm guessing @westbrook1972 's issue is that the agents don't have all of their needed agent greeting recorded and/or some of the calls they take are not set to use whisper and/or agent greeting for instance.

Ok got it.

This is how it works when auto answer and headset is configured.

You could adjust the duration of notifications as a complete ring by adjusting the Auto Answer Timer in service parameter Callmanager. By default is set to 1 that’s why they hear just a “chime”

 

Please let me know

 

Thanks a lot

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

I’m going to move this thread to the Contact Center board and clarify that this is a UCCE question in the subject. It has additional controls for auto answer, zip tone, agent/whisper greeting that folks monitoring that board are likely to be familiar with.

westbrook1972
Level 1
Level 1

Hi thanks very much for all your responses - where does the notification come from before the call terminates to the agent? we are finding some agents receive the tone whilst others don't. Is this a setting on CUCM? I dont want to change the setting but I am querying why it works for some calls and not for others- all agents set to Auto Answer in Desk setting.

I am guessing you are referring to a tone that agents hear when call is auto answered. If so, then as @bill.king1 stated, you should have auto answer set on CUCM also - "if an agent is set to auto answer in CCE, if you then set them in UCM to be auto answer they'll hear the beep."

Also as @Carlo Poggiarelli suggested, you can adjust tone settings - "You could adjust the duration of notifications as a complete ring by adjusting the Auto Answer Timer in service parameter Callmanager. By default is set to 1 that’s why they hear just a “chime”"

Please check these settings and see if it suffices your requirement.

Thanks.

Piyush

BLOG

 

Hi @Carlo Poggiarelli / @piyush aghera , so you're saying if we changed the Auto Answer Timer under Service Parameters/Cisco Call Manager to say 2, and an agent gets a call and they are set to auto answer in UCM, they'll get the tone/notification for 2 seconds and not the brief one they get today?
I ask because the help for that entry doesn't mention it/describes it differently.
"Auto Answer Timer: Required Field This parameter specifies the seconds to wait before the Cisco IP Phone auto answers an incoming call on an idle line. The value that this parameter specifies should be lesser than the value that is specified in the T301 Timer parameter. If the value in the Auto Answer Timer parameter is greater than the value that is specified in the T301 Timer parameter, the call does not get answered, and the caller receives a busy signal. Setting this value to the higher end of the allowable range could result in calls being rolled to the voice-messaging system, if configured, before the call gets auto answered.
This is a required field.
Default: 1
Minimum: 1
Maximum: 500
Unit: sec"

Hi @bill.king1 

Yes I personally tested it on an UCCE environment and  the behavior with the Timer set to 10  is that  the agent hears silence after the initial beep while the customer hears ringback until it is answered. That's because the agent's phone brings up the line after 1 second (by default) and and agents hear that message until he answers the call. While with that parameter set to 10, the agent has the time to pickup the call without hearing any message.

 

Cheers

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"

Thanks, but I'm asking about the opposite scenario, is there a way to give more of a notification to the agent/user when they answer the call?

Some groups use agent greeting for instance but yet they still say that the agent would like more of a notification when the call arrives (I know, I know). So in their ideal world, these agents being set to auto answer in UCCE, call arrives, they hear more than the brief notification that happens today when the phone is set to auto answer, say 1-2 seconds of beeping/zip tone, then their agent greeting. I remember Tone on Connect in UCM was something that was explored but it had some limitations, not sure if that has changed.

westbrook1972
Level 1
Level 1

@Carlo Poggiarelli  Thanks for your response. Do you know where the chime/beep actually comes from? What part of UCM will generate that specific notification to an agent? On wireshark traces to the agent PC we can see the whisper RTP stream from VVB but the beep tone is not captured as part of that flow. If so, where does it come from as its not being captured in any wireshark captures to the agent, from what I can see.

Hi @westbrook1972 ,

That tone should be sent by the PG that notifies the call while the message is “played” during the time that the “auto answer “ takes  place and the call is connected to the agent.

 

HTH

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"