cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3619
Views
4
Helpful
11
Replies
Highlighted
Beginner

UCCE Finesse 10.0 - 3rdpartygadget Error 404

Hi D.Lender / All,

In Finesse 10.0 (UCCE), i have configured a Screenpop xml under 3rdpartygadget. But when rendering it shows HTTP error 404. When I checked the 3rdpartygadget/files, gadget xml is available on Finesse server.

URL Configured in cfadmin is as follows,

<tab>

            <id>screenpop</id>

            <label>Screenpop</label>

            <gadgets>

              <gadget>/3rdpartygadget/files/ScreenPop/ScreenPop.xml</gadget>

            </gadgets>

          </tab>

Below screen shows that screenpop gadget that has been hosted under 3rdpartygadget.

But still shows 404 rendering issue in Finesse10(UCCE).

Note: I have working knowledge on Finesse 9 and Finesse 10 (UCCX) prior to this Finesse(10) UCCE.

Let me know, if there are any configuration to make it works.

Thanks,

DanielInbaraj J.

Everyone's tags (3)
11 REPLIES 11
Highlighted
Frequent Contributor

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

Try specifying the full ip address of the gadget files.

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

I tried with full address and got the following error. Our finesse application is hosted under https. Following is the error screen,

javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated.

Highlighted
Frequent Contributor

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

I have deleted my last 2 responses as they are not correct. You should not use the full path.  Also note that even though your Finesse agent desktop is using https, gadgets that reside on the Finesse server use http since the gadget is on the same server as Finesse so there is no security issue.

Here is the recommendation for getting out of the problem:

1) Make sure the Gadget is deployed to both Finesse Servers (or at least the one that you are trying to access)

2) Revert the Desktop layout to load using relative path (/3rdpartygadgets/files/ScreenPop/ScreenPop.xml)

3) Try to load the Gadget XML into a browser directly by using the full URL (using your example): http://172.16.6.180:8080/3rdpartygadget/files/ScreenPop/ScreenPop.xml

…if the above works you will see the contents of the gadget in your browser.  This proves it is deployed properly.

4) Restart “Cisco Tomcat” on the target server to clear the gadget cache.

That should clear things up.

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

I had a similar problem which was remedied by giving permissions to the gadget's files

chmod 644 <gadget name>

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

We are facing the exact same symptoms, and chmod and using relative path/restart havent made a difference.

Accessing (or trying to access) the gadget XML file directly as below, also shows the 404 error:

http://172.16.6.180:8080/3rdpartygadget/files/ScreenPop/ScreenPop.xml

This would indicate that tomcat is unable to serve/locate the content at the path - however gadget files are visible at the target location and have 644/777 permissions.  Is there a need to "activate" the content deployed within the 3rdpartygadget folder?

Highlighted
Enthusiast

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

I realize this is an old thread but was this ever resolved?

I am facing the exact same error and am looking for a solution.

Highlighted
Frequent Contributor

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

I believe this was a problem with a firewall between Finesse and the gadget server.

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

This sounds like you followed Cisco's instructions and uploaded the .xml and .js files to Finesse Publisher but your Agent desktop is instead trying to parse them on a Subscriber. (even if the URL points to the publisher). Try turning off all subs before loading the report.

Or you can try uploading the gadgets to each of the Finesse servers manually (something that will have to be done anyhow)

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

This issue was resolved for me, once I restart the finesse server. Sorry for providing the late response.

Thanks,

Daniel Inbaraj

Highlighted
Beginner

Re: UCCE Finesse 10.0 - 3rdpartygadget Error 404

Yes, everytime you upload your Gadget, you need to reload the finesse page. As I understand it, the finesse gadget is loaded during login process and is not updated whenever you upload or replace the files.