cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
418
Views
10
Helpful
6
Replies
Highlighted

UCCX CUIC Timezone not updating Daylight

Hi 

I have a uccx set up for one of my customers. We are using UCCX 12 and CUIC co-existence with it. the UCCX has the BST, but when the user runs the report, their reports don't reflect the DST. 

 

UCCX time zone configured as BST. 

admin: show timezone config
Current timezone: British Summer Time (Europe/London)
Timezone version: 2018c

 

the user time zone is Europe/London. I tried to change here BST and GMT+1 but no luck. 

 

Can anyone point me in the right direction to check it? 

 

note: another thing which I noticed is that under system parameter configuration, the time zone as GMT. i am not sure is it expected to like this or not?

System Time Zone*Greenwich Mean Time

 

Regards, 

Shalid 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

You might need to update your timezone data file, as I see you are on 2018c, and there are 2019 files available.

https://software.cisco.com/download/home/286323009/type/286315794/release/MultipleRelease_Cops

View solution in original post

6 REPLIES 6
Highlighted
VIP Mentor

I'm not the best with CUIC, but I do know that all records in UCCX/CUIC are in GMT. That's how they are stored. They get converted to a timezone offset during a retrevial like running a CUIC report. The timezone the report is in, is based on the CUIC User settings. So, in CUIC go to Security > Users > Find the User > Edit > Timezone and see what the timezone is. If it's correct in terms of what it should be set to, but the report is still wrong, then I'd guess you hit a defect.

Highlighted
Participant

If you are using NTP, the system will run on UTC (Universal Coordinated Time).  If your location is in a time zone that observes daylight saving time, then you will need to configure your timezone to the correct one in the timezone list.

I believe you are looking for:  375 - Europe/London  (which observes daylight saving time).

From the CLI of the primary/publisher:

show timezone config - to view the currently configured timezone

show timezone list - to view the list of available time zones

set timezone 375 - to set server timezone to Europe/London  (depending upon what version you are running, you may or may not have to restart your server - [during maintenance window!!]  utils system restart - yes  )

 

Hope this helps.

-Sean

Highlighted

Thanks Both.

 

I had tried the way where Anthony mentioned but no luck. 

 

Verified the time zone configured in the system is BST. 

 

admin:show timezone config
Current timezone: British Summer Time (Europe/London)
Timezone version: 2018c

 

Regards, 

Highlighted
VIP Mentor

You might need to update your timezone data file, as I see you are on 2018c, and there are 2019 files available.

https://software.cisco.com/download/home/286323009/type/286315794/release/MultipleRelease_Cops

View solution in original post

Highlighted

Thanks,. it was the case. I re-assured with Cisco. Issue resolved.
Thanks all for your valuable input.
Highlighted

Thanks for letting the all of us know what the solution was.