cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6380
Views
0
Helpful
16
Replies
panjwani80
Contributor

UCCX script editor 8.5.1 Java error

Hi,

UCCX Script editor 8.5.1 was working fine but after the window 7 laptop reboot (I believe it updated Java version) script editor just doesn't work. I can log in ok but when I click on file-open it comes up with error message: Failed to load script file; java.lang.RuntimeException:java.io.IOException: Could not get shell folder ID list.

It works fine on other laptops. I have tried installing/uninstalling different versions of Java and UCCX script editor several times but no joy.

When I compared the working script editor with the problem one I noticed that following 5 folders are missing all together from within wfavvid folder, C:\Program Files\wfavvid_851

  1. Documents
  2. Grammers
  3. JdbcDrivers
  4. log
  5. Prompts

Any help would be much appreciated

Thanks

Aamir

16 REPLIES 16
Anthony Holloway
Cisco Employee

panjwani80 wrote:

Any help would be much appreciated

Whenever I face a software problem, just like this one, I do these things, in this order to troubleshoot:

  1. Reboot
  2. Uninstall the application from add/remove programs
  3. Delete the folders and files on disk manually which the uninstaller leaves behind (I believe they do this so when you reinstall it can remember a few of your settings and make it easier on you, however, that's just a guess)
  4. Delete the registry keys associated to this program (I know for most people this can be scary, but hey, 60% of the time, this works 100% of the time for me)
  5. Reboot
  6. Download a fresh installer file
  7. Install
  8. Reboot
  9. Try again

It's a long process, but it has worked for me so many times.  Good luck.

Alos, I'm pretty sure the CRS Editor comes with it's on Java and does not look at what you have installed on the machine.

My Reference:

#cd

C:\Program Files\wfavvid_851\java\bin

#java -version

java version "1.6.0_13"

Java(TM) SE Runtime Environment (build 1.6.0_13-b03)

Java HotSpot(TM) Client VM (build 11.3-b02, mixed mode)

#cd \

#cd

C:\

#java -version

java version "1.6.0_30"

Java(TM) SE Runtime Environment (build 1.6.0_30-b12)

Java HotSpot(TM) Client VM (build 20.5-b03, mixed mode, sharing)

#

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

I have gone through ALL the steps recommended by Anthony including manually deleting the wfavvid folder and all the associated reg keys. I still don't see those 5 folders as mentioned in my original post. I noticed that when I attempted to login after all the steps, script editor still remembered by user id and server ip address so it appears that some of the reg keys may not have been deleted.

I have downloaded editor from 8.5.1SU3 and all scripts I am trying to open have been written in the same version. (Actually I don't even get to the stage of opening script. As soon as I click "open" icon on the top toolbar it comes up with the error message)

Thanks

Chris Deren
Hall of Fame Master

What version is your editor?  The editor changed in version 8.5.1SU3 and if you are trying to open scripts developed on that version with previous version editor you will run into the same error.  I know because I did and after uninstalling and reinstalling SU3 version editor all was well.

HTH,

Chris

Awe yeah!

6. Download a fresh installer file

My process is long, but step six would have saved this man.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Hi Chris,

Are you saying if we develop the script using v8.5.1 then upgrade to SU3, the old scripts will no longer work?

Thanks!

-JT-

No, scripts work fine, what i am saying is that there were some changes in script editor in version 8.5.1SU3 that have to do with the java steps where you need to use the exact script editor to open the scripts built in that version.

Chris

Has anyone had any luck with this issue? I'm still fighting the same thing after following Anthony's suggestions. 8.5.1SU3

I have seen the 8.5.X script editor be rather fussy on Windows 7. In particular, it seems to need admin privileges to add a new server even though the application doesn't explicitly ask for it. If I am going to connect to a new server in the editor, I will run the script editor as administrator and then it seems happier. Have you tried that?

I gave that a try with same result. It will work on WinXP. Just won't go on Windows 7.

Have you tried setting the shortcut for XP compatibility mode?

No luck. Slightly different java error (java.lang.arrayindexoutofboundsexception:3184).

asiddhu
Beginner

Hi

if i understand correct , when you go and try to load a script via open menu , you get the error , am i right ?

i will recommend , just turn off the Windows Firewall or any type of antivirus , and i guess your issue should be fixed.

Firewall is disabled. Turned off antivirus and tested with same results.

Hi Brad,

ok,

can you try the following as well

go into the registry and go to

HLMC\Software\Microsoft\Windows\CurrentVersion\Uninstall

and them delete the folder for the Cisco Unified CCX Editor

after that please try to uninstall the CCX editor and install it back ,

to me this looks like a  Windows machine issue , if other can access the script repository , that means UCCX is fine.

Content for Community-Ad

Spotlight Awards 2021