cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1620
Views
20
Helpful
24
Replies
Highlighted
Frequent Contributor

CUCM Translation issues

I have a PRI on the router that is configured and it is up.  I setup everything in CUCM like a few other sites we have.  Hooked up a phone and they are able to make outbound calls.  I can also reach that phone via extension.

But when I try to call the masked number I get, "Call cannot be completed as dialed ...........".  When that phone calls me I can see the outbound number though.  What might be missing here that I can't call the external number.  I have tried on the router:

debug isdn q931 and 921 but I don't even see the call from my cell hit that router.

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Hi,

Are you aware of the DDI allocation associated with the bearer? As the first post indicated it would seem that the telco has not brought the DDIs into service if your dialling what you expect to be a valid DDI yet it does not hit the gateway. When you dial external do you see the Calling Party on the called party, and is this the mask you are attempting to call back in with? The fact that you don't see any debug when calling in with that number would lead me to investigate the issue with the Telco.

Incidentally there are two T1s indicated in the config, are both of these back-hauled and registered with CUCM? Also do they both carry the same DDIs? If both are registered, then the controller should be configured correctly and you would see the incoming call on either.

Regards
Allan

Sent from Cisco Technical Support iPad App

View solution in original post

Highlighted

Mohammed,

Your best bet is to turn on debug isdn q931 as you rightly said. Ensure that while using telnet that you have "term mon" enabled on the gateway. Also ensure that your gateway is not configured to send debugs to the router's buffer. If it is you can use gthe command "show logging" to see the logs..

If the call comes to your router, then you must see the logs on debug isdn q931...

If after you have done all this and you still dont see the call coming in to the gateway then you need to speak to your telco. Its either the DDI is invalid or your DDI range has not been properly provisioned

Please rate all useful posts

View solution in original post

Highlighted
Hall of Fame Cisco Employee

Call your telco and ask them to ID the exact PRI where they're sending the call to.
If you don't see anything on the debug for inbound calls, but see debugging for outbound calls, telco is not delivering calls to that PRI.

Nothing you can do if thats the case, except call telco to correct this on their end.

Sent from Cisco Technical Support iPad App

HTH

java

if this helps, please rate

View solution in original post

24 REPLIES 24
Highlighted
Rising star

Hi Mohammad,

What are you running MGCP, SIp or H323?

Let me clear if I understood corectly, when you call the T1 pilot number, the call is not received throught the router? If that is the case maybe the problem is at your Telco.

If the call is answered by the router, the translation pattern you have made is wrong and that's why is not hitting the phone. Please attach a show run.

Please remember to rate useful posts clicking on the stars below.
Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie
Highlighted

We are doing mgcp.  And debug isdn q931 doesn't show any calls from outside hitting the router.  Here is the voice related config.

card type t1 0 0   

card type t1 0 1   

no network-clock-participate wic 0    

network-clock-participate wic 1    

!   

no ip source-route   

ip cef   

!   

!   

!   

!   

!   

!   

ip flow-cache timeout active 1   

no ip domain lookup   

ip name-server 10.202.100.5   

ip name-server 10.206.100.5   

ipv6 spd queue min-threshold 62   

ipv6 spd queue max-threshold 63   

no ipv6 cef   

!   

multilink bundle-name authenticated   

!   

!   

!   

!   

isdn switch-type primary-4ess   

!   

!   

      quit

voice-card 0   

dsp services dspfarm   

!   

application   

global   

  service alternate default   

!   

!   

hw-module pvdm 0/0   

!   

hw-module pvdm 0/1   

!   

!   

!   

archive   

path flash:/archive_config   

maximum 7   

time-period 10080   

!   

redundancy   

!   

!   

!   

!   

!   

controller T1 0/0/0   

cablelength long 0db   

channel-group 0 timeslots 1-24   

!   

controller T1 0/0/1   

cablelength long 0db   

!   

controller T1 0/1/0   

cablelength long 0db   

channel-group 0 timeslots 1-24   

!   

controller T1 0/1/1   

cablelength long 0db   

pri-group timeslots 1-24 service mgcp   

!   

ip tcp selective-ack   

ip tcp path-mtu-discovery   

ip telnet source-interface Loopback0   

ip ftp source-interface Loopback0   

ip tftp source-interface Loopback0   

ip ssh source-interface Loopback0   

ip ssh logging events   

ip ssh version 2   

!   

track 1 ip route 192.168.253.28 255.255.255.252 reachability   

!   

class-map match-any COS-3_cm   

match protocol snmp   

match protocol dns   

match protocol ntp   

match protocol pcanywhere   

match protocol RADIUS   

match protocol TACACS   

" match protocol http host ""\.XXXX\.com$"""   

" match protocol http host ""\.XXX\.com$"""   

" match protocol http host ""^\w*-\w*-\d*$"""   

" match protocol http host ""^\w*\d*\w*\d*$"""   

" match protocol http host ""^\w*\d*$"""   

" match protocol http host ""^\w*\d*\w*"""   

" match protocol http host ""^\w*$"""   

" match protocol http host ""^10\."""   

" match protocol http host ""^172\.(1[6-9]|2[0-9]|3[0-1])\."""   

" match protocol http host ""^192\.168\."""   

match access-group name COS-3_acl   

class-map match-any COS-2_cm   

match ip dscp af31    

match ip dscp cs3    

match protocol bgp   

match protocol telnet   

match protocol ssh   

match protocol skinny   

match protocol mgcp   

match protocol sip   

match protocol citrix   

match protocol xwindows   

match protocol AS400   

match protocol RF_Guns   

match protocol printer   

match access-group name COS-2_acl   

class-map match-any COS-1_cm   

match dscp ef    

match protocol rtp   

class-map match-any COS-4_cm   

match protocol exchange   

match protocol kerberos   

match protocol gre   

match access-group name COS-4_acl   

class-map match-any Blocked-Traffic   

match protocol cuseeme   

match protocol edonkey   

match protocol fasttrack   

match protocol gnutella   

match protocol kazaa2   

match protocol streamwork   

match protocol winmx   

match protocol vdolive   

match protocol irc   

match protocol secure-irc   

class-map match-any BGP   

match protocol bgp   

!   

policy-map ReMark-BGP   

class BGP   

  set ip dscp cs6   

policy-map XXX-QOS-Policy   

class COS-1_cm   

  priority percent 60   

  set ip dscp ef   

class COS-2_cm   

  bandwidth remaining percent 55    

  set ip dscp af31   

   service-policy ReMark-BGP   

class COS-3_cm   

  bandwidth remaining percent 30    

  set ip dscp af21   

class COS-4_cm   

  bandwidth remaining percent 10    

  set ip dscp default   

class Blocked-Traffic   

  drop   

class class-default   

  fair-queue   

  set ip dscp af11   

!   

!    

!   

!   

!   

!   

!   

!   

!   

!   

interface Loopback0   

ip address 172.16.14.209 255.255.255.255   

no ip redirects   

no ip proxy-arp   

!   

interface Port-channel1   

no ip address   

!   

interface Port-channel1.1   

description Management VLAN   

encapsulation dot1Q 1 native   

ip address 10.141.104.2 255.255.255.0   

standby 1 ip 10.141.104.1   

standby 1 priority 250   

standby 1 preempt   

standby 1 track 1 decrement 6   

!   

interface Port-channel1.20   

description Phone VLAN   

encapsulation dot1Q 20   

ip address 10.141.105.2 255.255.255.0   

standby 20 ip 10.141.105.1   

standby 20 priority 250   

standby 20 preempt   

standby 20 track 1 decrement 6   

!   

interface Port-channel1.40   

description End User VLAN   

encapsulation dot1Q 40   

ip address 10.141.108.2 255.255.254.0   

standby 40 ip 10.141.108.1   

standby 40 priority 250   

standby 40 preempt   

standby 40 track 1 decrement 6   

!   

interface Port-channel1.60   

description RF Gun VLAN   

encapsulation dot1Q 60   

ip address 10.141.106.2 255.255.255.0   

standby 60 ip 10.141.106.1   

standby 60 priority 250   

standby 60 preempt   

standby 60 track 1 decrement 6   

!   

interface Multilink1   

description ATT MLPPP AVPN   

bandwidth 1544   

ip address 192.168.253.29 255.255.255.252   

ip flow ingress   

ppp multilink   

ppp multilink group 1   

service-policy output XXX-QOS-Policy   

!   

interface Embedded-Service-Engine0/0   

no ip address   

shutdown   

!   

interface GigabitEthernet0/0   

description MEMBER OF PO1   

no ip address   

duplex auto   

speed auto   

channel-group 1   

!   

interface GigabitEthernet0/1   

description MEMBER OF PO1   

no ip address   

duplex auto   

speed auto   

channel-group 1   

!   

interface GigabitEthernet0/2   

no ip address   

shutdown   

duplex auto   

speed auto   

!   

interface Serial0/0/0:0   

no ip address   

encapsulation ppp   

ppp multilink   

ppp multilink group 1   

!   

interface Serial0/1/0:0   

no ip address   

encapsulation ppp   

ppp multilink   

ppp multilink group 1   

!   

interface Serial0/1/1:23   

no ip address   

encapsulation hdlc   

isdn switch-type primary-ni   

isdn incoming-voice voice   

isdn bind-l3 ccm-manager   

no cdp enable   

!   

!   

ip forward-protocol nd   

!   

!   

ip route 172.16.14.210 255.255.255.255 10.141.104.3   

ip tacacs source-interface Loopback0   

!   

!   

!   

!   

control-plane   

!   

!   

voice-port 0/1/1:23   

!   

voice-port 0/2/0   

timing hookflash-out 50   

timing guard-out 1000   

!   

voice-port 0/2/1   

timing hookflash-out 50   

timing guard-out 1000   

!   

!   

!   

!   

ccm-manager fallback-mgcp    

ccm-manager redundant-host 10.202.110.36 10.208.110.20   

ccm-manager mgcp   

no ccm-manager fax protocol cisco   

ccm-manager music-on-hold   

ccm-manager config server 10.202.110.36 10.206.110.20    

ccm-manager config   

!   

mgcp   

mgcp call-agent 10.206.110.20 2427 service-type mgcp version 0.1   

mgcp dtmf-relay voip codec all mode out-of-band   

mgcp rtp unreachable timeout 1000 action notify   

mgcp modem passthrough voip mode nse   

mgcp package-capability rtp-package   

mgcp package-capability sst-package   

mgcp package-capability pre-package   

no mgcp package-capability res-package   

no mgcp package-capability fxr-package   

no mgcp timer receive-rtcp   

mgcp sdp simple   

mgcp fax t38 inhibit   

mgcp rtp payload-type g726r16 static   

mgcp bind control source-interface Loopback0   

mgcp bind media source-interface Loopback0   

!   

mgcp profile default   

!   

sccp local Loopback0   

sccp ccm 10.206.110.20 identifier 2 priority 2 version 4.1    

sccp ccm 10.202.110.36 identifier 1 priority 1 version 4.1    

sccp   

!   

sccp ccm group 1   

description DSP Farm Resources For Local Phones   

associate ccm 1 priority 1   

associate ccm 2 priority 2   

associate profile 1 register XXX-Tran   

associate profile 2 register XXX-Conf   

associate profile 3 register XXX-MTP   

switchback method graceful   

!   

dspfarm profile 1 transcode     

codec g729abr8   

codec g729ar8   

codec g711alaw   

codec g711ulaw   

maximum sessions 2   

associate application SCCP   

!   

dspfarm profile 2 conference     

codec g729br8   

codec g729r8   

codec g729abr8   

codec g729ar8   

codec g711alaw   

codec g711ulaw   

maximum sessions 8   

associate application SCCP   

!   

dspfarm profile 3 mtp     

codec g711ulaw   

maximum sessions software 10   

associate application SCCP   

!   

dial-peer voice 999020 pots   

service mgcpapp   

port 0/2/0   

!   

dial-peer voice 999021 pots   

service mgcpapp   

port 0/2/1   

!   

!   

gateway    

timer receive-rtp 1200   

!   

!   

!   

gatekeeper   

shutdown   

!   

!   

call-manager-fallback   

max-conferences 4 gain -6   

transfer-system full-consult   

ip source-address 172.16.14.209 port 2000   

max-ephones 24   

max-dn 48   

!   

!   

Highlighted

Hi,

Are you aware of the DDI allocation associated with the bearer? As the first post indicated it would seem that the telco has not brought the DDIs into service if your dialling what you expect to be a valid DDI yet it does not hit the gateway. When you dial external do you see the Calling Party on the called party, and is this the mask you are attempting to call back in with? The fact that you don't see any debug when calling in with that number would lead me to investigate the issue with the Telco.

Incidentally there are two T1s indicated in the config, are both of these back-hauled and registered with CUCM? Also do they both carry the same DDIs? If both are registered, then the controller should be configured correctly and you would see the incoming call on either.

Regards
Allan

Sent from Cisco Technical Support iPad App

View solution in original post

Highlighted

Allan thanks for the reply, only the PRI beign utilized for the Voice and is backhauled to the CUCM. 

Leo thank you for the reply as well, so is there a way for me to see if the call is hitting the CUCM?  I have reached out to telco too.  Now when I turned it up they metioned that this is a Local PRI.  Would that require a different config?

Highlighted

Hi,

No problem can you post the output from the 'show ccm-manager', this will indicate the registration status of each configured end-point in Communications Manager for that gateway. If you have enabled debug and turned monitor on, I would expect you to see output as calls externally appear to routed Offnet successfully. Just to be certain, there is no other way for an external call to be routed on-net to another PTSN gateway, this is the only outbound gateway for this site?

If outbound is successful, then inbound calls should hit the gateway, even if the gateway has an incorrect CSS, the call would show as unallocated and return fast busy.

Regards
Allan
Sent from Cisco Technical Support iPad App

Highlighted

@Mohammad ,

if you are running MGCP remember Q.931 is managed by CUCM so I think that's why you're not receiving the call signaling (I don't remember for sure right now ).

The prompt you received "Call cannot be completed as dialed..." is from CUCM so the call has been received. The problem it's maybe because the DID received by the TELCO is not matching the translation pattern created in CUCM.

Ask the Telco which DID number they're sending on the call, then match that number creating a translation pattern to the destination DN.

Please remember to rate useful posts clicking on the stars below.
Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie
Highlighted

There are 4 T1s there, 2 data, one with no config, and one for voice.

Yes, Q931 info is managed by CUCM, but you should still see output from a debug ISDN Q931.

The message "your call cannot..." is definitely CUCM.

I would suspect you are matching something, but there's a CSS problem.

If you don't match anything, you do not hear CUCM, you send a reason code of unallocated number back to the PSTN.

Are you 100% sure of the call flow and the PRI on which you expect the call????

Provide a sh diag from the ISR

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate
Highlighted

Mohammed,

Your best bet is to turn on debug isdn q931 as you rightly said. Ensure that while using telnet that you have "term mon" enabled on the gateway. Also ensure that your gateway is not configured to send debugs to the router's buffer. If it is you can use gthe command "show logging" to see the logs..

If the call comes to your router, then you must see the logs on debug isdn q931...

If after you have done all this and you still dont see the call coming in to the gateway then you need to speak to your telco. Its either the DDI is invalid or your DDI range has not been properly provisioned

Please rate all useful posts

View solution in original post

Highlighted

Thanks y'all for your help here are the answers to all the questions:

Output from the 'show ccm-manager'

Priority        Status                   Host

============================================================

Primary         Registered               10.202.110.36

First Backup    Backup Ready             10.206.110.20

Second Backup   None

Current active Call Manager:    10.202.110.36

Backhaul/Redundant link port:   2428

Failover Interval:              30 seconds

Keepalive Interval:             15 seconds

Last keepalive sent:            21:07:09 DST Oct 31 2013 (elapsed time: 00:00:07)

Last MGCP traffic time:         21:07:09 DST Oct 31 2013 (elapsed time: 00:00:07)

Last failover time:             None

Last switchback time:           None

Switchback mode:                Graceful

MGCP Fallback mode:             Enabled/OFF

Last MGCP Fallback start time:  None

Last MGCP Fallback end time:    None

MGCP Download Tones:            Disabled

TFTP retry count to shut Ports: 2

If you have enabled debug and turned monitor on, I would expect you to see output as calls externally appear to routed Offnet successfully. Just to be certain, there is no other way for an external call to be routed on-net to another PTSN gateway, this is the only outbound gateway for this site?

**** Yes this is the only gateway for this site in CUCM I see it registered too

If outbound is successful, then inbound calls should hit the gateway, even if the gateway has an incorrect CSS, the call would show as unallocated and return fast busy.

**** Inbound calls to the DID don't even show hitting the router at all

There are 4 T1s there, 2 data, one with no config, and one for voice.

**** We only have a single PRI and a Data T1 at this site

Yes, Q931 info is managed by CUCM, but you should still see output from a debug ISDN Q931.

**** No when I call the DID I do not see anything in the debug

The message "your call cannot..." is definitely CUCM.

I would suspect you are matching something, but there's a CSS problem.

If you don't match anything, you do not hear CUCM, you send a reason code of unallocated number back to the PSTN.

**** Can you please elaborate I'm new to voice this is the firs time touching it.  Even if there is a CSS problem I should still see the call hit the router.

Are you 100% sure of the call flow and the PRI on which you expect the call????

**** There is only one PRI and per telco it is a Local PRI and DID's should be hitting that PRI from what my understanding is.

Your best bet is to turn on debug isdn q931 as you rightly said. Ensure that while using telnet that you have "term mon" enabled on the gateway. Also ensure that your gateway is not configured to send debugs to the router's buffer. If it is you can use gthe command "show logging" to see the logs..

If the call comes to your router, then you must see the logs on debug isdn q931...

If after you have done all this and you still dont see the call coming in to the gateway then you need to speak to your telco. Its either the DDI is invalid or your DDI range has not been properly provisioned

**** Already done this, I just don't see the call hitting the router when I call the DID, I tried to map couple of DID's to one of the extensions and same results.

Highlighted
Hall of Fame Cisco Employee

Call your telco and ask them to ID the exact PRI where they're sending the call to.
If you don't see anything on the debug for inbound calls, but see debugging for outbound calls, telco is not delivering calls to that PRI.

Nothing you can do if thats the case, except call telco to correct this on their end.

Sent from Cisco Technical Support iPad App

HTH

java

if this helps, please rate

View solution in original post

Highlighted

Hi M. Ali,

Check that you configuredd the CSS for inbound calls in Gateway PRI interface configured in CUCM

Regards

Selvarathnam

Highlighted

Yes Under Call Routing --> Class of Controll --> CSS I have created an inbound CSS and then added the inbound Partition to it.

I just created a ticket with our Telco as well.

Highlighted

Wow I create a ticket with ATT to check the DID's if they are provisioned for the right PRI and they send me an automated email in like 2 min closing the ticket telling me that PRI is up really?

Highlighted

Hi Mohammad,

Please use the command: debug isdn 931. We have to know what DID number is sent by the Telco.

Regards

Please remember to rate useful posts clicking on the stars below.
Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie
Content for Community-Ad