cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2193
Views
0
Helpful
4
Replies

%FLEXDSPRM-3-TDM_CONNECT: failed to connect voice-port (0/1/1) to dsp_channel(1/0/2)

O.Zang
Beginner
Beginner

Dear Experts,

 

I have 2 E1.
Here his the diagram that i am using:

CUCM => H323 Gateway => E1=> sumsung OfficeServ PBX.

Diagram for incomming calls:

PSTN => E1=> H323 Gateway => E1=> sumsung OfficeServ PBX.

A caller call from the PSTN an internal phone, the internal phone ring. But when the user pick up the phone, we hear a busy tone and the error message below is show on the console.

%FLEXDSPRM-3-TDM_CONNECT: failed to connect voice-port (0/1/1) to dsp_channel(1/0/2.


After look it at bugg: CSCvg29183, i tried Fuji-16.8.1, Denali-16.3.6 but I have the same problem.

2 Accepted Solutions

Accepted Solutions

Maren Mahoney
VIP Advocate VIP Advocate
VIP Advocate

This behavior (ring, then disconnect on pickup) is often a codec-mismatch issue. If the call is coming in G711alaw over the E1, and the router/CUCM are negotiating G711ulaw then a trans-compander is needed on the router in the form of a transcoder. The software MTPs in CUCM can also do the recompanding, but that would require that CUCM be aware of the need to do so, which I don't believe is happening in your current config.

If it won't mess up other things in your system, the simple answer would be to change your 'voice class codec 1' to prefer g711alaw over ulaw (and all of Cisco's phones support alaw as far as I know), and make sure that the H323 gateway configured in CUCM has MRG/MRGL access to CUCM's software MTP in the event it's asked to send that call to a G711ulaw-only device.

HTH. Let us know how it goes.

View solution in original post

Hello ,

Maren and Jan, Thanks for your help.

After troublesooting this was due to the IPBX of the customer.

It's E1 was by default configure as switch type primary-net5 because of that i had configure the gateway's E1 to that same switch type.

I just change It to primary-qsig. and i also did the same thing on the gateway's E1.

It's working fine now.

Thanks for your help

Regards,

Zanga

View solution in original post

4 Replies 4

O.Zang
Beginner
Beginner

Hello Team:

Below is the sh run:

boot-start-marker
boot system flash bootflash:isr4300-universalk9.16.06.03.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
card type e1 0 1

!
no aaa new-model
!
no ip domain lookup

!
!
!
!
!
!
!
!
!
!
subscriber templating
!
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
!
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
no call service stop
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
!
!
!
!
!
!
voice-card 0/1
no watchdog
!
license udi pid ISR4321/K9 sn FDO22432NBH
diagnostic bootup level minimal
spanning-tree extend system-id
!
!
!

!
redundancy
mode none
!
controller E1 0/1/0
framing no-crc4
clock source line primary
pri-group timeslots 1-31
description "connected to TELCO"
!
controller E1 0/1/1
framing no-crc4
pri-group timeslots 1-31
description "connected to IPBX"
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address
negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface Service-Engine0/1/0
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn protocol-emulate network
isdn incoming-voice voice
!
interface Serial0/1/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route
!
ip ssh version 2
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0:15
bearer-cap Speech
!
voice-port 0/1/1:15
timing delay-connect 20
bearer-cap Speech
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
destination-pattern [1500-1520]
session target ipv4:CUCM-IP
voice-class codec 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 1000 pots
description "MOBILE CALLS"
preference 1
destination-pattern [045678].......$
port 0/1/0:15
forward-digits all
!
dial-peer voice 1001 pots
description "LANDLINES CALLS"
destination-pattern [23]T
port 0/1/0:15
forward-digits all
!
dial-peer voice 1002 pots
destination-pattern 245074[50-99]
incoming called-number .
port 0/1/0:15
forward-digits all
!
dial-peer voice 1010 pots
destination-pattern [1000-1400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 1030 pots
destination-pattern [3000-3400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 1020 pots
destination-pattern [2000-2400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 1040 pots
destination-pattern [4000-4400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 1050 pots
destination-pattern [5000-5400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 1060 pots
destination-pattern [6000-6400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 1070 pots
destination-pattern [7000-7400]
incoming called-number .
port 0/1/1:15
forward-digits all
!
dial-peer voice 100 voip
destination-pattern 5555
session target ipv4:
voice-class codec 1
dtmf-relay h245-alphanumeric
no vad
!

j.huizinga
Frequent Contributor
Frequent Contributor

This is an ISR router

So first make sure that you have DSP's on the NIM card

And under E1 config put the command: pri-group timeslots 1-31 voice-dsp

Jan

 

Maren Mahoney
VIP Advocate VIP Advocate
VIP Advocate

This behavior (ring, then disconnect on pickup) is often a codec-mismatch issue. If the call is coming in G711alaw over the E1, and the router/CUCM are negotiating G711ulaw then a trans-compander is needed on the router in the form of a transcoder. The software MTPs in CUCM can also do the recompanding, but that would require that CUCM be aware of the need to do so, which I don't believe is happening in your current config.

If it won't mess up other things in your system, the simple answer would be to change your 'voice class codec 1' to prefer g711alaw over ulaw (and all of Cisco's phones support alaw as far as I know), and make sure that the H323 gateway configured in CUCM has MRG/MRGL access to CUCM's software MTP in the event it's asked to send that call to a G711ulaw-only device.

HTH. Let us know how it goes.

Hello ,

Maren and Jan, Thanks for your help.

After troublesooting this was due to the IPBX of the customer.

It's E1 was by default configure as switch type primary-net5 because of that i had configure the gateway's E1 to that same switch type.

I just change It to primary-qsig. and i also did the same thing on the gateway's E1.

It's working fine now.

Thanks for your help

Regards,

Zanga

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers