cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
101609
Views
106
Helpful
18
Replies
paul.omahony
Beginner

SIP/2.0 503 Service Unavailable

Hi

I'm trying to set-up a click to dial service using JTAPI, I don't know where this problem is coming from as I'm new to CUCM can anyone tell me what the problem might be? Here's the error I got from the servlet log:

SIP/2.0 503 Service Unavailable

Date: Wed, 30 Sep 2009 19:59:36 GMT

Warning: 399 "Unable to find a device handler for the request received on port 5060 from 10.36.134.137"

From: Click-to-Dial<sip:2003@10.36.134.137:5060>;tag=1

Content-Length: 0

To: <sip:2003@10.36.134.124:5060>;tag=1181960151

Contact: <sip:2003@10.36.134.124:5060;transport=tcp>

Call-ID: 1254223590633-0006@10.36.134.137

Via: SIP/2.0/TCP 10.36.134.137:5060

CSeq: 1 REFER

I'd appreciate any help.

Cheers

18 REPLIES 18
comsameer
Beginner

I ma getting the same Error message. If you can get the solution for it please reply on my e-mail.

amitpatel711@gmail.com

Thanks.

Hi,

For information, i had the same error because the domain on the invite was not configured in the Call Manager / Entreprise Parameters > Organization Top Level Domain & Cluster Fully Qualified Domain Name

If it can help you

Best regards

Matthieu

Hi folks,

Am facing the same issue. Unable to trace the root cause. Can someone help to trace the problem.

Am having contact center environment where Inbound calls to Agents coming from PSTN are getting into RESERVED state on Cisco Finesse desktop. After tracing, found SIP 503, Service Unavailable on CUCM and VG logs. Also, I see error "Unable to find a device handler for the request received on port 8317 from 192.168.4.12 (CVP)" on CUCM Logs.

My lab environment contains ICM Sprawler, CVP, Finesse and VG with 1E1 interface.

On ICM, call hits and remains in Queue to SG Node. Call doesnot move from Success or failure node.

Attached CUCM and ICM logs. VG Config attached reference.

*** Please rate helpful post. Please mark as answer if it solves your problem/query.
regards, Ritesh Desai

Thanks for taking above too read. Issue is been resolved. In contact center scenario, SIP trunk between CVP and CUCM was missing.

regards,

Ritesh Desai.

*** Please rate helpful post. Please mark as answer if it solves your problem/query.
regards, Ritesh Desai

Hi,

I had the same issue as you.

error 503 with warning like this :

Warning: 399 Server name "Unable to find a device handler for the request received on port 

The issue come from on my gateway i have "server-group"  with  IP of sub pair.

But on my CUCM SIP trunkl, i have DEVICE POOL with other SUB pair for manage call of this trink.

When i update server-group with right ip adress. every wsorking good !!!

How to resolve that issue. I am facing same issue. 

This occurs when the source IP address that is sending the SIP INVITE does not exist as a SIP trunk in CUCM. You may have never created it, or the IP address may not be the one that is in use. Check bind commands for gateways, etc.

-nick

Hi nick,

Thanks for the advice I set up a SIP trunk for my source ip and I got one phone to ring, when I send the click to dial request.

However I'm trying to get one phone to ring the other phone but I've had no luck so far. Is that still a SIP trunk issue?

It could be a calling search space / partition issue - it doesn't sound like a SIP trunk issue.

-nick

This was exactly my issue. I have dual SIP gateways in an HSRP group connected to a third party IVR. When the IVR sends a refer message to move a call from queue to an available agent the CUBE invites the CUCM via the SIP trunk. I had the trunk configured with the VIP address instead of the actual box address of the active router. So I was receiving the same error message.

Based on Nicholas' message above I decided to add the actual active router and standby to the SIP trunk CUCM side, and now the error is resolved. Great job Nick!

Jonathan

I had this issue and your solution worked for me. I have missed one subscribers IP on SIP trunk.

Thank you.

csco11391130
Beginner

Just in media gateway i did in

voice service voip

sip

bind all source-interface Loopback0

where the loopback0 had the ip source of trunk.

with debug ccsip message

you can watch the ip local of sip trunk, and the dial-peer you put the ip remote

This is awesome and helped me fix an issue I was having.

thanks!

toormehdi
Beginner

You can experience this problem if the only IP of CCM you are pointing to in the SIP dialpeer is not the primary CCM in the call manager group for the device pool you have applied to the SIP trunk.

Ensure that either the CCM you are pointing the dialpeer  to is primary in the CCM group or you have multiple dial-peers with different preference as per the CCM group on the other side.

Please rate the post

Content for Community-Ad

Spotlight Awards 2021