cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3846
Views
8
Helpful
35
Replies

877 router reset itself, no ADSL connection after restoring config

Zenith888
Beginner
Beginner

Hi,

There was no Internet connection this morning and I looked at the router - the CD light was blinking fast.

Router did not respond to SSH connection and I plugged in the console cable.

sh run had factory default configuration. So I've restored the last running config, but still would not have Internet.

CD light continues to flash frequently and this is what router reports:

#sh dsl int atm0
ATM0
Alcatel 20190 chipset information

Line has not yet been activated.

Modem Status:    Down (DMTDSL_DO_OPEN)
DSL Mode:        Unknown
Interrupts:      8238 (0 spurious)
PHY Access Err:  0
Activations:     0
LED Status:      OFF
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-4.0.015.bin
Operation FW:    AMR-4.0.015.bin
FW Source:       external

DSL: Training log buffer capability is not enabled

As of now I am connected thru a combination of SpeedTouch modem and DLink router as a backup.

Is there any way to diagnose what is missing for the DSL connection to be established by 877?

35 REPLIES 35

Put the DSL modem in bridging mode and then try the following config on your Cisco 877.  Let me know it it works out.

!

interface ATM0

no ip address

shutdown

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

description <<< Uplink to DSL Modem >>>

switchport access vlan 2

load-interval 30

!

interface Vlan1

description <<< LAN >>>

ip address 192.168.1.1 255.255.255.0

ip nat enable

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Vlan2

description <<< WAN Vlan >>>

no ip address

ip tcp adjust-mss 1452

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

no ip redirects

no ip proxy-arp

ip nat enable

ip virtual-reassembly

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username password 0

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat source list natlist interface Dialer1 overload

!

ip access-list extended natlist

permit ip any 192.168.1.0 0.0.0.255

!

Since the last post in this thread I've arranged to change the provider and the new provider will install 2x dry

DSL loops. Currently, due to untimely death of 877's modem, I am using a PT-link modem with a software router, which will do load balancing of 2 DLS connections using round-robin algorithm.

Can 877 do that? I can see from the post above that it can create pppoe on one of the Ethernet ports, but can it create 2x pppoe interfaces and round-robin between them? That would be awesome, as the PC I am using is consuming quite some electric power.

Appreciate your help!

Yes, with an 877 you should be able to load balanc two ADSL circuits, one to the ADSL interface, the other using an external modem in bridge mode.

This thread is entirely about how ADSL interface on the router is DEAD. Passed away. Kicked the bucket.

Get a support contract and RMA it.

Are you referring to a support contract with Cisco?

Isn't that going to cost me more than to buy another 877? How much does it cost to have contract which would allow RMA of this router?

You have to contact a Cisco reseller, however (logically) It does not cost more than the router itself.

And without spending any money at all, is it possible to load-balance between two PPPoE interfaces created on the ETH ports of 877? How?

Those examples, although providing some hints, are quite different in that they load-balance different connections.

Those examples, although providing some hints, are quite different in that they load-balance different connections.

That is what you asked before:

is it possible to load-balance between two PPPoE interfaces created on the ETH ports of 877?

Answer: yes as indicated above.

In your example one line is DHCP another PPPoE, while in my configuration both lines are PPPoE.

Examples cannot cover all possible configuration combinations.

They are there to show and teach you a concept, not give cut and paste solutions.

So in the case above it doesn't matter what type of connection there is.

The specific difficulty I am having understanding the examples is that I can't figure what indicates that the following commands are in any way associated with a particular FastEthernet interface. Does IOS somehow figure what interface to create Dialer0 on? How?

Interface Dialer 0
description PPPoX dialer
ip address negotiated
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss

Do I have to create similar section for Dialer1 if I use 2 PPPoE, not 1 PPPoE and 1 DHCP connection?

Do I have to add a line between these two for Dialer1?

ip nat inside source route-map fixed-nat interface Dialer0 overload

ip nat inside source route-map dhcp-nat interface FastEthernet0 overload

like this?

ip nat inside source route-map fixed-nat interface Dialer1 overload

Basically, is this a correct configuration for a router with load balancing on 2x PPPoE connections, using 10.10.10.0 network for the LAN?

!
interface FastEthernet0

no ip address pppoe enable

no cdp enable

!

interface FastEthernet1

no ip address

pppoe enable

no cdp enable

!

interface FastEthernet2

no cdp enable

!

interface Vlan1

description LAN Interface

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452


!---Define LAN-facing interfaces with "ip nat inside".

Interface Dialer 0

description PPPoE dialer for ISP0

ip address negotiated

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss


Interface Dialer 1

description PPPoE dialer for ISP1

ip address negotiated

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss


!---Define ISP-facing interfaces with "ip nat outside".

ip route 0.0.0.0 0.0.0.0 dialer 0 track 123

!

ip nat inside source route-map fixed-nat interface Dialer0 overload

ip nat inside source route-map fixed-nat interface Dialer1 overload

ip nat inside source route-map dhcp-nat interface FastEthernet0 overload! !--- Configure NAT overload (PAT) in order to use route-maps.!

access-list 110 permit ip 10.10.10.0 0.0.0.255 any

!--- Define ACLs for traffic that are NATed to !--- the ISP connections.

!

route-map fixed-nat permit 10

match ip address 110

match interface Dialer0

!

route-map fixed-nat permit 10

match ip address 110

match interface Dialer1

!

That's about correct but with some mistakes in the configuration.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: