cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
26281
Views
5
Helpful
17
Replies

Cisco 1801 - Ping - Request Timed Out

offpister
Beginner
Beginner

Hello everyone,

I have a Cisco 1801 Router, but whenever there is anything plugged into the integrated 8 port switch for example two computers, I cannot get them to ping each other. All of the ports are on the same vLAN.

I am a Cisco newbie, so sorry if this question/query is really basic. Is there anyway I can test the integrated switch to see if it is faulty - what is the likelihood of this happening???

Any suggestions/solutions welcome.

Thanks

Jonathan Worth.

Network Manager

Hesa Limited

1 Accepted Solution

Accepted Solutions

That seems to indicate a faulty unit.

If you don't have a support contract to have it replace by Cisco, it's not expensive to buy one.

View solution in original post

17 Replies 17

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Begin disabling firewall on the PCs.

Hi,

I have done this. I can also ping the computers when they are connected to an unmanaged switch. I am using the switch part of the router out of box without any configuration - is this possible?

If not, please can you advise me on what configuration I need to do to get this working.

If I configure the FE0 port of the router with an IP address I can ping this, it is only when I have connected two computers to the switch interfaces that I cannot ping.

It also seems intermittent - I can get two pings sometimes and then nothing and then maybe one another time.

Thanks,

Jonathan.

You may need to configure a BVI (Bridged Virtual interface) to get those switch ports onto the same broadcast domain as the FE0 port.

Add a sho run and show vlan and we can take a look

Hello,

Thanks for your reply. Here is the show run output:

Router#show run
Building configuration...

Current configuration : 1044 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
!
!
!
!
ip cef
no ip domain lookup
multilink bundle-name authenticated
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
duplex full
speed 100
!
interface FastEthernet2
duplex full
speed 100
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
shutdown
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Vlan1
ip address 192.168.2.2 255.255.255.0
!
interface Dialer0
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router#

Here is show vlan-switch:

Router#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1, Fa2, Fa3, Fa4, Fa5, Fa6
                                                Fa7, Fa8
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Router#

I do not want/need to use the FE0 port. I want to use the FE1-FE8 as my internal switch and the ADSLoPOTS connection for a PPPoA ADSL broadband connection.

Thanks.

Jonathan Worth.

To begin with add spanning-tree portfast under interface range fa1 - 8.

The connected PCs must be able to ping each other and the router.

Then there is a bunch of config needed for a good job, my recommendation would be get someone knowledgeable and avoid loosing time yourself with it.

Hi,

Thanks for the replies. Would it be safe to assume that the integrated switch is working ok and that I can expect this because I need to do some more configuration?

I also have the switch uplinked to an unmanaged switch. Would this be ok or is this that is causing the ping problems?

Also, as this is just a test/lab setup I just want to be able to successfully ping two devices that are connected to the network and know that the switch is functioning correctly before I expand and configure other things on the router.

I am currently at work at the minute, but will let you know later if "spanning-tree portfast" does anything.

Below is the output from Pinging a PC that is connected directly to the Cisco Router - Switch interface (FE2) from a PC that goes through the unmanaged switch that is connected to the Cisco Router - Switch interface (FE1):

Reply from 192.168.2.32: bytes=32 time=1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time=19ms TTL=128

Reply from 192.168.2.32: bytes=32 time=2ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time=19ms TTL=128

Reply from 192.168.2.32: bytes=32 time=10ms TTL=128

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time=19ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time=1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Request timed out.

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Reply from 192.168.2.32: bytes=32 time<1ms TTL=128

Request timed out.

Thanks again for all your help

Regards,

Jonathan.

Hi,

Could you get rid of this unmanaged switch and try with the 2 machines connected to 2 ports on the switch module of the router.

Regards.

Alain.

Don't forget to rate helpful posts.

Hello,

I have set one of the PCs to:

IP: 192.168.2.32

Subnet: 255.255.255.0

The other PC:

IP: 192.168.2.34

Subnet: 255.255.255.0

No uplink/connection to any other switch.

I cannot ping each PC from the other PC - Request Timed Out. Is this a hardware/physical problem with the switch.

Thanks.

Jonathan Worth

So now without the unmanaged switch no pings are working anymore?

Regards.

Alain.

Don't forget to rate helpful posts.

Hi.

No they are still intermittent. Do I have to set a Default Gateway for this to work and if so what do I use. I was thinking on using the IP address of vLAN1 (192.168.2.2). Is that right?

There seems to be network traffic - the lights on the front are blinking every couple of seconds.

The ARP Cache on the router lists the following:

192.168.2.2 (vLAN1)

192.168.2.32 (PC1)

192.168.2.35 (PC2)

The ARP Cache on PC1:

192.168.2.35 (PC2)

The ARP Cache on PC2:

192.168.2.2 (vLAN1)

192.168.2.32 (PC1)

I don't know what to do anymore!!! I really just want to find out if the switch on the router is faulty or not.

Thanks.

Jonathan.

Take "show interface" for the relevant interfaces.

Do "term mon" and check for any message while stuff happens.

Hi.

I have done "show interface" for all of the relevant interfaces:

FastEthernet1 = Uplink to unmanaged switch

FastEthernet2 = Link to PC1

FastEthernet3 = Link to PC2

HESALTD-R1#show interface fastethernet1

FastEthernet1 is up, line protocol is up

  Hardware is FastEthernet, address is 0019.0684.cace (bia 0019.0684.cace)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 207/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 2 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     1279 packets input, 384906 bytes, 0 no buffer

     Received 92 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     289 packets output, 26086 bytes, 0 underruns

     169 output errors, 0 collisions, 3 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

HESALTD-R1#show interface fastethernet2

FastEthernet2 is up, line protocol is up

  Hardware is FastEthernet, address is 0019.0684.cacf (bia 0019.0684.cacf)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 185/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 1000 bits/sec, 1 packets/sec

     96 packets input, 11622 bytes, 0 no buffer

     Received 66 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     892 packets output, 218760 bytes, 0 underruns

     706 output errors, 0 collisions, 3 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

HESALTD-R1#show interface fastethernet3

FastEthernet3 is down, line protocol is down

  Hardware is FastEthernet, address is 0019.0684.cad0 (bia 0019.0684.cad0)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 220/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     69 packets input, 8598 bytes, 0 no buffer

     Received 21 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     402 packets output, 93759 bytes, 0 underruns

     289 output errors, 0 collisions, 3 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

I hope that this makes sense to you and hopefully this will shed some light on the problem!

Thanks again (and again)

Jonathan.

Too many output errors, try updating IOS in the hope it's just some nasty bug.

Hi,

Thanks for your reply. Is there a particular verison of IOS that you would recommend me try?

Thanks

Jonathan.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: