cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

221
Views
20
Helpful
5
Replies
Beginner

Cisco L3 switch communication with Moxa industrial Swi

Greetings,

 

Can someone share their knowledge and experience to explain below troubleshoot scenario.

 

Customer has two existing L3 3560 switches. We need to connect 6 Moxa industrial switches to cisco switches as shown in pic attached. Customer doesnot want any vlan on moxa switches as there is only industrial traffic.

 

 

Customer has given defalt gateway of a.b.x.250

 

Now what additional configuration should be done on cisco switch.  I created vlanx, int vlanx with ip as default gateway a.b.x.250 and configure port to moxa as trunk or access (as no vlan in moxa).

 

The link is up between cisco and moxa but no ping is working between cisco and moxa 

 

Pls advise

 

 

 

Default Gateway  Managed Switch IP addressMoxa SWITCH NAME
a.b.x.250   a.b.x.200MOXA-SW01
a.b.x.250   a.b.x.201MOXA-SW02
a.b.x.250   a.b.x.118sw03
a.b.x.250   a.b.x.119sw04
a.b.x.250   a.b.x.120sw05
a.b.x.250   a.b.x.121sw06

 

5 REPLIES 5
VIP Advisor

Re: Cisco L3 switch communication with Moxa industrial Swi

since that is dumb device, i would suggest here to make (Cisco side as Access port) , make SVI on switch for that Access port example :

 

interface gi 1/1

description connected-moxa

switchport mode access

switchport access vlan 5

no shutdown

!

interface vlan 5

ip address x.x.x.x

no shutdown

BB
*** Rate All Helpful Responses ***
VIP Advocate

Re: Cisco L3 switch communication with Moxa industrial Swi

Hi,

I am not sure about the MOXA switch module number. As Moxa is having managed and unmanaged switch so we need the model number of the switch. 

But try like this: (If the switch is unmanaged) 

Cisco switch port configuration: 

 

interface gigx/x/x

switchport mode access

switchport access vlan x

!

!

But try like this: (If the switch is managed) 

Cisco switch port configuration: 

 

interface gigx/x/x

switchport mode trunk

switchport trunk native VLAN X --> X VLAN is must match at both ends as a native VLAN ID.

!

 

!

  

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Beginner

Re: Cisco L3 switch communication with Moxa industrial Swi

Its Moxa EDS-510E-3GTXSFP-T. Its a managed Sw.

 

 

So on cisco sw.

 

I shall create a vlan x, interface vlanx, its ip address a.b.x.250 and on port make trunk with swicthport native vlan x and then on moxa make the uplink port with trunk and native vlanx. Do I need to define vlanx on moxa as well? Can I instead make cisco and moxa port as access port with cisco as vlanx access port?

VIP Advisor

Re: Cisco L3 switch communication with Moxa industrial Swi

If you like L3 connectivity, you need to have L3 interface on Moxa side also.

 

yes, you can make both the side access ports - belong to certain VLANs.

 

 

 

 

 

BB
*** Rate All Helpful Responses ***
VIP Advocate

Re: Cisco L3 switch communication with Moxa industrial Swi

Hi,

I shall create a vlan x, interface vlanx, its ip address a.b.x.250 and on port make trunk with swicthport native vlan x and then on moxa make the uplink port with trunk and native vlanx. Do I need to define vlanx on moxa as well? Can I instead make cisco and moxa port as access port with cisco as vlanx access port?

Yes, It will work but make sure that you will not receive DTP on the cisco switch and the MAXO switch will not react on DTP massage, sent by Cisco switch.

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
CreatePlease to create content
Content for Community-Ad