cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2878
Views
0
Helpful
3
Replies

Connect a Cisco 2611 to internet using PPPoE

TheTrueMc128k
Beginner
Beginner

Hi all.

I'm new to the cisco IOS system. I'm also italian, so I can make mistakes while typing.

I have the following problem: I need to connect my router to the internet using a PPPoE Tunnel (it will act as a gateway). The router is connected to my ISP's modem via RJ45.

The router needs to connect like a PC, open session, username and password and so on. Nothing more. And the connection must be stable (when it's lost it automatically restarts the tunnelling)

I looked every guide I could find with no success... ping didn't work. This is my last try.

Thank you.

p.s.: one more thing... what's the best firmware for those kind of things? I need only pppoe, routing, dhcp, ntp, port mapping.

1 Accepted Solution

Accepted Solutions

rizwanr74
Rising star
Rising star

This might help you....

interface dialer 1
ip address negotiated
encapsulation ppp
ip mtu 1492
ip nat outside
ppp authentication pap callin
ppp pap sent-username your-pppoe-user-name pass KING-OF_THE_Hill
dialer pool 1
exit

Interface FastEthernet0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shut

exit


interface ethernet0
no shut
ip address
ip adjust-mss 1452
ip nat inside

exit


ip nat inside source list NAT-ACL interface dailer 1 overload

ip route 0.0.0.0 0.0.0.0 dialer1

View solution in original post

3 Replies 3

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

If doesn;t work, you have configured somethign wrong. You can either have someone that know what he's doing fix it,

or try yourself reading monay, posts, documentation, and spending a lot of time.

rizwanr74
Rising star
Rising star

This might help you....

interface dialer 1
ip address negotiated
encapsulation ppp
ip mtu 1492
ip nat outside
ppp authentication pap callin
ppp pap sent-username your-pppoe-user-name pass KING-OF_THE_Hill
dialer pool 1
exit

Interface FastEthernet0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shut

exit


interface ethernet0
no shut
ip address
ip adjust-mss 1452
ip nat inside

exit


ip nat inside source list NAT-ACL interface dailer 1 overload

ip route 0.0.0.0 0.0.0.0 dialer1

              T H A N K    Y O U ! ! ! ! !

WORKED PERFECTLY!! Simply fantastic!!

Thank you again! You saved me from hours of googling.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers