06-15-2011 05:10 AM - edited 03-07-2019 12:49 AM
Hi all,
I have Cisco 6509 with 5 ether-channel configured on it.
On one ether-channel other side are Dell Powerconnect 5448 switch.
All is working fine for some month, but today for some reasons this Po was disabled (already 4 times).
On Cisco in logs I can see:
48w2d: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Gi3/5 in err-disable state
48w2d: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Gi4/5 in err-disable state
48w2d: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting Po3 in err-disable state
On Dell are no entry about this problem.
Configuration on cisco are:
interface Port-channel3
description Po3
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 15-18,25,35,x,x,x,x
switchport mode trunk
no ip address
end
interface GigabitEthernet3/5 (also gi4/5)
description Po3
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 15-18,25,35,x,x,x,x
no ip address
no cdp enable
channel-group 3 mode on
end
On Dell Pc 5448 configuration are:
interface port-channel 1
description Po3
exit
interface port-channel 1
switchport mode trunk
exit
interface port-channel 1
switchport trunk allowed vlan add 15-18,25,35,x,x,x,x
exit
interface range ethernet g(45-48)
channel-group 1 mode on
exit
How can I found what is reason of this problem?
Thanks.
Zigmunds
06-15-2011 05:28 AM
Please verify the allowed vlan list is identical on both sides.
regards,
Leo
06-15-2011 05:30 AM
In addition to Leo's sggestion,
for 'interface Port-channel3'
no cdp enable
for 'interface GigabitEthernet3/5 (also gi4/5)'
switchport mode trunk
06-15-2011 05:40 AM
Hi,
thanks.
About: "switchport mode trunk" in gi4/5 and 3/5 - there is this parameter, I accidentally deleted it when post
about cdp:
cisco(config)#int po3
cisco(config-if)#no cdp enable
% CDP already disabled since not supported on this interface, or for this encapsulation
ok, I will check all vlans
06-15-2011 06:18 AM
Hi,
allowed vlan list on both sides ar equal.
what should I chech next?
Thanks.
06-15-2011 06:27 AM
Post output for
show etherchannel port-channel
show etherchannel port
show etherchannel summary
Though the Dell should default to standard 802.1q encapsulation, I would hard-code that on the 5448 side as well.
06-15-2011 06:48 AM
Hi,
show etherchannel port-channel:
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 55 Gi3/5 On 4
1 AA Gi4/5 On 4
Time since last port bundled: 0d:01h:19m:15s Gi4/5
Time since last port Un-bundled: 0d:01h:20m:28s Gi4/5
show etherchannel port:
Group: 3
----------
Ports in the group:
-------------------
Port: Gi3/5
------------
Port state = Up Mstr In-Bndl
Channel group = 3 Mode = On Gcchange = -
Port-channel = Po3 GC = - Pseudo port-channel = Po3
Port index = 0 Load = 0x55 Protocol = -
Age of the port in the current state: 0d:01h:20m:22s
Port: Gi4/5
------------
Port state = Up Mstr In-Bndl
Channel group = 3 Mode = On Gcchange = -
Port-channel = Po3 GC = - Pseudo port-channel = Po3
Port index = 1 Load = 0xAA Protocol = -
Age of the port in the current state: 0d:01h:20m:22s
cisco#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
Number of channel-groups in use: 7
Number of aggregators: 7
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Gi3/7(P) Gi4/7(P)
2 Po2(SU) - Gi3/8(P) Gi4/8(P)
3 Po3(SU) - Gi3/5(P) Gi4/5(P)
4 Po4(SU) - Gi3/3(P) Gi4/3(P)
5 Po5(SU) - Gi3/6(P) Gi4/6(P)
11 Po11(SU) - Gi7/3(P) Gi8/3(P)
20 Po20(SU) - Gi3/15(P) Gi3/16(D) Gi4/15(P) Gi4/16(D)
On dell switch I found very little information about port-channel:
show interfaces port-channel 1
Load balancing: Layer 2.
Gathering information...
Channel Ports
------- -----
ch1 Active: g(45-46) Inactive: g(47-48)
Thanks.
06-15-2011 09:55 AM
Hi,
1. Do a shut and no shut on the ports and see if they join back the etherchannel bundle.
2. Try changing the channel group mode to desirable mode and test again.
3. The errors comes this way. When you configure an etherchannel between two switches, you do it one at a time. As long as they are connected, at one moment one switch will have the config and the other will not - that is where the "misconfig" falls in. As soon as this is detected, the involved ports will be placed into err-disabled state. One way to configure an etherchannel if you do not want to disable the ports first could be to use the following command:
"no spanning-tree etherchannel guard misconfig" on switches. This is a global config command and is applied across the entire switch.
This way communication continues to happen - and switch will see any misconfigs as you carry out your configurations. The etherhcannel guard feature is on by default and it is the one that reports on this and err-disables the ports as soon as it notices a misconfiguration on the etherchannel.
It is a useful feature so after you finish configuring and your port-channel comes up - turn it back on as follows:
"spanning-tree etherchannel guard misconfig"
Hope this helps.
Sweta
06-15-2011 11:22 AM
Sweta has a good point.
06-15-2011 03:08 PM
I would make sure it matches on both sides. Looks like you have 2 ports configured in your port channel on the cisco side and 4 ports configured on the dell side . Maybe it doesn't like that . Might want to think about using LACP for your port channels instead of forcing the channel on . The dell should support that .
06-15-2011 03:20 PM
1. Correct me if I'm wrong, but doesn't Dell switches support "LACP"?
2. How did you change the settings of your etherchannel on the 6500? The reason why I'm asking because in some cases (due to IOS), you can just edit a line out during configuration (like putting a "no" to remove the line). With the 6500 you have to remove the port channel completely (no interface Po
06-15-2011 11:22 PM
Hi,
thanks all.
Sweta - I will try your suggestions.
Yesterday after 8th downtime ( it happens every 40 min) I remove port channel and leave singe port configuration on both sides
Now I will create new one Po config with test connections and test it.
Thanks.
06-16-2011 07:55 AM
Leolaohoo has a point. Shouldn't you use LACP
So instead of the channel-group being set to on set it to active. Try the following:
channel-group {#} mode active
Thanks in advance
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide