cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
25603
Views
25
Helpful
25
Replies
Beginner

Switch Catalyst 3560G Web Interface Problem

Hello,

I have a problem with my Cisco Catalyst 3560G switch. The web interface does not work (I tried IE11, IE6, Chrome, Firefox and Safari).

There is only displayed icons but no text :

 

To try to solve the problem, I've updated the switch to its latest IOS version (from 12.2(55)SE7 to 12.2(55)SE9). But the problem persists

WS-C3560G-48TS     12.2(55)SE9           C3560-IPBASEK9-M

In the configuration, the web server is enabled:
ip http server
ip http secure-server

What can I do?

Thanks

Best Regards,
Fabien

 

Everyone's tags (7)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Hi Fabien, for using the GUI

Hi Fabien,

 

for using the GUI , you have must have permission of privilege level 15 access

create a user

==>1

username admintest privilege 15 privilege 15 secret admintest

then runn the http services

==>2

ip http server
ip http secure-server

ip http authentication login local

 

==>3

management ip

http://xx.x.x..xx.x.x

it will ask you username and pass

make sure you have updated java version and follow attached pic

 

 

rate it if help full

BR

SYED

View solution in original post

Highlighted
Beginner

Hello Fabien,I think i have

Hello Fabien,

I think i have found the problem and a workaround for that.

The problem comes from the language of the webbrowser.

I had exactly the same problem with the same model with the same IOS version.

I have inspected with debugging tools in firefox and I find, the browser want to get  (firefox in french for my case) 2 scripts :

http://<ip switch>/fr/charset.js

http://<ip switch>/fr/re_preflight.js

But there is not any fr folder in flash:/C3560.......

 

So I have changed preferred language in firefox (putting english in first). Reload webpage and it works fine ;)

 

I hope it will help you

Thanks

Jeremy

View solution in original post

25 REPLIES 25
Highlighted
VIP Expert

Hi,Try loading the latest

Hi,

Try loading the latest version of Java and than test again.

HTH

Highlighted
Beginner

Hi,I installed the latest

Hi,

I installed the latest version of Java (https://www.java.com/fr/download/win8.jsp).

The problem remains the same

Highlighted
Beginner

Hello Fabien,I think i have

Hello Fabien,

I think i have found the problem and a workaround for that.

The problem comes from the language of the webbrowser.

I had exactly the same problem with the same model with the same IOS version.

I have inspected with debugging tools in firefox and I find, the browser want to get  (firefox in french for my case) 2 scripts :

http://<ip switch>/fr/charset.js

http://<ip switch>/fr/re_preflight.js

But there is not any fr folder in flash:/C3560.......

 

So I have changed preferred language in firefox (putting english in first). Reload webpage and it works fine ;)

 

I hope it will help you

Thanks

Jeremy

View solution in original post

Highlighted
Beginner

Hello Jeremy,Yes, it works!Is

Hello Jeremy,

Yes, it works!

Is it not possible to create a directory /fr/ with English files into for not having to change the language of naviguator ?

Also , In interface I do not click on the left menu, the menu not work. Have you also this problem on Firefox ?

Thanks

Fabien

Highlighted
Beginner

Hello,Yes I have the same

Hello,

Yes I have the same problem with the left menu in Firefox. It doesn't work .

I haven't ever tried to create a fr folder and copy paste files from /en folder.

I'll keep you in touch, when I'll realize the test.

Highlighted

Hi Fabien, for using the GUI

Hi Fabien,

 

for using the GUI , you have must have permission of privilege level 15 access

create a user

==>1

username admintest privilege 15 privilege 15 secret admintest

then runn the http services

==>2

ip http server
ip http secure-server

ip http authentication login local

 

==>3

management ip

http://xx.x.x..xx.x.x

it will ask you username and pass

make sure you have updated java version and follow attached pic

 

 

rate it if help full

BR

SYED

View solution in original post

Highlighted
Beginner

Hi aman,Thank you for your

Hi aman,

Thank you for your reply.
We advance, but there is still a problem :

Config :

username adminweb privilege 15 secret 5 $1$pnSK$3HooqgcPV5WpjVPrXvoPu/
ip http server
ip http authentication local
ip http secure-server

I also set intranet security in IE.
What's missing?

Thanks,
Fabien

Highlighted

Dear Fabien, try to check on

Dear Fabien,

 

try to check on another pc, and make sure the following thing on PC

==>1 Latest IE browser (please check the attachment for security setting)

==>2 latest version of Java install ( please check the attachment for Java Setting)

==>3 check PC firewall allowed program for testing ( best to be off the PC firewall)

 

rate it if help full

BR

SYED

 

Highlighted
Beginner

I disabled the firewall and

I disabled the firewall and apply all settings, but without success.

IE : 11.0.9600
Java : Version 8 MAJ 25

All programs are up to date

See attached

Same thing from another pc :-(

Highlighted
Hall of Fame Community Legend

Post the output to the

Post the output to the command "dir".  

 

I am suspecting the IOS was upgraded by copying the BIN file and not a total "unpack" of the TAR file.

Highlighted
Beginner

Hello Leo,SwitchBureau

Hello Leo,

SwitchBureau#dir
Directory of flash:/

    2  drwx         192   Mar 1 1993 00:12:57 +00:00  c3560-ipbasek9-mz.122-55.SE9
    3  -rwx        8139   Mar 1 1993 15:25:10 +00:00  config.text
  499  -rwx        1036  Oct 22 1993 00:16:56 +00:00  vlan.dat
  500  -rwx         106   Mar 1 1993 00:14:42 +00:00  info
  502  -rwx        1938   Mar 1 1993 15:25:10 +00:00  private-config.text
  503  -rwx        3096   Mar 1 1993 15:25:10 +00:00  multiple-fs

32514048 bytes total (17069568 bytes free)

And in "c3560-ipbasek9-mz.122-55.SE9" directory :

SwitchBureau#dir flash:c3560-ipbasek9-mz.122-55.SE9
Directory of flash:/c3560-ipbasek9-mz.122-55.SE9/

    4  -rwx    11772212   Mar 1 1993 00:12:57 +00:00  c3560-ipbasek9-mz.122-55.SE9.bin
    5  -rwx         505   Mar 1 1993 00:12:57 +00:00  info
    6  drwx        4800   Mar 1 1993 00:14:41 +00:00  html

32514048 bytes total (17069568 bytes free)

I used this command to install the latest IOS :

archive tar /xtract tftp://10.30.0.2/c3560-ipbasek9-tar.122-55.SE9.tar flash:

Highlighted
Hall of Fame Community Legend

I used this command to

I used this command to install the latest IOS :

archive tar /xtract tftp://10.30.0.2/c3560-ipbasek9-tar.122-55.SE9.tar flash:

Thanks, Fabien.  

 

I can't really see the date and time stamp of the HTML folder.  Also, I know the command "/xtract" works because I used to use it.  For the sake of argument, can I ask you to do the following commands: 

 

1.  delete /f /r flash:c3560-ipbasek9-mz.122-55.SE9/

2.  archive download-sw tftp://10.30.0.2/c3560-ipbasek9-tar.122-55.SE9.tar

 

And when the unpacking is complete, reboot the appliance and try again.

Highlighted
Beginner

The problem remains the same

The problem remains the same :(

Here is the log of the update : http://pastebin.com/8HHBXVxk

What's weird is that by looking at the HTML source of the web GUI, I get errors in javascript. See here: http://pastebin.com/J8NpwwDy. Normal ?

thanks

Highlighted
Hall of Fame Community Legend

If you've tried different

If you've tried different browsers then I would recommend try a different machine.  

CreatePlease to create content
Content for Community-Ad