Showing results for 
Search instead for 
Did you mean: 

UCS Director and VMRC(HTML5)


I have been running Director 5.0 against a vSphere 5.5 cluster and using the VMWare client integration to provide remote console access. I began the upgrade to the systems March 19. Due to issues in the Director upgrade (corrupted DB), I  abandoned my old implementation. I have upgraded vSphere to 6.5 (and vCenter) and deployed a brand new Director 6.5 appliance. 


I have a fairly simple setup to allow users to build a vm and boot it from an ISO installer via the self-service portal. All of that works. I cannot get the VMRC 10.x to work. I have engaged the TAC and for more than a week, they can't figure this out either. I have valid certs on the Director box as well as my vCenter. 


If I select a vm within Director, then launch the HTML5 VMRC, I get immediately disconnected. If I select Launch VM Console (as an end user), then select Launch VMRC browser plugin, I get a different window that says the plugin is not installed correctly. If I login as admin, select Launch VM Console, then select Launch VMRC Console - stand-alone plugin, it works. I can get it to work on all machines if I login as admin and use the above procedure.


I have tried Firefox 51 through current release. I have tried Chrome, Opera and IE. 


Curiously, on the machine we tested with originally, it works in Opera, Chrome and IE, but not Firefox. We cannot duplicate the successes. 



Two of my test machines are even in the same vlan as the Director appliance and the vCenter appliance. All firewalls are off.


I'm at a loss. Any suggestions?


Dale DuVall

Datacenter Admin

Lane Community College

Eugene, Oregon

4 Replies 4


[Topic refresh] Any success with that? I have been also struggling with VMRC console from some time already, with no luck. Users can access VMs (RDP or SSH)  after they are provissioned and IP is assigned, but with plain ISO-mounted VMs or when some console-based action is needed they are stuck. Has anyone ever made this work? Whithout this feature UCSD becomes useless for end users :-(

I've found the the remote console works as expected whilst inside my management/private network.


Once I configure a NAT and route to the public facing IP over the internet, everything stops.


When deconstructing the vmrc:// URL, and the VMRC Web Browser Plugin URL, both reference the internal vSphere vCenter Server address as embedded Base64 URL. I've published a test vCenter Server to the internet with split DNS, and there are still issues with VMRC.


Has anyone had success with the "Browser Plugin"? I continue to receive "This plugin is not supported".

I managed to make it work. I looked at what was going on in the background and it appeared to be a cert issue. I downloaded vcenter cert and applied it to end user's browser, and the console started working. Also, it looks like end user must be able to resolve host's DNS names, as the console goes directly to the host by name, if the host is registered with the name not IP to vcenter.

That's 100% correct.


That's the behavior that mimicks a internal network. Inside an internal network all names are resolvable, and the hosts are routable.


The issue comes when publishing UCSD to the internet via. a WAF or NAT and those ESXi hosts aren't routable and don't have public DNS resource records.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers