cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12613
Views
18
Helpful
30
Replies

9971 SIP phone re-registering every 10 mins

ai.solutions
Beginner
Beginner

On a UC560, is it normal for a 9971 to re-register itself to the UC every 10 mins?

Without fail it happens. Whilst the phone is re-registering it says "Not Registered" and then reconnects.

Only noticed this happening after I configured a SIP trunk. So im not sure if its a coincidence. All configured with CCA:

voice register global

mode cme

source-address 192.168.100.254 port 5060

max-dn 56

max-pool 14

load 9971 sip9971.9-2-2

load 9951 sip9951.9-2-2

load 8961 sip8961.9-2-2

authenticate register

timezone 43

time-format 24

hold-alert

voicemail 399

tftp-path flash:

create profile sync 0001402427654588

30 Replies 30

bjames
Contributor
Contributor

It's not normal, ours are fine after they registered the first time. Do all you SCCP phones work fine?

Can you take the SIP trunk off to see if that fixes them?

Bob James

No issues with the skinny phones. I cant really take the SIP trunk out...

I cant find anywhere a setting that would cause the re-registration every 10 mins.

Do they register and get their parameters, then re-register? Or do they just keep trying and never regster?

Anything in debug showing any info?

Bob James

Yeah the phone registers fine. Then after 10 minutes, it loses registration and then re-registers.

The phone log shows:

21:43:37 CUCM closed TCP connection

21:43:38 No DNS Server IP

21:43:38 Updating Trust List

21:43:38 No trust List Installed

Then the normal registration log messages.

Here's the debug for the register:

http://inetpro.org/pastebin/7f2a60df83444d25a4f325a0254f89cd

I see it; can you sanitize and post your UC config here or on pastebin?

Bob James

On pastebin:

http://inetpro.org/pastebin/61ab92ac235f4d89bfc6346290a61879

I omitted the dial-peers... they arent relevant and just take up too much space.

OK this configuration confuses me;is your voice vlan 192.168.100.0? and your PC vlan 192.168.169.0?

I'm no expert but I would try changing your registar and sip-server in sip-ua to the IP v4 addresses:

registrar ipv4:x.x.x.x expires 3600

sip-server ipv4:x.x.x.x:5060  

also add

connection-reuse

And under voice server voip

sip

add

outbound-proxy ipv4:x.x.x.x - pointing to your ITSP

I'm not sure if these will help, like I said this config is a little confusing to me so take backups and try after hours

Bob James

      

Couple more things;

on you dial-peer voice is the internal session target set to ipv4:10.1.10.1?

and your outgoing set to your ITSP?

This route:

ip route 10.1.10.1 255.255.255.255 Vlan90

should be:

ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0

Hi, very sorry for the late response.

Yes... VLAN 100 (voice) is 192.168.100.0/24

VLAN 1 (data) is 192.168.169.0/24

I have removed the SIP trunk configuration through CCA. However it appears that the re-registration issue still continues.

There is no registrar ipv4, sip-server ipv4 commands configured now that the SIP trunk is removed.

Regarding the route command... that was configured by CCA, and achieves the same thing.

Are the phones plugged directly into the UC ports or something else?

I would try downgrading the code for the 9971's one version to see if it's a code issue.

Sorry i can't be more help

Bob James

David Trad
VIP Alumni
VIP Alumni

Hi ai.Solutions,

I am not familiar with these phones as I haven't used one of them yet, but what on earth is this relating too?

"307362: Jul 23 13:53:39.824: VOICE_REG_POOL: No entry for (asterisk) found in contact table"

Was this phone registered to an Asterisk system first before the UC? Or do these phones have an Asterisk forked kernel???? Mystery surrounds me on this one LOL

Also when you added the SIP trunk did it change the SIP registration timers? Maybe this could cause the drop-outs as it sounds like the registration timers may be kicking in and causing the phones to re-register for no reason...

Just a thought.

Cheers,


David Trad.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

Are you using the phones 9971 with wired or wireless connection? I had this problem using wireless connection and resolves fixing a static channel for 802.11a (in my case) on Cisco AP.

Another suggestion is for yoou use new version of SIP phones. For 9971, Im using cmterm-9971.9-2-2SR1-9.

I tried to use the version sip9971.9-3-1-33 but I don´t know why the phones can´t download it from CME.

Hi Fabio,

We have a similar issue with our 9971s over the wireless network.

All the phones are connected via wireless and the customer cann't retain a call for any longer than 10-15 seconds before it re-connects/un-registers.

CCME version 8.5 with SIP9971.9-1-1SR1

I've seen on other posts that this maybe down to CAC on the WLC, but thinking that your solution above may be the answer.

I'm no wireless engineer so was just hoping you could ellaborate on fixing the channel on the AP, or WLC?

Cheers

Oli

Are you configuring QoS on your WLC for APs?

My APs are standalone and I have this configuration of Qos:

class-map match-all SIP

match ip dscp cs3

class-map match-all Video

match ip dscp af41

class-map match-all RTP

match ip dscp ef

!

!

policy-map Voice

class RTP

  set cos 6

class Video

  set cos 5

class SIP

  set cos 4

interface Dot11Radio1

service-policy input Voice

service-policy output Voice

I have using the auto qos cisco-phone on my switch too.

trustedit
Beginner
Beginner

Anyone have a fix for this, we have the same problem.?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: