Showing results for 
Search instead for 
Did you mean: 

3504 fails update to 8.8.125

Level 4
Level 4

I have a 3504 that I have been able to update as far as 8.8.120.  Multiple attempts to update to 8.8.125 have failed.  I have tried via GUI and command line.  Consistently fails trying to expand the file downloaded from CCO.   Anyone else having this issue?  If so have you been able to overcome it.  I

1 Accepted Solution

Accepted Solutions

Well the licensing appears to be the issue.  I removed the RTU licenses and the unit updated to 8.8.125.  I did notice that my RTU count of (5) put me at (6) including the one license that comes with the unit.  I have since reassigned to a total of (5).  See what happens next update.

View solution in original post

21 Replies 21

David Ritter
Level 4
Level 4

Um, no I don't have that problem..  because I know that support ENDED with 8.5.x code for most if not ALL 802.11n class devices.  Only 802.11ac class devices supported from 8.6 and up.

That's from Supported Access Points in Cisco Wireless Software Releases (Table 5) of the Cisco Wireless Solutions Software Compatibility Matrix dtd jul 2019.

I will have an old 5508 hangin around for legacy support.  Because it too dies with 8.5.x code.  It is 5520's and up from here on out.


oh my bad, you were saying the 3504 wlc.. hum, table 6 say's its still covered.
are you pulling the .aes file your self and loading the wlc or are you letting the wlc reach out to cisco for the file?

Haydn Andrews
VIP Alumni
VIP Alumni

couple of questions

Have you done a MD5 check on the file once it was downloaded, just to make sure it was not corrupt.

Are you using TFTP to upload the file to the WLC - if so what TFTP client, have you tried SFTP or HTTP? I had this issue previously where code wouldn't load via TFTP, worked by SFTP and HTTP. Believe some TFTP clients have issues with large files (50mb plus)


I also find it best to download the file from the CCO site myself and then upload to the WLC rather than getting the WLC to reach out to CCO.


What code are you upgrading from?

*****Help out other by using the rating system and marking answered questions as "Answered"*****
*** Please rate helpful posts ***

Leo Laohoo
Hall of Fame
Hall of Fame

@rm760 wrote:

Consistently fails trying to expand the file downloaded from CCO. 

I suspect the firmware file is corrupt.  

You need to download the firmware again.

VIP Alumni
VIP Alumni
If the md5 is correct of the file, reload the WLC and try again. I actually also had issues to upgrade a 5520 from to It only worked once I stopped using Chrome and used Edge.

Cisco Employee
Cisco Employee



It is recommended to post the upgrade log for analysis.


Best regards,



Thanks for all of the replies.   I have tried downloading the file from CCO using multiple browsers on multiple computers, all have been able to download the file with positive MD5 results.  I have tried multiple computers as the source or host of the update file.  Again met with failure.  I have also tried power cycling the 3504 before attempting the update. Updated were attempted via GUI / HTTP transfer and CLI.  Again failure.  As I stated 8.8.120 worked just fine.  I have (4) APs connected, (3) 3802 in local mode and (1) 3702 in flexconnect mode at a remote site. 

Logs I am seeing only detail a basic failure to complete the upload.   Is there debug or a more specific logging I could run to capture more detail?

Here are screenshots of the errors


Can you please post a show version of the WLC?

How is the cpu load on the Wlc? If it is high, disable the 2.4 and 5 Ghz networks and try again.
I don't think this is the solution though, I think you have some leftover files on the partition which don't get removed correctly, or maybe broken flash. I currently don't have any links handy for those issues sadly, but try to search for "wlc clean flash " or similar.

Again thanks to all who have taken the time to look at my thread.  It may be interesting to note that the controller came out of the box with 8.5 code.  I first tried going to 8.8.125 which failed.  I thought it might be a revision step upgrade so I upgraded to 8.7 without issue.   An attempt from 8.7 to 8.8.125 failed.   Going from 8.7 to 8.8.120 worked.   Now trying to go from 8.8.120 to 8.8.125 is failing.   

Please also know CPU load is low.   4 APs with 16 endpoints.   Hyperlocation is turned off. 


Can you enter the following and compare it with my output?

(Cisco Controller) >test system disk-usage

Filesystem Size Used Available Use% Mounted on

devpts 1.7G 388.0K 1.7G 0% /dev/pts

none 1.7G 64.0K 1.7G 0% /var/run

none 1.7G 32.0K 1.7G 0% /tmp

none 1.7G 388.0K 1.7G 0% /dev

/dev/mmcblk0p2 16.4G 566.6M 15.0G 4% /mnt/wlc

/dev/mmcblk0p3 7.2G 92.1M 6.7G 1% /var/log

/dev/mmcblk0p1 464.8M 77.2M 359.3M 18% /boot

/dev/loop3 110.0K 10.0K 92.0K 10% /root/.csl

tmpfs 40.0M 0 40.0M 0% /mnt/ap_bundle

It's also from a 3504 running

And please also show the output for this command:

(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.

Product Name..................................... Cisco Controller

Product Version..................................

RTOS Version.....................................

Bootloader Version...............................

Emergency Image Version..........................

OUI File Last Update Time........................ N/A

Build Type....................................... DATA + WPS




Compare info as suggested by Pat but also I notice the error message in your screenshot exactly matches the one quoted in this bug:
Check/clear/correct anything in the file path field then try again.

I did notice this as well.  the same file path is used for 8.8.120 and works correctly.   Even tried changing file path.  no Joy. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card