cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10105
Views
5
Helpful
10
Replies
Highlighted
Beginner

Cisco AP 3802 cannot join WLC - aptrace_register_sysproc_fn: duplicate registeration for 'wired'

Hi,

 

We have bought some Cisco 3802 Ap's. I connected 1 of the AP's to a switch we have at our office to see if it worked and it did. I read that there has been some bugs with the AP where if you connect it to a 100mbps port it will show you the "aptrace_register_sysproc_fn: duplicate registeration for 'wired'". 
I have now set up the antenna up on the right location, but we are using a POE which is 1gbps.

 

The problem is the same as with 100mbps... I have tried to google it, but so far I don't see any solution.

The WLC is running version 8.5.135.0 which is not the newest. I would love to update the version, but we can't since we also have 1602 AP's in our enviroment, so if we update 1 more version it doesn't support it anymore.

 

Does anyone have a good solution to make the 3802 AP to work with a POE?

 

Regards,

Jørgen

10 REPLIES 10
Highlighted
VIP Mentor

Could be this bug

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvi14641/?rfs=iqvred

Symptom:
Access point goes into a boot loop. The switch shows the link as up, but no CDP information.
The AP console shows messages similar to the following:

[*02/23/2018 18:40:50.3857] waiting for POE negotiation to complete
[*02/23/2018 18:40:52.9034] SYS-COND: AP is in critical condition
[*02/23/2018 18:40:55.3865] Waiting for uplink IPv4/IPv6 configuration
[*02/23/2018 18:41:08.3887] Resetting wired0, if[02/23/2018 18:41:08.4200] wired0: stopped
config down up
[02/23/2018 18:41:10.5000] wired0 emac 2: link up
[02/23/2018 18:41:10.5600] wired0: link up
[02/23/2018 18:41:10.6000] wired0: started
[*02/23/2018 18:41:10.6537] aptrace_register_sysproc_fn: duplicate registeration for 'wired'

Conditions:
- switch port speed is configured for 100Mbps (or, in some cases, a port configured for 1Gbps may come up in 100Mbps due to cabling)
- AP2802 or 3802 (problem does not affect IOS APs or 1800 series)

Workaround:
Change the switch port speed to 1000M, or use a power injector

 

HTH

Rasika

*** Pls rate all useful responses ***

Highlighted

Hi Rasika,

I still face this issue as below:

 

[*02/07/2019 22:46:53.8695] Resetting wired0 and

[02/07/2019 22:46:53.9000] wired0: stopped restart DHCP client

[02/07/2019 22:46:55.9900] wired0 emac 2: link up

[02/07/2019 22:46:56.0400] wired0: link up

[02/07/2019 22:46:56.0900] wired0: started

[*02/07/2019 22:46:56.1373] aptrace_register_sysproc_fn: duplicate registeration for 'wired'

[*02/07/2019 22:47:00.2431] Waiting for uplink IPv4 configuration

[*02/07/2019 22:47:05.2443] Waiting for uplink IPv4 configuration

 

cdp information on the AP:

AP00FC.BAC9.3F0A#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone, D - remote_managed_device
V - CVTA, U - Unknown

Device ID Local Intf Hold-time Capability Platform Port ID
Cisco_00:aa:45 wired0 179 H AIR-CT2504-K9 GigabitEthernet0/0/2

 

Software Version8.5.131.0

(Cisco Controller) >show interface summary


Number of Interfaces.......................... 2

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
-------------------------------- ---- -------- --------------- ------- ------ -----
management 1 untagged 192.168.1.73 Static Yes No
virtual N/A N/A 172.16.1.100 Static No No

 

On the controller, this is the cdp information

(Cisco Controller) >show cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater,
M - Remotely Managed Device

Device ID Local Intrfce Holdtme Capability Platform Port ID
AP00FC.BAC9.3F0A Gig 0/0/2 152 R T AIR-AP280 Gig 0

 

The connection i am using is PWRINJ6 - data out port to POE port of Cisco 2802E-D-K9 AP.

Data in to Port 2 of Cisco 2500 series WLC.

 

Please help to resolve

Highlighted

I had a similar issue with AIR-2802I unable to obtain an IP address via DHCP and join 3504WLC. Besides changing the software, you could try what I did which was assigning the AP an IP address manually, i.e.

capwap ap ip {ip_addr} {subnet_mask} {default_GW} {dns_srv1} {dns_srv2} {domain}

Ap was able to join WLC afterwards. 

Highlighted

I solved this problem by investigating the DHCP server.  It turns out conflicts on my DHCP server used up all the addresses.  The AP was cycling endlessly trying to get an address.  Once I cleared up the DHCP server, the AP connected to the controller and progressed as expected.

Highlighted

Keep in mind that this can happen again. This is known issue with Windows DHCP server and bad address. AP’s like the 3702 when unable to find the controller will request a new dhcp address.
-Scott
*** Please rate helpful posts ***
Highlighted

Hello all.

 

I'm getting the same error message described on the subject. This is the first time that happened with me.

 

So I'm using dell swiches. I got 20 2802i APs connected and working and one of them is with this message.
aptrace_register_sysproc_fn: duplicate registeration for 'wired'

 

from the swich side I got 100Mbps Half duplex (with autonegotiation on). all the other ports negotiated at 1000Mbps Full Duplex

If I use another 2802i AP in the same switchport it works fine. I got 200x 2802i APs working, only this one with error.

Even though the AP gets connected to the WLC after a while, but still on half duplex mode 100Mbps

 

If I fix the speed to 1000Mbps in the port configuration, the AP keep the same message. I don't have any power injector in this site to test.

Software version 8.5.140.0 for all APs

 

Any other hint?

Highlighted

Hey,

Please check the DHCP server settings in the controller.
Highlighted

If the DHCP hint from arunkr doesn't help, RMA the AP, might be broken.
Highlighted
Beginner

Hi,

 

I got the same issue on cisco 2802 and assume this is related to a missing configuration on DHCP server.

I was able to solve by adding a default-router to the DHCP scope:

 

ip dhcp pool MANAGEMENT
SW(dhcp-config)#def
SW(dhcp-config)#default-router 192.168.1.1

 

Issue was AP looping DHCP client:

AP2800-TEST#capwap ap [*05/02/2019 06:52:26.7989] Waiting for uplink IPv4 configuration
[*05/02/2019 06:52:31.7999] Waiting for uplink IPv4 configuration
[*05/02/2019 06:52:35.8006] Resetting wired0 and[05/02/2019 06:52:35.8300] wired0: stopped
restart DHCP client
[05/02/2019 06:52:37.9100] wired0 emac 2: link up
[05/02/2019 06:52:37.9600] wired0: link up
[05/02/2019 06:52:38.0100] wired0: started
[*05/02/2019 06:52:38.0662] aptrace_register_sysproc_fn: duplicate registeration for 'wired'
[*05/02/2019 06:52:39.0738] Waiting for uplink IPv4 configuration
[*05/02/2019 06:52:44.0748] Waiting for uplink IPv4 configuration
[*05/02/2019 06:52:49.0758] Waiting for uplink IPv4 configuration
[*05/02/2019 06:52:53.0765] Rese[05/02/2019 06:52:53.0800] wired0: stopped
tting wired0 and restart DHCP client
[05/02/2019 06:52:55.1800] wired0 emac 2: link up
[05/02/2019 06:52:55.2400] wired0: link up
[05/02/2019 06:52:55.2800] wired0: started
[*05/02/2019 06:52:55.3416] aptrace_register_sysproc_fn: duplicate registeration for 'wired'
[*05/02/2019 06:52:56.3527] Waiting for uplink IPv4 configuration
[*05/02/2019 06:53:01.3537] Waiting for uplink IPv4 configuration
[*05/02/2019 06:53:06.3548] Waiting for uplink IPv4 configuration
[*05/02/2019 06:53:10.3555] Resetting wired0 and[05/02/2019 06:53:10.3800] wired0: stopped
restart DHCP client

 

Regards,

Tom

(CCNP R/S)

Highlighted

Well, I tried with 5 other APs on the same switchport, and all of them work, but not the faulty one.
I will open an RMA.