Showing results for 
Search instead for 
Did you mean: 

NCS unable to communicate with MSE

Level 1
Level 1


I am trying to add a MSE 3300 to the NCS from the management console.

The MSE is at (eth0) and the NCS is at

I am able to ping the NCS from the MSE. There is no firewall between these two.

'msed' is up and running as verified by '/etc/init.d/msed status'

'eth0' is up and running as verified by /etc/init.d/network status'

I ran the setup utility in the MSE and set the NCS communication userid/password to 'admin/admin' which is the default. I rebooted and restarted the msed service.

In the NCS, I do (Services->MObility Services Engine -> Add Mobility Services Engine -> Go)  and then set the IP, username, password.

At this point, the message I get back is 'No response from the Server. It may be unreachable, or server is down or HTTPS connection to server failed'

So, what am I not doing correctly? Both the NCS and MSE are on the same subnet and no firewall.  Any help please?

12 Replies 12

Scott Fella
Hall of Fame
Hall of Fame

I would rerun the setup script and when it ask for the communication username and password, enter 'D' IIRC is to set it back to default. Don't enter admin/admin... I ran into issues trying to change this. Then the MSE will be restarted and try again.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***

Thanks for your response Scott.

Just tried what you suggested and still no joy.

I poked in the NCS logs and I am getting a message 'Handling ServerEngineUnreachableException, reason:

RAW PING to Port: 443 failed" where is the MSE device.

Then it tries to ping port 8001 and fails.

I logged in NCS via SSH and pinged and it works. So I am not sure what is going on.

Well that is how I have delt with that issue in the past.  When your trying to add the MSE, your not touching the default username and password for the WCS communications are you?  The only thing else I would try is to rerun the startup and reboot the MSE and maybe restart the NCS and see if that helps.



Help out other by using the rating system and marking answered questions as "Answered"

*** Please rate helpful posts ***

No, I am not changing the default user/pwd for NCS communication in the MSE setup. I have re-run the setup script and rebooted about 4 times today. No luck.

Would there be any issues with iptables on the MSE, that I can check?


I'm talking about in NCS when you add the MSE. The defaults are hashed in there and I don't touch that. Also I should of mentioned is that I reboot the appliance not just restart the service.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***

Is your MSE and NCS the same version?

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***


You could ping it but if port 443 is blocked the add operation would fail. NCS uses 443 & 8001 to communicate to the MSE.

From the NCS server's CLI, try

telnet port 443

does it connect ?

Also, make sure there are no iptables (host based firewall on Linux) setup on the MSE side to block these ports ? The command "iptables -L" would list the rules & "iptables -F" would flush the rules.


@Scott - I power cycled the appliance not just a reboot. Here's the versions that I have

MSE: 7.2.110


@Ram - I checkd port 443, 8001 and for port 443, I get a connection refused error and at 8001, it connects.

I checked the iptables and these ports were not blocked.

I am currently re-installing the MSE image so I can go back to factory default and then try again. Hopefully, this shouuld work.

Thanks very much for your responses

I just went through this with TAC.  Don't know why, but during the join process, I was selecting the 'http' radio button (think I saw that in the documentation somewhere?).  Each time it failed with the "No response" error.  Once we left that box unchecked, the MSE joined no problem.  Since this was my first one, I put together this little cheat sheet.  If anything in here is wrong, feel free to comment.  Hope this helps!


Upon first boot, run through the automated script.  The MSE uses ‘admin | admin’ as the default to communicate with the NSC/PI server.  This is a DIFFERENT function from using the ‘root’ username and password to log in via the CLI.  THERE IS NO GUI FOR MSE!!    The ‘http’ and ''https' status shown when you type getserverinfo is the protocol used to communicate with NCS.  By default, the MSE has http disabled and uses https.  When you go to add the MSE into NCS, DO NOT check the box that says “http”.  That will cause your join to fail.  The NCS is configured to search for the MSE on https, and the MSE is configured to respond on https.  If you later need to change this due to port issues, you have to do this from the GUI of NCS.

To re-run the setup script:  Telnet to the MSE.  At the command prompt, type:


To check status:

/etc/init.d/msed status

To restart the service:

Step 1 /i/templates/blank.gifTo stop the software, enter /etc/init.d/msed stop.

Step 2 /i/templates/blank.gifTo check status enter /etc/init.d/msed status.

Step 3 /i/templates/blank.gifTo start the software, enter: /etc/init.d/msed start.

To make the service start on bootup:

chkconfig msed on

To join the MSE to NCS/PI:

Log in to NCS

Services | Mobility Services

Select a command | Add MSE

Once added, reachability status should say Reachable

On the left, step through each of the catagories:


Select Service


Assign Maps

Next, Click Synchronize Service under the Services tab

On the left, click controllers.  Choose the controllers you want to have feed the MSE

Click Network Designs on the left

For EACH map on the right:

                Open one of the maps from your facility (you could have multiple maps per location, just choose one)

                Open the map

                On the left, click MSE assignment

                Click the Change Assignment button

                Select your MSE, then click the Synchronize button

                You should now see two green opposing arrows under the Synch Status column

                When you click Services | Synchronize services, you should now see all maps for that facility synched

It may take a while for the MSE to synch with the controllers and NCS.

Open a map.  On the left side,  make sure Clients is checked.  You should now see the location of your clients!

I try to follow all your step but still i got issue. once i check our MSE status, below is the output. is there any command to enable the HTTPS or HTTP?

Two years after your post (on 7.6) an "iptables -F" got me moving on the install. Thanks.

I have PI 2.2.1 and CMX 10.3 for MSE. when adding MSE on PI it shows error. when I browsing to MSE via 8001, refusing connection. there is no and getserverinfo binaries.

Review Cisco Networking for a $25 gift card