Showing results for 
Search instead for 
Did you mean: 

roaming of clients not working as expected

I've just deployed a new solution and im experiencing issues with clients not roaming properly. 

Access points are installed really close to eachother. There is 6 access points loated around the premises. 

For example im in one room, i can see that im connected to access point 1. If i walk to the next room i will still be connected to access point 1 event though im closer to access point 2. I can see a drop in speed also. If i switch off WIFI and turn it back on im being connected to access point 2 and get the proper speed. 


Network info:

Software running:

Fast SSID: enabled

RF Optimization: Enabled

Traffic Type: Voice and Data


CLients i used to test is using Intel NIC  (AC-7260, driver date 2017-october-01) 


Any ideas on what the problem might be or where i can start looking into this?

Hall of Fame Community Legend

Intel NIC?
By default Intel NIC has a setting called "Aggressive Roaming" and this is set at "2" (out of 5). Change the setting to 3 and see if it improve things.

Hi @Cisco SE,


Very important to understand it's the client's decision to which AP will roam.

You can only influence this decision using:

  • 802.11r;
  • 802.11k;
  • 802.11v;
  • you're saying the APs are quite close one to the other, you may want to disable the lower data rates on the controller - this is quite a powerful feature and I think will work for you. Check the link speed while you are in the other room, this way you will know what to disable.

You may want to ask your users to "forget" the network and rejoin, after enabling/adjusting the roaming features.





Forgot to mention that the same issue happens on a brand new Samsung Galaxy Note8.


I checked the setting and aggressive roaming is set to 3 already. 


How do i disable the lower rates? Im not running a WLC, using the builtin mobility express controller. 



Hall of Fame Community Legend

Another thing, upgrade the firmware of the ME.

I evaluated Mobility Express (AP2802i and various firmwares including latest and recommended) and found roaming totally broken on most devices.. the clients simply would not roam, even under extreme RF design e.g. 15dB above/below the known roaming characteristics of the client.

Disabling 802.11k, v and r (must be all of them) was the solution, so something about this in ME seems broken and preventing roaming rather than assisting.

Other vendors' roaming with 802.11k,r,v engaged worked perfectly in the same evaluation and conditions.



Impossible. Pretty sure you're missing something.

Wondering what type of authentication you configured on the SSID and how are you handling the FT.




Also what firmware on the AP. There were several improvements to those roaming features in the last few years.

As I posted, I tried various firmwares including latest and recommended (Cisco's suggested release). Please see Cisco's software portal for the release numbers.


I have the APs for a further 24hours or so, I can test any configuration you wish.


Fresh retest this morning: 2 x AP2802i, Mobility Express (Cisco’s suggested release)

1: factory reset

2: CiscoAirProvision Settings: Employee network (default), WPA2 Personal (default), RF Parameter Optimization off (default)

3: GUI settings: WLAN Radio Policy 5Ghz only

4: 802.11k enabled, 802.11v enabled, 802.11r adaptive (all default)


Connect single client = iPhone 5s (802.11kvr, no adaptive 802.11r, latest iOS) at location 1

Roam to location 2  (source AP -85dBm, target AP -51dBm)

…. takes 5 minutes before roam occurs!

Repeat 10 times, same result



WLAN 802.11r enabled (not adaptive), iPhone 5S = roaming still broken

WLAN 802.11kvr disabled, iPhone 5S = roaming works perfectly

WLAN 802.11kvr enabled, MacBook Pro (no 802.11kvr) = roaming works


Changing to WPA2 enterprise is still broken but not so bad (no roaming under normal expected conditions, roams after 30 seconds not 5 minutes with extreme roaming conditions… )


Other vendors have no problems with the same clients and conditions.




Can you give us some little more information about how is the configuration set?


- Are you using RF groups?

- Which configuration do you have on your RF groups if you are using it?

- Which beacon are you using?

- Which rates are allowed?

- Are you talking a dual band SSID or a single one?


I'm guessing the problem could be located on the RF and maybe on the AP that you are sending a lot of TX power.


On the same way I see you roaming took 30 seconds if you have the FT disabled, can you confirm if you have the option to FT ADAPTATIVE ? Just for the MACOS be aware the MAC will roam when the signal will decrease till - 70 dBm.


If you provide a little more information about the RF configuration maybe we can help you more :)





All the information you ask for is contained within my post.

If you need to know the features of ME for the release (such as RF groups) please look it up.

If you need to know if I changed anything other from default after factory reset other than what is detailed, the answer is no.

I never said 30 seconds roam with FT disabled.

You're wrong, MacOS looks to roam at -75dBm not -70dBm... anyway it is irrelevant because I said it roams as expected.

Transmit power has no bearing as the client RSSIs are reported. In any case, different power levels were tested in order to control RSSI including Tx power of 8dBm, so that theory is also wrong.


Thanks for your input.

Content for Community-Ad