05-15-2012 06:35 PM - edited 03-12-2019 09:46 AM
TITLE
Unable to share desktop on Jabber for Windows.
SYMPTOMS
The Desktop Sharing Option is grayed out in the Chat Window.
ENVIRONMENT
Cisco Jabber 9.0.1
Cisco Unified Communications Manager 8.6.1 and 8.6.2
Cisco Unified Presence Server 8.x (On-premises deployment)
Cisco WebEx Connect (Cloud based deployments)
CAUSES
To configure Cisco Unified Communications Manager for video desktop sharing, you need to apply a COP file to Cisco Unified Communications Manager and enable video desktop sharing on the SIP profiles of CSF devices.
RESOLUTION
Configuring Desktop Sharing on CUCM 8.6.1 -
On the CUCM Admin page –
Configuring Desktop Sharing on CUCM 8.6.2 -
On the CUCM –
1. Upload and apply the ‘cmterm-bfcp-e.8-6-2.cop.sgn ‘ COP file for desktop sharing, you can download the Admin folder on the following link to get access to the same.Note: - As of this release, Cisco Jabber for Windows supports video desktop sharing in software phone mode only. Video desktop sharing is not available in desk phone mode.
- You cannot enable video desktop sharing on the default SIP profile. You can copy the default SIP Profile and save it as a new one.
RELATED TOPICS
Hi i only see the jabber msi in the jabber admin file , I dont see a ccm folder with cop files in. Please advise, obviously doing something wrong here.
So this COP file needs to be installed on all the callmanager servers in the cluster and then rebooted. Is that correct? Does this file need to be installed on the Presence (CUP) server?
Yes, that's correct. You need to do it first on the CUCM publisher, reboot server, be shure there's no problem with installation and after that you need to do it on the CUCM subscriber(s). Just need to install file on the CUCM cluster, not on CUP.
I am just curious - will this eventually extend to other SIP devices as well (i.e. 8900 and 9900 series video phones?)
It would be great to share your desktop to a deskphone or enduser to assist with a helpdesk ticket (i.e. - look here, click on the button that looks like this etc.) especially if there was a preference to allow selection of a bounding box area of your screen, or follow the mouse on your screen for the video feed.
This issue was resolved for me as of the 9.2.2 release of the Cisco Jabber IM Client (was still occuring as of 9.2.1).
Sana,
Small correction on procedure described in this document. When updating CSV file to allow desktop sharing, value should be changed to T and not Y:
- Set the value of the column to Y for all required devices. <<<--------- Wrong, it should be T
Regards,
Tijana
I would like correct above doc under " Configuring Desktop Sharing on CUCM 8.6.2 "
Enable video desktop sharing capability on the appropriate devices as follows –
For an individual device, select Allow Presentation Sharing Using BFCP and then select Save
For multiple devices, do the following –
- Select Bulk Administration > Phones > Export Phones > All Details.
- Select Bulk Administration > Upload/Download Files and download the exported CSV file.
- Open the CSV file with any editor.
- Insert a column named Allow presentation sharing using BFCP into the CSV file.
- Set the value of the column to Y for all required devices. <<<-----the value should be "T " not " Y"
- Save the CSV file.
- Select the Override the existing configuration option.
- Import the CSV file.
Updating the post for 9.X versions of CM. As per the below statement and document, in CM 9.X and greater, the COP file is not longer needed, since BFCP presentation is enabled by default.
Cisco Jabber for Windows 9.2.x Server Setup Guide - Set Up On-Premises Deployments with Cisco Unified Communications Manager Version 9.x and Higher
On Cisco Unified Communications Manager version 9.0(1) and higher, BFCP presentation sharing is automatically enabled
This post (and all the Cisco docs I could find) neglect to mention that any firewall or IPS software running on the PC (like Symantec or Mcafee) needs to be configured to allow UDP port 5070 in and out of the PC. I followed all the instructions, but I ended up doing a Wireshark capture with the firewall off to confirm exactly what was happening (UDP 5070 to negotiate BFCP, then h.264 in RTP packets).
So don't forget to update your host-based firewall to permit UDP port 5070 in and out for BFCP.
Ryan
Try this steps-
- Select Device >Device Settings >SIP Profile.
- In the Trunk Specific Configuration section, select Allow Presentation Sharing Using BFCP.
- Select Save.
- Select Device > Phone on an individual device.
- Open the Cisco Unified OS Administration interface.
- Select Settings > Version.
- Select Restart.
-Try again
Greeting,
Rachel Gomez
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