Showing results for 
Search instead for 
Did you mean: 

CTI warning: The request failed because the timeout limit was exceeded.



For a perticular IP Phone extension when agent is going to login using CTI agent toolkit then CTI generatin this msg "CTI warning: The request failed because the timeout limit was exceeded". but the other ph is working fine. I have deleted this phone and add againg. And the ph re-associate with PG and JTapi user. but still have the prob. For more plz see the find attached.

11 Replies 11

VIP Advocate VIP Advocate
VIP Advocate

check that the CTI desktop installed correctly. can you ping the pg ips? can you try to log in to a different phone from that computer? finally, replace the phone and try again. However, i'm sure it's something with the desktop and not the phone.


Thanks for ur reply. After delete the ph configuration 2nd time and after add again and associate with pg and jtapi user its working fine.


I have the same problem here but we are using the IP Phone Agent.

Sometimes, it's working, sometimes not and we receive an kind of CTI request timeout ?!

Do you have an idea?

Thanks you in advanc,e


I am facing the same issue . I have tried to delete the phone configsurations and the re associated them to the PG User but Stil am not able to log in and it says request time out limit exceeded.

I did a work around as bouncing my JTAPI Process on the PG boxes. but unsure why this is happening time again.

I could see an error message on JTAPI as the phone extension is not in service but the physical phone is up and running..  any ideas

Kris Lambrechts

Your first troubleshooting step here should be to check what JTAPI Gateway thinks is the state of that extension, you can easily check that through procmon. Here's an example from my lab.

C:\Documents and Settings\Administrator>procmon ipcc pg1a jgw1
>>>>jdi 2000
Addr: 2000      ActiveLines: 0          RegistrationState: IN_SERVICE
        m_CurrentInvokeID = 0
        m_elapsedTPServicesRequestSeconds = 0
        queuedDTMFDigits = null
        sendingDTMFInProgress: N
        sendQueuedMsgAddCallObserverResponse: Y
        monitoredVirtualDialerPort: N
        virtualDialerPort: N
        loggedInAgent: N
        DeviceStatus : UnmonitoredDevice
        addressDeviceType : GWMSG.DEVICE_TYPE_DEVICE
        observeredTypeString : logged Out Agent Device
        isAddressRestricted: N
        addressDeviceProtocol : PROTOCOL_SCCP
        silentMonitorStatus : 0
        silentMonitoredCallID : -1
        TerminalName : SEP001BD52C547F

The RegistrationState should be IN_SERVICE for a phone that is registered with CUCM. If you can see that the phone is registered with CUCM in it's adminsitration pages, made sure that it's in the list of associated devices, made sure you're running the correct version of the jtapi plugin and still see it as OUT_OF_SERVICE, you're probably looking at a CTI Manager defect. CSCti07947 and CSCti11651 spring to mind but there are probably a couple more.

Most of these defects should be fixed in releases like CUCM 7.1(5), 8.0(x) and up. If the issue persists, you're probably best off opening a TAC Service Request to identify the exact cause. The PG (JTAPI Gateway) only shows you what it gets from CTI Manager, so as you can see from my above observations, you'd want to focus your troubleshooting on the CUCM end.

Thanks Kris,

I have a raised a TAC Case and the engineer advised me to remove the CTI Allow controll all devices from the permission of the PG user  and to restart the CTI Manager the CUCM PG service.

Upon doing it i still face the same issue. I Did the Procmon to find the device state and it says as Out of Services for the Phones iam not ablke to log in.

Also this error occurs only for Extension Mobility users. the other Phone users are normal and i am not having a probelm. if the Agent log out of the extension mobility  and re logs back in he is not able to log in. this does not happen for all of the Extension mobility users it happens random and there is no pattern for this.

According to the BUG iD which you shared with me I tried the work arounds but the probelm still persits..

Going on with the TAC for hours...

Did you receive any more information on this issue from TAC? I seem to also be suffering from this. After a WAN outage the agents try to log back in and fail to do so. Looking at the desktop logs and i see "The request failed because a timeout limit was exceeded."

Kris Lambrechts

Actually I can chip in here. I've been working this week on a TAC SR where we've identified a new defect on CUCM 6.1(5), where this is behavior is triggered through Extension Mobility. Whenever a user logs into the phone who has 'Allow Control From CTI' unticked on a user level, the 'Allow Control From CTI' field for the phone stays disabled on the phone level, even if it is ticked in the Admin pages. Hence the PG can't control the phone and it keeps showing as OUT_OF_SERVICE.

There is no defect yet, I'll try to remember to update the thread. But there is a work-around :

1. Disable Allow Control from CTI on device level and reset the phone
2. Enable Allow Control from CTI on device level and reset the phone
3. Disassociate the phone from the application user (pguser)
4. Associate the phone to the application user (pguser)

So go and give that a try for now.


Hi kris,

We running on CUCM version 8.0(3) with the lastest patch and facing the same issue only with extension mobility phones.

Tac engineer asked us to associate the phone mac address with PG USER but it didnt work.Is it necessary to added the mac address ?

After that we've tried your workaround chip and it solved the issue.I am able to see the Registration state as IN service and the agent is able to log in.

Escalated the case to developer team and hoping to get any resolution on this.

Thanks Kris.


Hello Kris,

Do you have any inputs from your end? did you get any other info regarding this issue. the temp fix which you had provided seems to resolve the issue tempoarlily but need a permanent fix for this.

the JATPI developers from CUCM and IPCC are working on this currently. Thought if you could provide some inside thoughts on this.




This is Vishal M,

We are having CCM Version 6.1.5

Just now I have rebuild the Subscriber and registered some IP Phones on that; now I am unable to lo login in the the instrument which are registered on new installed subscriber.

Getting error as “CTI warning: The request failed because the timeout limit was exceeded.”

As per the document I have tried to remove and add the ext. in PG user but still I a unable to login;

Please help how to resolve this.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers