cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14720
Views
86
Helpful
66
Replies

CUIC on a UCCX - Dataset status is Failed. (Database error)

Kim Nielsen
Beginner
Beginner

Hi,

Suddenly this Saturday, some of our rapports stopped working. Detailed call by call CCDR report is working, when you choose today, but when you choose yesterday, we are getting a "Dataset status is Failed (Database error).

Details on the error is:

Error information:
com.cisco.ccbu.cuic.businesslogic.datasource.CuicDbException: DbException: CuicDataSourceServiceManagerImpl.getDataSet() { Nested SQLException; SQLState: IX000 Vendor code: -1265 Message: Overflow occurred on a datetime or interval operation. } at com.cisco.ccbu.cuic.businesslogic.datasource.CuicDataSourceServiceManagerImpl.getDataSetBuilder(CuicDataSourceServiceManagerImpl.java:860) at com.cisco.ccbu.cuic.businesslogic.engine.CuicReportEngineWorker.executeQueryUsingDatasetBuilder(CuicReportEngineWorker.java:659) at com.cisco.ccbu.cuic.businesslogic.engine.CuicReportEngineWorker.runReport(CuicReportEngineWorker.java:503) at com.cisco.ccbu.cuic.businesslogic.engine.CuicReportEngineWorker.run(CuicReportEngineWorker.java:458) at com.cisco.ccbu.infra.threads.InstrumentedRunnable.run(InstrumentedRunnable.java:88) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) at java.lang.Thread.run(Thread.java:662) at com.cisco.ccbu.infra.threads.ThreadPoolThread.run(ThreadPoolThread.java:164) Caused by: java.sql.SQLException: Overflow occurred on a datetime or interval operation. at com.informix.util.IfxErrMsg.getSQLException(IfxErrMsg.java:407) at com.informix.jdbc.IfxSqli.a(IfxSqli.java:3461) at com.informix.jdbc.IfxSqli.E(IfxSqli.java:3774) at com.informix.jdbc.IfxSqli.dispatchMsg(IfxSqli.java:2580) at com.informix.jdbc.IfxSqli.receiveMessage(IfxSqli.java:2496) at com.informix.jdbc.IfxSqli.a(IfxSqli.java:1766) at com.informix.jdbc.IfxSqli.executeStatementQuery(IfxSqli.java:1704) at com.informix.jdbc.IfxSqli.executeStatementQuery(IfxSqli.java:1635) at com.informix.jdbc.IfxResultSet.a(IfxResultSet.java:206) at com.informix.jdbc.IfxStatement.executeQueryImpl(IfxStatement.java:1229) at com.informix.jdbc.IfxPreparedStatement.executeQuery(IfxPreparedStatement.java:395) at com.informix.jdbc.IfxCallableStatement.executeQuery(IfxCallableStatement.java:238) at com.mchange.v2.c3p0.impl.NewProxyCallableStatement.executeQuery(NewProxyCallableStatement.java:2131) at com.cisco.ccbu.cuic.businesslogic.datasource.CuicDataSourceServiceManagerImpl.executeAndLoadDataset(CuicDataSourceServiceManagerImpl.java:978) at com.cisco.ccbu.cuic.businesslogic.datasource.CuicDataSourceServiceManagerImpl.getDataSetBuilder(CuicDataSourceServiceManagerImpl.java:846) ... 8 more Caused by: java.sql.SQLException at com.informix.util.IfxErrMsg.getSQLException(IfxErrMsg.java:407) at com.informix.jdbc.IfxSqli.E(IfxSqli.java:3779) ... 20 more

I have tried to restart the CUIC service, but no change. It's still giving me this error.

I'm thinking that it's having something to do with the date/time, because of the "1265 Message: Overflow occurred on a datetime or interval operation" that is seen in the error.

But I can't seem to find any info on this error, other than it's some kind of date/time error in the Informix database.

Anyone else seen this error? (It's an 9.0(2) version of the uccx.)

Br

Kim

66 Replies 66

Is this COP file published? I can't find it anywhere??? Or is it only available via TAC case?

It's attached right here on this page. Look above for Arnayyar's comment.

Hi,

I have the cop file applied to my UCCX 10.6 long bck and everything was working fine until now I cant get report for 1/11 like any detail report CCDR or Agent CSQ for 1/11 or 1/12 I can get that for 1/13.

I also put some other sql commands which I faced for some other issue.Should I remove the cop file and re add it back.

Has someone faced this ??

Regards,

DJ

just got the answer from TAC:

Hi Daniel,

 

My name is Simranjeet Singh and I have ownership of Service Request 680929771. I am sending this e-mail as an initial point of contact.

 

Problem Description:

Data Set Error: "overflow occurred on a datetime or interval operation"

 

Action Plan:

This is an outage. All customers are experiencing this issue. As a solution, download and apply the attached cop file. This is applicable from any version from 8.x to 11.x.

 

Please download the cop file for the bug fix and save it an SFTP server. Applying this cop will NOT cause any service impact and no reboot or switch-version is required.

 

Let me know if you need assistance applying this cop which is the solution to this issue.

 

Instructions: Please refer readme for more:

 

  • Save the cop.sgn to the root of the SFTP directory.
  • Run utils system upgrade initiate on both Nodes one by one incase of HA and just one Node incase of standalone.
  • Choose the cop file and let it install.

Close web browser and run CUIC and the reports should be working after this solution.

It's an ES, anyone is willing to install this?

Did they tell you what the "outage" was?  Seems odd that an on-prem app could be impacted by anything external, so I was thinking it's more likely a design issue with that part of the database.

Reason for the failure:

"Due to the code, dates later than 09/08/2016 will generate a negative value and the report generation fails"

 

This is Document sent by TAC

Okay, thanks

Booby, whats the name of the cop file and did it fix the issue?

Mike Iversen
Beginner
Beginner

I too am experiencing this error. Version 9.0(2) as well. Started last week.

Unable to view bug as well,

Getting: Insufficient Permissions to View Bug

kenobiwan
Beginner
Beginner

Same issue but 09/09/2016 is the known troubled date for us thus far. We can pull error-free reports before this day or after this day.

System Version:10.6(1) build 1 (10_6_1_11002_15)

Paul McGurn
Frequent Contributor
Frequent Contributor

Same here, same start date to my issues, though they are still occurring.  I have no issues with Agent State Detail reports, but Detailed Call CSQ Agent fails.

We're on 11.0.1.10000-75.

Joseph Thvedt
Beginner
Beginner

Same here on CCDR. Also on Agent State Summary Report. Can't run any date from 9/9/2016 to at least 9/12/2016. Haven't tried tomorrow's date yet...

UCCX 10.6.1.10000-39

Patch worked for me.

David Tigue
Beginner
Beginner

Our Agent State Detail report is good up to 9/7/2016, then it appears no date working after that.
I believe there are other reports with the same issue.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers