cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1206
Views
15
Helpful
14
Replies

Menu Option in UCCX not responding

Good Morning,

 

I'm working on editing a script for our Contact center. My end user wants to allow the callers to have an option to press 1 to leave a voicemail. I've been watching videos and learning how to write these scripts but when I call and get put in the queue and enter 1 on my phone it never actually goes to one.

I put the Menu option in the queued loop and I know I'm in the correct part of the script by the prompts I hear, "position in queue is...." but I can press 1 and it still continues to play. I made it interruptible and set the filter connection for 1 to go to my voicemail tag but the system seems to ignore my input. 

 

Any ideas on what is missing or why I can't press any numbers? 

Attached is a picture of the menus and the call redirect it's going to. 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Anthony Holloway
Cisco Employee

I mean, on the surface it sounds like you're pretty close, albeit you're confusing uninterruptible with barge. Barge allows you to press a key during prompt playback, while uninterruptible just means that the step will abruptly end should an Agent become available during step execution. However, you will also need to know about input buffers if you are trying to press 1 before the menu step is actually executing. If you press it during the play prompt just above it, then the flush input buffer on that step should be set to no, as well as the menu step, it too needs flush input buffer set to no as well.

View solution in original post

Yeah...  only part of the details here, so kinda hard to really determine. 

Next steps, if you are going down the correct branch for the menu options, is to determine if your redirect step is the problem.  Does your GoTo Step go to the correct label?  Is your CTI answering port (group) configured with a Call Search Space for the Voicemail service target / partition?  Is your Voicemail pilot the variable to which you are transferring?  Is it a STRING variable (we can't see your variable pane, so the question needs to be 1asked).  Is the voicemail pilot extension in quotes sExtension = "7000".  Do you have the target voicemail box extension set as a STRING variable.  sExtVoiceMailBox = "12345".  What errors are you seeing in the reactive debug?  Does script crash when you cross over a specific step?  Does the system speak an error to you on the output step when the script stops?  What is the system message?

 

Example:  Call Redirect to Voicemail system pilot extension and Voicemail Box recipient Extension

2020-0410-transferToVM.png

 

Hope this helps.

-Sean

View solution in original post

14 REPLIES 14
Anthony Holloway
Cisco Employee

I mean, on the surface it sounds like you're pretty close, albeit you're confusing uninterruptible with barge. Barge allows you to press a key during prompt playback, while uninterruptible just means that the step will abruptly end should an Agent become available during step execution. However, you will also need to know about input buffers if you are trying to press 1 before the menu step is actually executing. If you press it during the play prompt just above it, then the flush input buffer on that step should be set to no, as well as the menu step, it too needs flush input buffer set to no as well.

View solution in original post

Thanks for the quick response.

I realized about the Barge and interruptible differences after I posted. I set all of my buffers to No in the loop as you can see in the comments in the below picture. Still getting the same results. Note I am refreshing the scripts and application once reloaded into UCCX. 

 

I found online some articles referencing the Get digit command but read it was really only needed if you had more than 1 digit in your menu option. Do you think I would still need that as a placeholder for the variable? 

 

I apologize in advance, I'm new to all of this UCCX scripting and have no training. 

 

Also, here is a link I found a cisco guide to all of the script commands if anyone else is lost in the forum to help, contact center seems to be hard to find guides online.  https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/crs/express_11_0/programming/guide/EditorSeriesVol2.pdf

 

 

 

I would recommend you to do a reactivate debug of your script to see if you actually reach the menu step and what happens when you press 1.



Response Signature


Did you actually assign key press 1 to the branch in the menu step properties like Sean shows in his screenshot? Otherwise, are you maybe having DTMF issues in your network? Does any menu work from your phone?
Sean Lynch
Rising star

…I'm in the same frame of mind as Roger.  You say you select '1' from the menu option but it doesn't redirect.  It is probably the filter is not selected as you say it is.  It can't go down that branch unless you assign the button to the menu option you added.  This doesn't show on your image, so I thought I'd just second guess it.

2020-0409-menuFilterSelected.png

 

...easy to miss.  Easy to fix.  If this isn't it, then no harm to double check.

 

Hope this helps.

-Sean

 

Thanks for the debug tip Roger! I didn't know I could do that and it really helps locating issues. 

 

I did the reactive debug and I'm able to get to the menu step, once there and press 1 on the phone, nothing happens on the phone but it is jumping to 1- Voicemail step and the Set Extension part (see image SupportCenterReactiveLog) but nothing is happening after that. 

I also verified that the dial pad 1 is selected in the menu properties (see image SupportcenterMenuOption). 

 

My guess is it has to do something with that Set Extension not holding the digit or moving onto the next step automatically. If i force it to go to the next step, it will go to my call redirect which calls my voicemail as expected.

Note: I have tried this on an internal and external phone. I also have tested this with another prompt management queue in UCCX and when I press a number on the dial pad it is going to the respective call redirect. 

That sounds really weird. I'm not sure i even understand what you're describing though. Let me know if you're comfortable with it and I can setup a webex for you and I to look at it in real time. Sean and Roger are welcome to participate as well!

From the video I had watched, the variables are something that I think I'm confusing myself with. The Set Extension = voicemailredirectnumber which has my voicemail number hardcoded into it. 

 

I'd be happy with a webex session. Would you PM the link? I work until about 4pm CST.

 

Thanks!

Yeah...  only part of the details here, so kinda hard to really determine. 

Next steps, if you are going down the correct branch for the menu options, is to determine if your redirect step is the problem.  Does your GoTo Step go to the correct label?  Is your CTI answering port (group) configured with a Call Search Space for the Voicemail service target / partition?  Is your Voicemail pilot the variable to which you are transferring?  Is it a STRING variable (we can't see your variable pane, so the question needs to be 1asked).  Is the voicemail pilot extension in quotes sExtension = "7000".  Do you have the target voicemail box extension set as a STRING variable.  sExtVoiceMailBox = "12345".  What errors are you seeing in the reactive debug?  Does script crash when you cross over a specific step?  Does the system speak an error to you on the output step when the script stops?  What is the system message?

 

Example:  Call Redirect to Voicemail system pilot extension and Voicemail Box recipient Extension

2020-0410-transferToVM.png

 

Hope this helps.

-Sean

View solution in original post

That "Called Address" was set to destination and not my voicemailredirect. After changing that suggestion from Sean, it is working. 

Also, I believe the no buffer helped fixed my issue as well!

 

Thank you Anthony, Sean and Roger for all your help!

the way you described the debugging:

"it is jumping to 1- Voicemail step and the Set Extension part (see image SupportCenterReactiveLog) but nothing is happening after that."

Makes it sound like it never made it to the Call Redirect step in the first place. Your screenshot is even paused on the Set step, thus confirming you couldn't even make it to the Call Redirect step.

Now that you say you solved it with a change to the Call Redirect step, what do you think was causing your debugging to not progress past the Set step?

+5 all round. Sean, Roger, Anthony. I have not touched ccx in a while having been focused on the cce solution. Great to see your contributions guys, it's exemplary.

By the way do you guys know anyone with Oracle SBC skill set? Need some help.

Please rate all useful posts

Thanks Ayodeji. I try to be an Engineer and not just an Installer! ;)

And sorry, no, I don't know anyone with Oracle SBC skills.

 

EDIT: I see that Roger and I both had your name spelled with a "G" instead of a "D"  I think it was auto corrected, however, I cannot reproduce the scenario.  In fact, when I look at the spelling suggestions, "Yodeler" is suggested for your name.  :/

 

My apologies for the typo.

Thanks Ayodeji, appreciate your acknowledgment of my effort.

Sorry no I don’t know anyone that has experience with Oracle SBC.



Response Signature


Create
Recognize Your Peers
Content for Community-Ad