Showing results for 
Search instead for 
Did you mean: 

BLF Issue with CME

Level 1
Level 1

Hi team,

I have an issue with a IP Phone 7975 with a 7916-24 extension module.

I configured the phone with 12 BLF, but only the first 7 are working.

This is the configuration :

ephone  1

device-security-mode none

mac-address XXXX.XXXX.XXXX

presence call-list

blf-speed-dial 1 250 label "USER1"

blf-speed-dial 2 425 label "USER2"

blf-speed-dial 3 445 label "USER3"

blf-speed-dial 4 156 label "USER4"

blf-speed-dial 5 205 label "USER5"

blf-speed-dial 6 784 label "USER6"

blf-speed-dial 7 123 label "USER7"

blf-speed-dial 8 478 label "USER8"

blf-speed-dial 9 789 label "USER9"

blf-speed-dial 10 459 label "USER10"

blf-speed-dial 11 789 label "USER11"

blf-speed-dial 12 458 label "USER12"

type 7975 addon 1 7916-24

button  1:15 2:12

I can change the order of the BLF as I want but it's always the same result, 7 first BLF work and 5 last don't...

I think it's not an extention module issue because the first BLF on the module work fine.

When I look at the debug ccsip message, I saw that the phone send a subscription for the 7 first BLF of the list but nothing is sent for the 5 other BLF.

In addition, on the sh presence subscribe the last 5 BLF are not present.

On the phone, the BLF button are shown as speed dials...

Best regards,


1 Accepted Solution

Accepted Solutions

Try reloading router. That is also a good occasion to update IOSm in order to gain new features and better stability.

View solution in original post

5 Replies 5

Rob Huffman
Hall of Fame
Hall of Fame

Hi Marc,

Just curious about two things;

1- what happens if you set up the 7916 as a 12 button rather than 24?

2- have you looked at the button layout?



Customized Button Layout


Allows you to customize the display order of various button types on a phone using the button layout feature. The button layout feature allows you to customize the display of the following button types:


Line buttons


Speed Dial buttons


BLF Speed Dial buttons


Feature Buttons


ServiceURL buttons

Configuring Button Layout on SCCP Phones



Hi Rob,

1. Nothing is appening, it's always the same thing, the two button lines and the 7 first BLF are working fine but the 3 last BLF don't.

2. Unfortunatly I am in CME 7.1, so I can't enter the layout commands...

The fact is this configuration worked fine until yesterday and a reboot of the phone by a user.

I have this configuration on another phone but I do not have this problem...

Best regards,


Try reloading router. That is also a good occasion to update IOSm in order to gain new features and better stability.

Hi Marc,

Did you try deleting the ephone and creating it again?

Best regards,


Hi all, yes I did the delete and recreate opereration but, nothing new...

I think I am good for an IOS upgrade.

Tks all,