Showing results for 
Search instead for 
Did you mean: 

Cannot upgrade after restore

Frequent Contributor
Frequent Contributor


I have a backup from a machine.

I prepared another machine and configured it the same as the original (IP's username/password, security password)

I am able to restore the backup and everything seems OK, but I can not do any upgrade anymore.

The upgrade starts correctly and then ends with this:

(10747) Fri Mar 18 12:46:01 EET 2011
Publisher: Starting installdb... /bin/su -l informix -s /bin/sh -c "source /usr/local/cm/db/dblenv.bash /usr/local/cm ; source /usr/local/cm/db/informix/local/ids.env ; nice /usr/local/cm/bin/installdb -x /usr/local/cm/db/xml/xml"
disablenotify  dsn[DSN=ccm_super]
disablenotify  rc[0]
xml DSN=ccm_super /usr/local/cm/db/xml/xml
installXml  rc[1]
enablenotify  dsn[DSN=ccm_super]
enablenotify  rc[0]
installdb Failure [-x] 1

(10747) Fri Mar 18 12:46:49 EET 2011
ERROR: Final installdb run unsuccessful

What could this be?

The original machine is an IBM, and the target machine is a HP, but that should not cause any problems I think.

Any idea/




Amer rajai Sha'er
Rising star
Rising star


To what version you want to upgrade?


7.1.5 and this version is supported.

The problem is when I don't restore the data, I can upgrade, when I restore the data I can not upgrade.



Jaime Valencia
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

What's the exact version you're trying to upgrade to?

Have you tried some other version for the upgrade to confirm it's not letting you upgrade?

Have you looked at the install/upgrade logs?



If this helps, please rate



if this helps, please rate

Hello Java,

What is happening is the following.

I have a backup from a customer running

I installed in my lab the same version and then try to upgrade to

When I install on my server, and then do an upgrade to everything works fine.

When I install on my server, restore the backup from customer (no errors) and then I try to upgrade it fails.

Before you can upgrade from to you have to install 'ciscocm.513e_upgrade.cop.sgn' because of a bug.

I can install 'ciscocm.513e_upgrade.cop.sgn' on my system running without error's

When I have restored the backup from customer and then I want to install 'ciscocm.513e_upgrade.cop.sgn' I receive the same error.

Untarring and a lot of things go well untill the staement mentioned in my first message.

I really would like to know why this is.

Thanks you,



Looking in the DB log files I see this error:

/21/2011 11:04:02.782 installdb|-->DBXMLParser::initParser() |
03/21/2011 11:04:02.782 installdb|<--DBXMLParser::initParser() |
03/21/2011 11:04:02.783 installdb|-->DBXMLParser::parse() |
03/21/2011 11:04:02.836 installdb|-->DOMErrorReporter::fatalError |
03/21/2011 11:04:02.836 installdb|   DOMErrorReporter::fatalError *ERROR* Fatal Error at file , line 0, column 0
message: An exception occurred! Type:RuntimeException, Message:The primary document entity could not be opened. Id=/usr/local/cm/db/xml/xml/c72xx_display_instance-t1_cas.xml|
03/21/2011 11:04:02.836 installdb|<--DOMErrorReporter::fatalError |
03/21/2011 11:04:02.836 installdb|   DBXMLParser::parse() Errors occurred, no output available|
03/21/2011 11:04:02.836 installdb|<--DBXMLParser::parse() |
03/21/2011 11:04:02.836 installdb|   CDBInstall::BuildDisplayInstanceRuleMap() *ERROR* getting error while parsing: /usr/local/cm/db/xml/xml/c72xx_display_instance-t1_cas.xml|
03/21/2011 11:04:02.839 installdb|<--CDBInstall::BuildDisplayInstanceRuleMap() |
03/21/2011 11:04:02.839 installdb|   CDBInstall::InstallXML() after BuildDisplayInstanceRuleMap, rv is [1]|
03/21/2011 11:04:02.839 installdb|<--CDBInstall::InstallXML() |
03/21/2011 11:04:02.839 installdb|-->CDBInstall::~CDBInstall() |
03/21/2011 11:04:02.839 installdb|<--CDBInstall::~CDBInstall() |
03/21/2011 11:04:02.839 installdb|<--xmlinstall |
03/21/2011 11:04:02.843 installdb|<--main |
03/21/2011 11:04:02.843 installdb|-->SDIControl::~SDIControl() |
03/21/2011 11:04:02.843 installdb|<--SDIControl::~SDIControl() |
03/21/2011 11:04:02.843 installdb|-->SDIControlBase::~SDIControlBase |
03/21/2011 11:04:02.843 installdb|<--SDIControlBase::TimerThread |
03/21/2011 11:04:02.843 installdb|<--SDIControlLayer::pollThread(30f0bb0) |

This is regardless if I install a Locale, or a firmware

What is this?

Any Idea?



My Friend j.huizinga did you find what was the problem ad how did you solve it? becuase i have the same issue. Can you help me?.


The issue was that on an older version of 5.x some files were there like (/usr/local/cm/db/xml/xml/c72xx_display_instance-t1_cas.xml)

When you install from scratch version 5.2.x these files are not there anymore.

When you then restore the data and want to do an upgrade you get conflicts.

With TAC we copied around 5 xml files from the old server to the new 5.2 server, and the upgrade went OK.



ok thanks my friend, your help was very helpfull for me. So now i know that i need to open a service resquest with TAC.

  • For those who suffer from this and get rejected by TAC for unsupport (even though we are in fact upgrading to latest version...), installing a suitable devicepack for the version you are upgrading FROM will repair those xml files.

Meanwhile, good luck in finding a suitable devicepack for your dusty x.y(z) CUCM version.

Brett Hanson

I had this same error when attempting to install firmware cop files.

Resolved - details here:


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: