Showing results for 
Search instead for 
Did you mean: 

IM and Presence AXL failure

Hi all,

I have a CUCM 9.1 and an IM&Presence 9.1

Everything worked fine, but suddenly I can't anymore synchronize the users from CUCM to CUP.

On the CUP, in the CUCM Publisher settings page, the Sync Status says "AXL failure". But just under that, in the CUCM Publisher Status section, all lights are green:


What's the problem?

The strange thing is that absolutely nothing was changed on the CUCM or on the CUP, it just stopped working from one day to another.

I also tried to re-install the CUP server, but it didn't fix the problem.

Thank you very much, regards


Chris Deren
Hall of Fame Master

What is the application user credentials policy on CUCM set to? Perhaps the application user password expired.

I would look into the logs for clues.



Hi Chris,

I looked into the logs of the AXL web service on the CUCM, and found out that the requests from the application user generate the following error:

org.xml.sax.SAXParseException: The content of elements must consist of well-formed character data or markup

Thank you,




Error Message:


Cisco UP Sync Agent service failed authentication


Cisco UP Sync Agent service failed authentication to the remote Cisco Unified Communications Manager publisher and therefore is unable to connect

Recommended Action:

Please verify the AXL credentials are correct and whether the Cisco AXL Web service is activated and running on the remote Cisco Unified Communications Manager publisher

Thank you

please rate if this will help


already checked the AXL Web service and the credentials, everything is correct.

Thank you


Chris Deren
Hall of Fame Master

I do recall a bug a while ago on CUPS where if you had special characters in password i.e. ! it would not work, do you have any special characters in your password?

Did you valdiate the application user credentials policy is set to not expire?



credentials are set to not expire. I also found out about the bug you are talking about, I don't have any special characters in the password.

Thank you very much



I opened a TAC case and they solved the issue, I'm reposting the answer:

1. Remove all the UC Service and Service Profiles on CUCM

2. Restart Tomcat on the CUCM node which runs the AXL Server

3. Re-add a UC Service and Service Profile manually

4. Start the CUP UP Sync agent

5. Confirm whether the service stays active and the data is synced


I had exactly the same problem (good password for AXL user, and an AXL failure on the "system/CUCM publisher" menu on CUP)  and this answer worked for me !



I have the same problem described above and after following the procedure suggested by testspa, the Dir Sync Service remains 'starting' and the AXL failure occurs over and over again. It's the 3rd time I reinstall the CUP server; I have also tried to update it but I must give up.

I don't know what's going on but it isn't normal.


I have seen this issues several occasions and tespas solution has worked every time.

YEP that is the only solution that worked .. Thanks testspa

4 years old post worked for me today,


Tony Segneri

I just spent hours re-building a 10.5 IM&P cluster with this same issue before I found this post.  For some more detail in the Syslog viewer under Application Logs, you will find repeated entries for: Name: SyncAgentAXLConnectionFailed    with description "Cisco Sync Agent service failed authentication".   Other symptoms included all of the services taking a long time to start (20+ minutes).  I  didn't even have to delete all service profiles, just one that appeared to be corrupt (when I clicked on it in the UCM gui, it came up blank).  Thanks for posting and hope anyone else that runs into this finds this post first!



I found the exact same issue in 2018, on CUCM/IM&P 11.5.1SU5 - my scenario was that we had done a PCD upgrade from 9.1, but due to some complex issues ended up building a new cluster doing a data Export/Import out of the upgraded 11.5 into a new 11.5.  IM&P was built clean, not upgraded (due to PCD bugs).  Services would take 20-30 minutes to start.  HA would never go fully active.  Cisco Sync Agent would start, then stop again.  After finding this thread, I checked my Service Profiles, and of the 6 Service Profiles, 5 of them were really odd - when I clicked on them in the CUCM GUI, the page where they should have displayed was blank.

I was able to run a system Export of just that table, and determined that the directory area of the CSV was messing it up - a search base has comma-separated values in it, and my search bases all had the first dc= entry, then were missing the remainder of the field. 

I added one manually with a good Directory portion, exported that from 11.5, then tried to copy/paste that area into the other Service Profiles and re-import... the Import says it succeeds, but it appears it fails on those because it's a CSV file and tries to process the next fields based on the comma in the Search Base indicating to move to the next column. Any new Service Profile being added using this Import method shows that it works in the Job, but because of the multiple dc= entries with commas, you get the same behavior - click on the Service Profile in CUCM to edit it, and it just shows a blank page.

I was able to get my import to work by just taking one Service Profile and not setting any options in the directory portion, then copying the Directory XML column value for that one Service Profile into the other Profiles in my original export file.  I then manually updated the Directory area in each Service Profile once they were imported (and showed up correctly then).


EDIT:  Found this bug that applies to the Service Profile failing on import, which is exactly what I ran into.

What they don't tell you in the bug is that it impacts IM&P servers, causing the Sync service to stop.

Recognize Your Peers
Content for Community-Ad