cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
19252
Views
10
Helpful
9
Replies
Highlighted
Beginner

IP Phones not registering and loading TFTP Files: CUCM 8.6

Dear Colleagues,


Recently, I upgrade a 7.0 Cluster from MCS to CUCM 8.6 in UCS environment. I used a LAB MCS to go from 7.x to 8.0 and then  to 8.6.

The installation was sucessfully done and also the restore of 7.x data. So I have all of my IP Phones in the new cluster.


The issue is that there are no phones going to register on the new cluster and not getting the TFTP files from CUCM. I checked the TFTP services and is running properly, I tried to restart the server, restart the service and also on the service activation.

I did this tests with old phones and also with new in box and the issue is the same.

I was reading some docs, is there any kind of different apporach, since I am upgrading from version 7.x to 8.6 ?

I have attached the TFTP logs from CUCM 8.6.

Regards,

Luiz Maia

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Hi,

We currently have the same exact problem. Can you share the fix?

Regards,

Ramon

View solution in original post

9 REPLIES 9
Highlighted
Enthusiast

Have you checked your DHCP server settings to ensure the phones are pointing to the new CUCM?


Matty

Highlighted

Matt,

Thanks, but I put a new phone in a new vlan with just the new TFTP option, but is not working. Seems to be a bug problem, but I am tryng to research something around that.

Luiz

Highlighted

Hi Luiz,

Can they route to the CUCM from the new VLAN?

Sorry if I’m stating the obvious but it’s this sort of thing I always overlook myself! :-)

Matty

Highlighted

Hello,

Try to delete the ITF files from one of your IP Phone.

Conectivity is ok?

DHCP Option 150 is correctly?

79XX - Settings > Security > Trust List > ITL File > **# (to unlock the settings) > Erase

89XX/99XX - Settings > Administrator Settings > Reset Settings > Security Settings

Regards

Leonardo Santana

Highlighted

Assuming the usual suspects have already been ruled out... have you tried pulling a file from the tftp server from your own laptop?

from windows, where 10.1.1.1 is your tftp server and SEP0004F2E3CE24 is a valid phone configuration file

tftp -i 10.1.1.1 GET SEP0004F2E3CE24.cnf.xml

And again, from the TFTP server command line, pull a traffic capture you can open in wireshark, it's a lot easier to see what is happening

admin:utils network capture file mycap count 100000 size all

press ctrl-c to stop the capture

to copy the file you need SFTP server running on your laptop (freeFTPd) is free

file get activelog platform/cli/mycap.cap

and finally, if you are in a tough spot and need to get these phones working while you troubleshoot, you can try creating an alternative TFTP server and point all your phones to that instead (no need to change option 150, this is done on CUCM)

In the phone device settings, find the "phone load name" field and specify the last known good load version (obviously you will need to download this from cisco and extract it to the tftp server, tip..you do not add the .load extension in this field) for example if the load file is called SCCP42.9-2-1S.loads, you put it in as SCCP42.9-2-1S

Then find the "Load Server" field, (again in device settings) and specify the IP of the new server.

The above two changes can be made to all phones at once by bulk admin, phones, update..query

Highlighted
Beginner

Hi,

We currently have the same exact problem. Can you share the fix?

Regards,

Ramon

View solution in original post

Highlighted

Hi Folks,

Sorry for delay to post some news about this case. I solve my problem, but was nothing related to the CUCM.

My problem was related to LAN Switching. There was connectivity between all vlans, but a particular vrf was blocking the tftp traffic, so the issue to download files to the IP Phones.

@Ramon,

I would recommend you yo check the steps:

1) Full Connectivity from CUCM to vlan IP Phones;

2) Check the TFTP service under Serviceability;

3) TFTP option 150 is configured on DHCP;

4) Check if the phones are getting the TFTP address and default-router correctly;

Most of the times the problem is not in CUCM, but around that. =)

Regards,

Luiz Maia

Highlighted

Hi Luiz,

Here is our fix:

1. During upgrade from 7.1.3 to 8.6.2 the parameter >Enterprise Parameters> 
"Prepare Cluster for Rollback to pre 8.0" was set to True.
 
- Action taken: Disabled it.
 
2. Host running in VMWare ESXi 5.0 LRO was NOT disabled.
 
- Action taken:
Disabled the parameters 
 http://docwiki.cisco.com/wiki/Disable_LRO 
 
Net.VmxnetSwLROSL
Net.Vmxnet3SwLRO
Net.Vmxnet3HwLRO
Net.Vmxnet2SwLRO
Net.Vmxnet2HwLRO 
 
3. On the Service Parameter> Call manager service> 
the Station KeepAlive Interval. It was set too high.
 
-Action taken:
Changed to 30 (default)
 
Phones registered right after that.
Highlighted

Hi,

It sounds like you are running into the following known issue, I came across this whilst trying to integrate unity connection using sccp, resorted to SIP in the end. It wasn't until after that I noticed that the station keep-alive was set quite high, this was purely because the customer's cluster had a number of distributed remote offices.

CSCtz30396 Bug Details
SCCP Phones Do Not Register With Certain Station KeepAlive Intervals
Symptom:

SCCP phones do not register to CUCM however SIP phones register fine.

Conditions:
CUCM version 8.6(2a)SU1 / 8.6.2.21900-5 and the Cisco CallManager service
parameters for Station KeepAlive Interval and/or Station and Backup Server
KeepAlive Interval have been changed from their default values of 30 and 60 so
that ((3 * Station and Backup Server KeepAlive + 1) * 1000 * Station and Backup
Server KeepAlive Interval * 1000) > 2,147,483,647.

Note - ES releases 8.6.(2).21014-1 to 8.6.(2).22028-1 also run into this behavior.

Regards
Allan

Sent from Cisco Technical Support iPad App

Content for Community-Ad