cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
8372
Views
0
Helpful
15
Replies
Humberto Velasco
Beginner

Unable to make a SIP trunk work.

                   I just set up a two 7940 SIP phones. Ive been trying for days to receive/send calls with no luck.I am using a CISCO 1760 router and I have installed a 4.3 CME version. I configured the phones according to many of the postings and I came to the conclusion that my problem is the way I configured the  phones on the router. I know by fact that the phones have access to URL services, and they can send and receive call whithsin my local network. . Please, can anybody point me on the right direction?. Thanks.

Building configuration...

Current configuration : 4825 bytes
!
! Last configuration change at 14:51:12 CA1_DST Tue Jul 24 2012
! NVRAM config last updated at 14:44:54 CA1_DST Tue Jul 24 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VOICE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
clock summer-time CA1_DST recurring
!
crypto pki trustpoint TP-self-signed-990320880
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-990320880
revocation-check none
rsakeypair TP-self-signed-990320880
!
!
crypto pki certificate chain TP-self-signed-990320880
certificate self-signed 01

  9F53E051 E687F356 AFC69E0A 34521D8D 29046BC6 47CE3C3E 54E698F1

6E0B7166
  DBA9FB31 B2AC424F 572A4081 0248862E 689A3611 E853C8B6 AAA74852

AFFA514A
  431EF188 75EEFA87 2C394197 AB99B453 D31E4349 803D1383 6B2B84F1 2002A8
        quit
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.18.1 192.168.18.200
!
ip dhcp pool VOICE_SCOPE
   network 192.168.18.0 255.255.255.0
   default-router 192.168.18.200
   option 150 ip 192.168.18.200
   dns-server 4.2.2.2
!
!
ip name-server 192.168.13.2
!
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
sip
  registrar server expires max 600 min 60
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 192.168.18.200 port 5060
max-dn 144
max-pool 24
load 7960-7940 P0S3-08-6-00
timezone 13
url service http://phone-xml.berbee.com/cgi-bin/weather.pl
file text
create profile sync 000124025500339A
ntp-server 134.214.100.6 mode unicast
!
voice register dn  1
number 7001
name Ubuntu
label Core7
!
voice register dn  2
number 7005
name ccna
label IPccna
!
voice register dialplan  1
type 7940-7960-others
pattern 1 7
!
voice register pool  1
id mac 0013.1A6C.XXXX
type 7940
number 1 dn 1
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
voice register pool  2
id mac 000B.5F80.XXXX
type 7940
number 1 dn 2
!
!
!
!
!
username 561623XXXX
username username privilege 15 secret 5 $1$W2PC$WHkf.nvnA6SLMAaZsxwSl0
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
ip address 192.168.254.254 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.18.200 255.255.255.0
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.18.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
!
!
!
tftp-server flash:/phone/7940-7960/P0S3-08-6-00.loads alias

P0S3-08-6-00.loads
tftp-server flash:/phone/7940-7960/P0S3-08-6-00.sb2 alias

P0S3-08-6-00.sb2
tftp-server flash:/phone/7940-7960/P003-08-6-00.bin alias

P003-08-6-00.bin
tftp-server flash:/phone/7940-7960/P003-08-6-00.sbn alias

P003-08-6-00.sbn
!
control-plane
!
!
!
!
!
!
!
!
dial-peer voice 13 voip
preference 1
session protocol sipv2
session target sip-server
incoming called-number 561623XXXX
dtmf-relay rtp-nte
codec g711ulaw
!
!!
!
!
!
line con 0
password password
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
ntp clock-period 17179988
ntp server 134.214.100.6
end

15 REPLIES 15
Chris Deren
Hall of Fame Master

So, where is your sip-ua configuration since you are pointing your dial-peer to sip-server?

Who is your SIP provider?

What is not working? Inbound calls, outbound, both?

Can you post "debug ccsip messages" for one of the calls?

Chris

I havent configured the sip-ua part yet. My SIP provider is IPComms. No inbound/outbound calls at all. The ccsip messagges didnt show anything at all. Thanks

You need to configure the sip-ua.

And the dial-peers ofr inbound and outbound calls!

Verify some key points with the ITSP:

• Verify the supported codecs

• Verify the digits format that you need to send and receive

• This SIP Trunk need authentications?

• IP address of the SIP Servers

• DTMF mode Supported

• Support early or dealyed offer?

Follow a config example:

voice service voip

allow-connections sip to sip

sip

  bind control source-interface

  bind media source-interface

  error-passthru

  no update-callerid

  early-offer forced

  midcall-signaling passthru

sip-ua

retry invite 2

retry register 10

timers connect 100

sip-server ipv4::5060

dial-peer voice 16 voip

description -------------[DDI]

translation-profile outgoing PSTNAccess

destination-pattern 000.T

modem passthrough nse codec g711alaw

session protocol sipv2

session target ipv4:

voice-class codec 1 

dtmf-relay rtp-nte

fax-relay ecm disable

fax rate disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

icpif 50

no vad

Note that this example i dont use authentication and early-offer, and confirm the informations with the ITSP. Other thing i have an SIP Trunk with this gateway this why i only have allow connections sip to sip. If you are using H.233 gateway you need the allow connection sip to h323, h323 to sip.

Thanks

Leonardo Santana

I am going to check the settings and make the proper changes. Thanks

Use this documentation too, is very good!

Cisco CallManager Express (CME) SIP Trunking Configuration Example

http://www.cisco.com/en/US/products/sw/voicesw/ps462/products_configuration_example09186a00808f9666.shtml#codecs

Regards

Leonardo Santana

Thanks everyone for your replies. I configured theSIP  AU and the incoming/outgoing Dial peer.

I am not still receiving calls and now I cannot able to receive calls inside my network. Far below, I added part of a deabug portion when trying to generate calls. Since I am missing the translation rules, could this be part of the problem ? ThanksPlease let me know.

By the way, the link you provided is down. I used this one instead: http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml

VOICE#show run
Building configuration...

Current configuration : 5966 bytes
!
! Last configuration change at 19:58:47 CA1_DST Tue Jul 24 2012
! NVRAM config last updated at 19:10:41 CA1_DST Tue Jul 24 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VOICE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
clock summer-time CA1_DST recurring
!
crypto pki trustpoint TP-self-signed-990320880
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-990320880
revocation-check none
rsakeypair TP-self-signed-990320880
!
!
crypto pki certificate chain TP-self-signed-990320880
certificate self-signed 01
  3082023B 308201A4 A0030201 02020101 300D0609 2A864886 F70D0101         quit
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.18.1 192.168.18.200
!
ip dhcp pool VOICE_SCOPE
   network 192.168.18.0 255.255.255.0
   default-router 192.168.18.200
   option 150 ip 192.168.18.200
   dns-server 4.2.2.2
!
!
ip name-server 192.168.13.2
!
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
sip
  registrar server expires max 600 min 60
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
!
!
voice register global
mode cme
source-address 192.168.18.200 port 5060
max-dn 144
max-pool 24
load 7960-7940 P0S3-08-6-00
timezone 13
url service http://phone-xml.berbee.com/cgi-bin/weather.pl
file text
create profile sync 0001240255003394
ntp-server 134.214.100.6 mode unicast
!
voice register dn  1
number 5616236333
name Ubuntu
label Core7
!
voice register dn  2
number 7005
name ccna
label IPccna
!
voice register dialplan  1
type 7940-7960-others
pattern 1 7
!
voice register pool  1
id mac 0013.1A6C.3693
type 7940
number 1 dn 1
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
voice register pool  2
id mac 000B.5F80.0479
type 7940
number 1 dn 2
!
!
!
!
!
username 5616236333
username username privilege 15 secret 5 $1$W2PC$WHkf.nvnA6SLMAaZsxwSl0
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
ip address 192.168.254.254 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.18.200 255.255.255.0
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.18.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
!
!
!
tftp-server flash:/phone/7940-7960/P0S3-08-6-00.loads alias P0S3-08-6-00.loads
tftp-server flash:/phone/7940-7960/P0S3-08-6-00.sb2 alias P0S3-08-6-00.sb2
tftp-server flash:/phone/7940-7960/P003-08-6-00.bin alias P003-08-6-00.bin
tftp-server flash:/phone/7940-7960/P003-08-6-00.sbn alias P003-08-6-00.sbn
!
control-plane
!
!
!
!
!
!
!
!
dial-peer voice 13 voip
description **Incoming Call from SIP Trunk**
translation-profile incoming CUE_Voicemail/Autoattendant
translation-profile outgoing PSTNAccess
preference 1
destination-pattern 000.T
modem passthrough nse codec g711ulaw
voice-class codec 1
session protocol sipv2
session target sip-server
incoming called-number .%
dtmf-relay rtp-nte
fax-relay ecm disable
fax rate disable
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

icpif 50
no vad
!
dial-peer voice 2 voip
description **Outgoing Call to SIP Trunk**
translation-profile outgoing PSTN_Outgoing
destination-pattern 9........
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
no vad
!
sip-ua
authentication username 5616236333 password 7 025F510C525158701E1D5E
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar ipv4:64.154.41.150 expires 3600
sip-server dns:sipconnect.ipcomms.net
  host-registrar
!
!
telephony-service
load 7960-7940 P0S3-08-6-00
max-ephones 24
max-dn 48
ip source-address 192.168.18.200 port 2000
system message URL
url services http://phone-xml.berbee.com/cgi-bin/weather.pl
dialplan-pattern 1 56162363.. extension-length 3 extension-pattern 2.. no-reg
voicemail 600
max-conferences 4 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
web admin system name voice secret 5 $1$g0TF$UKhdG0xKxqdw7CDpqzCiI/
dn-webedit
transfer-system full-consult
!
!
ephone-dn  1
number 333 secondary 5616236333 no-reg both
description ***Good Life***
name Latitude
!
!
ephone  1
mac-address 000B.5F80.0479
!
!
!
ephone  2
mac-address 0013.1A6C.3693
!
!
!
line con 0
password password
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
ntp clock-period 17180019
ntp server 134.214.100.6
end

  88888888888888888888888888888888888888888888888888888888888888888888888888888888
VOICE#debug ccsip all
This may severely impact system performance. Continue? [confirm]yAll SIP

Call tr
acing is enabled
VOICE#
Jul 24 23:49:26.594: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIAddContextToTable:

Added c
ontext(0x852C7DA0) with key=[29] to table
Jul 24 23:49:26.594:

//-1/000000000000/SIP/Info/sipSPIGetOutboundHostAndDestHost
: CCSIP: target_host : 64.154.41.150 target_port : 5060

Jul 24 23:49:26.594:

//-1/000000000000/SIP/Info/sipSPIValidateAndCopyOutboundHos
t: CCSIP: copy target_host to outbound_host
Jul 24 23:49:26.594: //-1/000000000000/SIP/State/sipSPIChangeState:

0x852C7DA0 :
State change from (STATE_NONE, SUBSTATE_NONE)  to (STATE_IDLE,

SUBSTATE_NONE)
Jul 24 23:49:26.594:

//-1/000000000000/SIP/Info/ccsip_spi_registrar_add_expires_
header: Inside ccsip_spi_registrar_add_expires_header for Expires
Jul 24 23:49:26.598: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued

event f
rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER
Jul 24 23:49:26.598:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event
: ccsip_spi_get_msg_type returned: 3 for event 40
Jul 24 23:49:26.598:

//-1/000000000000/SIP/Info/act_idle_outgoing_register: In a
ct_idle_outgoing_register

Jul 24 23:49:26.598:

//23/000000000000/SIP/Info/act_idle_outgoing_register:  Sen
d REGISTER to 64.154.41.150:5060

Jul 24 23:49:26.598: //23/000000000000/SIP/Info/sipSPIUaddCcbToUACTable:

****Add
ing to UAC table.
Jul 24 23:49:26.598: //23/000000000000/SIP/Info/sipSPIUaddCcbToTable:

Added to t
able. ccb=0x852C7DA0 key=C629EB93-D51F11E1-8014DE03-81F92794
Jul 24 23:49:26.598: //-1/xxxxxxxxxxxx/SIP/Info/sipSPISetDateHeader:

Converting
TimeZone CA1_DST to SIP default timezone = GMT
Jul 24 23:49:26.602: //23/000000000000/SIP/Info/sipSPISendRegister:

Associated c
ontainer=0x85A93914 to Register
Jul 24 23:49:26.602: //23/000000000000/SIP/Transport/sipSPISendRegister:

Sending
REGISTER to the transport layer
Jul 24 23:49:26.602:

//23/000000000000/SIP/Transport/sipSPIGetSwitchTransportFla
g: Return the Dial peer configuration, Switch Transport is FALSE
Jul 24 23:49:26.606:

//23/000000000000/SIP/Transport/sipSPITransportSendMessage:
msg=0x850B5EF4, addr=64.154.41.150, port=5060, sentBy_port=0, is_req=1,

transpo
rt=1, switch=0, callBack=0x80E02208
Jul 24 23:49:26.606:

//23/000000000000/SIP/Transport/sipSPITransportSendMessage:
Proceedable for sending msg immediately
Jul 24 23:49:26.606:

//23/000000000000/SIP/Transport/sipTransportLogicSendMsg: s
witch transport is 0
Jul 24 23:49:26.606:

//23/000000000000/SIP/Transport/sipTransportLogicSendMsg: S
et to send the msg=0x850B5EF4
Jul 24 23:49:26.606:

//-1/xxxxxxxxxxxx/SIP/Transport/sipTransportPostSendMessage
: Posting send for msg=0x850B5EF4, addr=64.154.41.150, port=5060,

connId=2 for U
DP
Jul 24 23:49:26.606: //23/000000000000/SIP/State/sipSPIChangeState:

0x852C7DA0 :
State change from (STATE_IDLE, SUBSTATE_NONE)  to

(SIP_STATE_OUTGOING_REGISTER,
SUBSTATE_NONE)
Jul 24 23:49:26.606: //23/000000000000/SIP/State/sipSPIChangeState:

0x852C7DA0 :
State change from (SIP_STATE_OUTGOING_REGISTER, SUBSTATE_NONE)  to

(SIP_STATE_O
UTGOING_REGISTER, SUBSTATE_NONE)
Jul 24 23:49:26.610: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:64.154.41.150:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.18.200:5060;branch=z9hG4bK1C1193
From: <7005>;tag=242E87-1D81
To: <7005>
Date: Tue, 24 Jul 2012 23:49:26 GMT
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1343173766
CSeq: 8 REGISTER
Contact: <7005>
Expires:  3600
Content-Length: 0

Jul 24 23:49:26.778: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads:

Msg enqueu
ed for SPI with IP addr: 64.154.41.150:5060
Jul 24 23:49:26.778:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event
: ccsip_spi_get_msg_type returned: 2 for event 1
Jul 24 23:49:26.778:

//-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewCon
nMsg: context=0x850B1084
Jul 24 23:49:26.778:

//-1/xxxxxxxxxxxx/SIP/Transport/sipConnectionManagerProcess
NewConnMsg: gConnTab=0x850B1084, addr=64.154.41.150, port=5060,

connid=2, transp
ort=UDP
Jul 24 23:49:26.778:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_new_msg_preprocessor: Chec
king Invite Dialog
Jul 24 23:49:26.782: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP

192.168.18.200:5060;branch=z9hG4bK1C1193;received=108.132.102.1
84
From: <7005>;tag=242E87-1D81
To: <7005>
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
CSeq: 8 REGISTER
Server: Asterisk PBX 1.6.2.13
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0

Jul 24 23:49:26.838: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads:

Msg enqueu
ed for SPI with IP addr: 64.154.41.150:5060
Jul 24 23:49:26.838:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event
: ccsip_spi_get_msg_type returned: 2 for event 1
Jul 24 23:49:26.838:

//-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewCon
nMsg: context=0x850B1084
Jul 24 23:49:26.838:

//-1/xxxxxxxxxxxx/SIP/Transport/sipConnectionManagerProcess
NewConnMsg: gConnTab=0x850B1084, addr=64.154.41.150, port=5060,

connid=2, transp
ort=UDP
Jul 24 23:49:26.842:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_new_msg_preprocessor: Chec
king Invite Dialog
Jul 24 23:49:26.842: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP

192.168.18.200:5060;branch=z9hG4bK1C1193;received=108.132.102.1
84
From: <7005>;tag=242E87-1D81
To: <7005>;tag=as122e8ac5
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
CSeq: 8 REGISTER
Server: Asterisk PBX 1.6.2.13
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="asterisk",

nonce="512fa694"
Content-Length: 0

Jul 24 23:49:26.846:

//23/000000000000/SIP/Info/sipSPIGenerateAuthorizationRespo
nse: HA1 is: 7f8699de54ca1c3ae55fc85c23cf048b
Jul 24 23:49:26.846: //-1/xxxxxxxxxxxx/SIP/Info/sipSPISetDateHeader:

Converting
TimeZone CA1_DST to SIP default timezone = GMT
Jul 24 23:49:26.850: //23/000000000000/SIP/Transport/sipSPISendRegister:

Sending
REGISTER to the transport layer
Jul 24 23:49:26.850:

//23/000000000000/SIP/Transport/sipSPIGetSwitchTransportFla
g: Return the Dial peer configuration, Switch Transport is FALSE
Jul 24 23:49:26.850:

//23/000000000000/SIP/Transport/sipSPITransportSendMessage:
msg=0x853734F4, addr=64.154.41.150, port=5060, sentBy_port=0, is_req=1,

transpo
rt=1, switch=0, callBack=0x80E02208
Jul 24 23:49:26.850:

//23/000000000000/SIP/Transport/sipSPITransportSendMessage:
Proceedable for sending msg immediately
Jul 24 23:49:26.850:

//23/000000000000/SIP/Transport/sipTransportLogicSendMsg: s
witch transport is 0
Jul 24 23:49:26.850:

//23/000000000000/SIP/Transport/sipTransportLogicSendMsg: S
et to send the msg=0x853734F4
Jul 24 23:49:26.854:

//-1/xxxxxxxxxxxx/SIP/Transport/sipTransportPostSendMessage
: Posting send for msg=0x853734F4, addr=64.154.41.150, port=5060,

connId=2 for U
DP
Jul 24 23:49:26.854: //23/000000000000/SIP/State/sipSPIChangeState:

0x852C7DA0 :
State change from (SIP_STATE_OUTGOING_REGISTER, SUBSTATE_NONE)  to

(SIP_STATE_O
UTGOING_REGISTER, SUBSTATE_NONE)
Jul 24 23:49:26.854: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:64.154.41.150:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.18.200:5060;branch=z9hG4bK1D2140
From: <7005>;tag=242E87-1D81
To: <7005>
Date: Tue, 24 Jul 2012 23:49:26 GMT
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1343173766
CSeq: 9 REGISTER
Contact: <7005>
Expires: 3600
Authorization: Digest

username="5616236333",realm="asterisk",uri="sip:64.154.41.
150:5060",response="0f077c9394532140da55c1074c4e4560",nonce="512fa694",a

lgorithm
=MD5
Content-Length: 0


Jul 24 23:49:27.042: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads:

Msg enqueu
ed for SPI with IP addr: 64.154.41.150:5060
Jul 24 23:49:27.042:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event
: ccsip_spi_get_msg_type returned: 2 for event 1
Jul 24 23:49:27.042:

//-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewCon
nMsg: context=0x850B1084
Jul 24 23:49:27.042:

//-1/xxxxxxxxxxxx/SIP/Transport/sipConnectionManagerProcess
NewConnMsg: gConnTab=0x850B1084, addr=64.154.41.150, port=5060,

connid=2, transp
ort=UDP
Jul 24 23:49:27.042:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_new_msg_preprocessor: Chec
king Invite Dialog
Jul 24 23:49:27.046: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP

192.168.18.200:5060;branch=z9hG4bK1D2140;received=108.132.102.1
84
From: <7005>;tag=242E87-1D81
To: <7005>
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
CSeq: 9 REGISTER
Server: Asterisk PBX 1.6.2.13
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0

Jul 24 23:49:27.098: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads:

Msg enqueu
ed for SPI with IP addr: 64.154.41.150:5060
Jul 24 23:49:27.102:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event
: ccsip_spi_get_msg_type returned: 2 for event 1
Jul 24 23:49:27.102:

//-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewCon
nMsg: context=0x850B1084
Jul 24 23:49:27.102:

//-1/xxxxxxxxxxxx/SIP/Transport/sipConnectionManagerProcess
NewConnMsg: gConnTab=0x850B1084, addr=64.154.41.150, port=5060,

connid=2, transp
ort=UDP
Jul 24 23:49:27.102:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_new_msg_preprocessor: Chec
king Invite Dialog
Jul 24 23:49:27.106: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden (Bad auth)
Via: SIP/2.0/UDP

192.168.18.200:5060;branch=z9hG4bK1D2140;received=108.132.102.1
84
From: <7005>;tag=242E87-1D81
To: <7005>;tag=as122e8ac5
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
CSeq: 9 REGISTER
Server: Asterisk PBX 1.6.2.13
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0

Jul 24 23:49:27.106:

//23/000000000000/SIP/Error/ccsip_api_register_result_ind:
Message Code Class 4xx Method Code 100 received for REGISTER
Jul 24 23:49:27.106:

//-1/xxxxxxxxxxxx/SIP/Info/ccsip_register_reset_dns_cache:
CCSIP_REGISTER:: Primary registrar DNS resolved addr reset
Jul 24 23:49:27.106:

//-1/xxxxxxxxxxxx/SIP/Info/ccsipRegisterStartExpiresTimer:
Starting timer for pattern 7005 for 180 seconds
Jul 24 23:49:27.110:

//-1/xxxxxxxxxxxx/SIP/Info/sipSPIDeleteContextFromTable: Co
ntext for key=[29] removed.
Jul 24 23:49:27.110:

//23/000000000000/SIP/Info/sipSPIUdeleteCcbFromUACTable: **
**Deleting from UAC table.
Jul 24 23:49:27.110:

//23/000000000000/SIP/Info/sipSPIUdeleteCcbFromTable: Delet
ing from table. ccb=0x852C7DA0 key=C629EB93-D51F11E1-8014DE03-81F92794
Jul 24 23:49:27.110:

//23/000000000000/SIP/Info/sipSPIFlushEventBufferQueue: The
re are 0 events on the internal queue that are going to be free'd

From your trace...

++++You are trying to register/authenticate to 64.154.41.150++++

State change from (SIP_STATE_OUTGOING_REGISTER, SUBSTATE_NONE)  to

(SIP_STATE_O
UTGOING_REGISTER, SUBSTATE_NONE)
Jul 24 23:49:26.610: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:64.154.41.150:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.18.200:5060;branch=z9hG4bK1C1193
From: <7005>;tag=242E87-1D81
To: <7005>
Date: Tue, 24 Jul 2012 23:49:26 GMT
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1343173766
CSeq: 8 REGISTER
Contact: <7005>
Expires:  3600
Content-Length: 0

+++Your provider is sending Unauthrorized and bad authentication++++++

Received:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP

192.168.18.200:5060;branch=z9hG4bK1C1193;received=108.132.102.1
84
From: <7005>;tag=242E87-1D81
To: <7005>;tag=as122e8ac5
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
CSeq: 8 REGISTER
Server: Asterisk PBX 1.6.2.13
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="asterisk",

nonce="512fa694"
Content-Length: 0

Received:
SIP/2.0 403 Forbidden (Bad auth)
Via: SIP/2.0/UDP

192.168.18.200:5060;branch=z9hG4bK1D2140;received=108.132.102.1
84
From: <7005>;tag=242E87-1D81
To: <7005>;tag=as122e8ac5
Call-ID: C629EB93-D51F11E1-8014DE03-81F92794
CSeq: 9 REGISTER
Server: Asterisk PBX 1.6.2.13
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0

In your registration request, I cannot see you passing any authentication credentials to your sip provider. I can see that you have configured username and password under sip-ua, but this is not been sent in your registration request, so your provider does not know who you are, hence rejecting your registration requests

Please rate all useful posts
Tony Cilli Jr
Beginner

You wont ever see any incoming calls until you configure the ip address trusted list under your voice service voip.. Here's an example from my config. You have to configure the router to allow calls to come in from your SIP provider.. (replace 10.255.255.255 with the ip address your SIP provider gives you. The other stuff below isn't as important as the ip address trusted list.. That's 100% crucial when doing SIP Trunking from a provider.

voice service voip

ip address trusted list

  ipv4 10.255.255.255

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0

  early-offer forced

  midcall-signaling passthru

HTH,

Tony

If you find my post helpful, please rate!

Humberto,
Have you tried enabling 'debug ccsip messages' and attempting to dial inward and see if you get any notifications? If not, I still believe you need to configure the ip address trusted list. Even the iOS on my router tells me it needs to be configured when you first start.

Furthermore, to add onto aokanlawon's respone, check with your provider to see how they want you to authenticate. If you can authenticate by using caller ID or perhaps a diverson header (these are the only two methods my provider will take). I find Diversion header's to be the simplest because then you can manipulate your calling number for outbound calls.

Example:

voice class sip-profiles 100

request INVITE sip-header Diversion add "Diversion: "

Replace the X's with the 10-digit BTN they give you for diversion header authentication and the Y's with the IP Address of your router passing through the calls. Then you assign "voiec-class sip profiles 100" to your outbound dial-peer.

HTH,

Tony

If you find my post helpful, please rate!

I am going to redo the whole SIP thing. I have done so many changes to the configuration that I am completely lost. I will come back as soon as I see something different. To answer to your question, the CCSIP messages never showed after calling in to my number from my cell phone. So, Im going to troubleshoot the authentication part first to verify that my router has been seen and not rejected by the ITSP server.

Humberto Velasco
Beginner

Im back. I started from scratch. As of right now, I am able to receive incoming calls, and make iternal inbound/outgoing calls with my two IP phones.However, I am not able to make phone calls to the outside world.After dialing 561xxxxxxx, the display shows proceeding in 100, then reorder, and finally a fast busy signal. I attached the actual config and the csip messages. I am pretty sure that may translation rules and my dial-peers are not configured correctly. Also, I have not configured anytyhing related to NAT, which could be part of the problem too. Please take a look and let me if you guys can help me.

Thanks

You SIP provider rejects the calls, probably because you are sending 333 instead of a valid calling number

Configure so that you send a valid calling number as assigned by SIP provider.

Jul 31 19:03:51.864: //-1/xxxxxxxxxxxx/SIP/sg/ccsipDisplayMsg:

Sent:

INVITE sip:5618537305@sipconnect.ipcomms.net:5060 SIP/2.0

Via: SIP/2.0/UDP 192.168.13.200:5060;branch=z9hG4bK3EB130B

From: "333" <>333@sipconnect.ipcomms.net>;tag=13A6B78-21B1

To: <>5618537305@sipconnect.ipcomms.net>

Date: Tue, 31 Jul 2012 19:03:51 GMT

Call-ID: 47C614D5-DA7911E1-82C2AA27-49453C96@192.168.13.200

Supported: 100rel,timer,resource-priority,replaces

Min-SE:  1800

Cisco-Guid: 1203803861-3665367521-2193467943-1229274262

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIF

Y, INFO, REGISTER

CSeq: 102 INVITE

Timestamp: 1343761431

Contact: <333>

Expires: 180

Allow-Events: telephone-event

Authorization: Digest username="5616236333",realm="asterisk",uri="sip:5618537305

@sipconnect.ipcomms.net:5060",response="a74b62c8ee2fe21f3539ba3167c0d02a",nonce=

"790ee99f",algorithm=MD5

Max-Forwards: 69

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 265

v=0

o=CiscoSystemsSIP-GW-UserAgent 6958 2124 IN IP4 192.168.13.200

s=SIP Call

c=IN IP4 192.168.13.200

t=0 0

m=audio 19406 RTP/AVP 0 8 101

c=IN IP4 192.168.13.200

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

Jul 31 19:03:51.928: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 192.168.13.200:5060;branch=z9hG4bK3EB130B;received=184.32.211.5

8

From: "333" <>333@sipconnect.ipcomms.net>;tag=13A6B78-21B1

To: <>5618537305@sipconnect.ipcomms.net>

Call-ID: 47C614D5-DA7911E1-82C2AA27-49453C96@192.168.13.200

CSeq: 102 INVITE

Server: Asterisk PBX 1.6.2.13

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO

Supported: replaces, timer

Require: timer

Session-Expires: 1800;refresher=uas

Contact: <5618537305>

Content-Length: 0

Jul 31 19:03:55.376: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 603 Declined

Via: SIP/2.0/UDP 192.168.13.200:5060;branch=z9hG4bK3EB130B;received=184.32.211.5

8

From: "333" <>333@sipconnect.ipcomms.net>;tag=13A6B78-21B1

To: <>5618537305@sipconnect.ipcomms.net>;tag=as76b59e9c

Call-ID: 47C614D5-DA7911E1-82C2AA27-49453C96@192.168.13.200

CSeq: 102 INVITE

Server: Asterisk PBX 1.6.2.13

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO

Supported: replaces, timer

Content-Length: 0

Just like Paolo has mentioned, ensure the CLI you are sending macthes with the DDI range from your provider. You can use xlation rules or sip profiles to modify the CLI

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

I found on this lilnk, http://wiki.kolmisoft.com/index.php/SIP/2.0_603_Declined what to look for when SIP/2.0 603 Declined appears. I changed on my phone the username and password, from "333" "333" to username xxxxx password yyyy, the ones provided by mis SIP server.

Thanks to all of you for your inputs. I am still working on more issues, but getting the sip trunk up and running was big.

Content for Community-Ad

Spotlight Awards 2021