cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
571
Views
0
Helpful
2
Replies
Atheeleon
Beginner

Intervlan Routing With OSPF

Hello, everyone.

 

I have a college project where I need to make a intervlan communication between these 3 switches using OSPF. I have searched the internet for every possible solution, but I can't seem to find the answers.

Here's what has been done so far:

 

The main network is 172.100.0.0/24 and the sub-net has been divided into /27

I am using these subnets:

172.100.0.0/27

172.100.0.32/27

172.100.0.64/27

 

 

I have created 3 Vlans in each switch:

Vlan 10 (172.100.0.0/27)

vlan 10

name Andar1

int vlan10

ip add 172.100.0.30 255.255.255.224

no sh

 

Vlan 20 (172.100.0.32/27)

vlan 20

name Andar2

int vlan 20

ip add 172.100.0.62 255.255.255.224

no sh

 

Vlan 30 (172.100.0.64/27)

vlan 30

name Andar3

int vlan 30

ip add 172.100.0.94 255.255.255.224

no sh

 

Each switch has ALL of its Fa interfaces in Access Mode to one specific vlan.

SW1

int range f0/1-24

switchport mode access

switchport access vlan 10

no sh

SW2

int range f0/1-24

switchport mode access

switchport access vlan 20

no sh

SW3

int range f0/1-24

switchport mode access

switchport access vlan 30

no sh

 

Each switch has their Gig interface in Trunk Mode.

SW1

int range g0/1-2

switchport mode trunk

no sh

SW2

int range g0/1-2

switchport mode trunk

no sh

SW2

int range g0/1-2

switchport mode trunk

no sh

 

The network inside each switch is working perfectly. The problem is that I don't know how I can make this intervlan communication using OSPF routing.

How can I make this work?

2 REPLIES 2
paul driver
VIP Mentor

Hell0
Looks like you are wanting to to extend your L3 connectivity down to the access layer and if you to do that then the vlans cannot be extended over to the other switches.

In the below example i have used three additional subnets for the l3 mgt connections.

Sw1-Sw2 MGT link 172.100.0.96/29
Sw1-Sw3 MGT link 172.100.0.128/29
Sw2-Sw3 MGT link 172.100.0.160/29


SW1
int x/x
description MGT link sw1-sw2
ip address 172.100.0.97 255.255.255.224
ip ospf network point-to-point

int x/x
description MGT link sw1-sw3
ip address 172.100.0.129 255.255.255.224
ip ospf network point-to-point


int vlan10
description server-PT
ip add 172.100.0.30 255.255.255.224


router ospf 1
auto-cost reference-bandwidth 1000
passive-interface default

no passive-interface default interface (sw1-s2)
no passive-interface default interface (sw1-s3)
network 172.100.0.30 0.0.0.0 area 0
network 172.100.0.97 0.0.0.0 area 23
network 172.100.0.129 0.0.0.0 area 23
area 23 stub no-summary

vlan 10
exit


SW2
int x/x
description MGT link vlan sw2-sw1
ip address 172.100.0.98 255.255.255.224
ip ospf network point-to-point


int x/x
description MGT link sw2-sw3
ip address 172.100.0.161 255.255.255.224
ip ospf network point-to-point


int vlan 20
description Andar2
ip add 172.100.0.62 255.255.255.224
no sh


router ospf 1
auto-cost reference-bandwidth 1000
passive-interface default
no passive-default interface (sw2-s1)
no passive-default interface (sw2-s3)
network 172.100.0.98 0.0.0.0 area 23
network 172.100.0.62 0.0.0.0 area 23
network 172.100.0.161 0.0.0.0 area 23
area 23 stub


vlan 20
exit

 


SW3

int x/x
description MGT link sw3-sw1
ip address 172.100.0.105 255.255.255.224
ip ospf network point-to-point

int x/x
description MGT link sw3-sw2
ip address 172.100.0.162 255.255.255.224
ip ospf network point-to-point

int vlan 30
description Andar3
ip add 172.100.0.94 255.255.255.224
no sh

router ospf 1
auto-cost reference-bandwidth 1000
passive-interface default
no passive-default interface (sw3-s1)
no passive-default interface (sw3-s2)
network 172.100.0.94 0.0.0.0 area 23
network 172.100.0.105 0.0.0.0 area 23
network 172.100.0.162 0.0.0.0 area 23
area 23 stub

vlan 30
exit



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Hey, thanks for the response.
Should I change my 2960 to 3560/3650? Or should I connect the L3 switches
to the L2's?