cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11736
Views
35
Helpful
13
Replies
Highlighted
Explorer

Siemens Profinet and Cat2960S

Hello,

I have a problem with siemens industrial profinet apparatous and my Cat2960.

Siemens host can be pinged without any problem but they are not able to do any other kind of traffic.

If i look at the interface I can find that all ingress packet are UNKNOWN DROPPED.

I found a document where si explained that "probably" siemens host are using packet with 802.1p header and vlan 0.

I tried the following tests:

1) port in access mode     -  failed

2) port in trunk mode with native vlan      - failed

3) port in access mode with voice vlan -   failed

4) port in acess-mode with voice vlan dot1p - failed

Did you never had such this problem?

can anybody help me?

Thanks

Johnny

13 REPLIES 13
Highlighted
Cisco Employee

Siemens Profinet and Cat2960S

Hello,

Have you attempted to get a sniffer capture of this traffic to see what the packets look like?  Where are you seeing the drops? Can you paste the output?

Fabienne

TAC

Highlighted

Hi,we usually get this also

Hi,

we usually get this also running with adding the same voice vlan to that port and all ports which use profinet, like falk already posted:

interface GigabitEthernet1/0/1

switchport access vlan 61

switchport mode access

switchport voice vlan 61


Did you already try?

Highlighted
Beginner

Siemens Profinet and Cat2960S

hello,

example:

interface GigabitEthernet1/0/1

switchport access vlan 61

switchport mode access

switchport voice vlan 61

it is usually the solution

regards

falk

Highlighted
Beginner

Siemens Profinet and Cat2960S

Recently configured this.

Use the following

switchport mode trunk

switchport trunk encapsulation dot1q               // if default is not dot1q

switchport trunk native vlan

Thanks,

Dev

Highlighted
Beginner

Re: Siemens Profinet and Cat2960S

Hi my friend. Did you solve this problem?

Highlighted
Beginner

Hello.

Hello.

I'm facing the same problem these days.

I know this is an old problem and probably you forgot it but, in any case, did you find any solution for the problem? And if yes, what is it?

Regards,

Gabriele

Highlighted
Beginner

Hi, actually it is not that

Hi, actually it is not that old, since it just happened to me.

In our case the solution was to remove the L3 interface that we had in the same VLAN. It makes absolutelly no sense... but it worked. The interface is configured as access, and there is no SVI for that VLAN.

Did you find some alternative (and explainable) solution?

Does anyone know if the traffic generated/exchanged between the Profinet devices is Multicast or unicast?

Regards,

Francisco 

Highlighted
Beginner

Hello,I've had a similar

Hello,
I've had a similar problem these days: a customer was using a Siemens software in order to discover the Siemens devices on the vlan. The discovery was successful with a simple unmanaged switch, but with a Cat2960X it was partially failing (only some devices were discovered). After conducting a troubleshooting we figured out that the packets were too small, so we used a trick to make them bigger. Instead on configuring the interfaces as access we have created some trunks, and this solved the problem.

Old configuration:
switchport mode access
switchport access vlan XXX

New configuration:
switchport mode trunk
switchport trunk native vlan XXX

Voillà! Problem solved!

Maybe one day this can help someone :)

Best regards,
Matteo

Highlighted
Beginner

Re: Hello.

Hello,

 

Do you solved this problem?

 

Highlighted
Beginner

Re: Siemens Profinet and Cat2960S

Hi guys, someone has solved this problem?

 

Highlighted
VIP Advocate

Re: Siemens Profinet and Cat2960S

This is my working configuration on a Catalyst 2960-X with Siemens devices and the Ethernet based protocol:

 

 
#sh ru int g1/0/1
Building configuration...

Current configuration : 191 bytes
!
interface GigabitEthernet1/0/1
 switchport access vlan 40
 switchport mode access
 switchport voice vlan 102
 no mdix auto
 spanning-tree portfast edge
 spanning-tree bpduguard enable
end

You can probably leave the last three lines away, but we have them for various reasons always in our configuration. 

The most important part is the voice vlan line. That will fix the "broken" broadcast replies of the Siemens devices, so that they can be found and used with the Broadcast function.

Highlighted
Beginner

Re: Siemens Profinet and Cat2960S

Hello all,

I had the same problem and for to arrive work profinet on Catalyst 2960, 2960S/X, 3750 and 3850 I did this :

  1. default interface yy xx/xx/xx [for reset port configuration]
  2. interface yy xx/xx/xx
  3. switchport trunk allowed vlan XX [XX is your vlan ID where Profinet devices are connected]
  4. switchport trunk encapsulation dot1x [if you need specified]
  5. switchport native vlan XX [XX is your vlan ID where Profinet devices are connected]
  6. Possible to add this command for spanning-tree : spanning-tree portfast trunk

Enjoy.

 

Best regards.

Highlighted
VIP Advocate

Re: Siemens Profinet and Cat2960S

Thanks.

For security reasons I suggest you also use:

switchport trunk allowed vlan xxx ! The vlan you configured as native. Please note, I haven't tested this.






CreatePlease to create content
Content for Community-Ad