07-22-2010 07:36 AM - edited 03-06-2019 12:09 PM
Our leaf switches are 3560. They have 2 uplinks to our core stack of 3750's. There has been a lot of changes on the 3560 configuration. The network guy has been trying to get a voice vlan setup and qos. He's off on vacation and we need to image up a slew of laptops for a project that starts monday and PXE is not working. We suspect it has something to do with the changes on the leaf switches. If we plug one of the laptops directly in the 3750 it works fine.
Here's the configuration on the leaf switch (please note on ports 41 and 44 I've tried to use access mode instead of trunk mode without results):
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname sw0-3
!
!
no aaa new-model
clock timezone EDT -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
ip name-server 172.22.1.240
ip name-server 172.22.1.243
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel9
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
description "Upstream Team"
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-group 9 mode desirable
!
interface GigabitEthernet0/2
description "Upstream Team"
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-group 9 mode desirable
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/5
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/8
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/9
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/10
description "Device: Wireless Device"
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/11
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/12
description "Device: Wireless device"
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/13
description "Device: Wireless device"
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
interface GigabitEthernet0/14
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/15
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/16
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/17
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/18
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/19
description "Data: D_130"
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/20
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/21
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/22
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/25
description "Computer: adminsal computer"
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/26
description "Data: D_177"
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/27
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/28
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/29
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/30
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/31
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/32
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/33
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/34
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/35
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/36
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/37
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/38
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/39
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/40
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/41
switchport access vlan 73
switchport mode access
no mdix auto
spanning-tree portfast
!
interface GigabitEthernet0/42
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/43
description "Data: D_096"
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
interface GigabitEthernet0/44
switchport access vlan 73
switchport mode access
no mdix auto
spanning-tree portfast
!
interface GigabitEthernet0/45
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/46
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/47
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/48
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/50
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/51
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/52
switchport trunk encapsulation dot1q
switchport trunk native vlan 73
switchport mode trunk
spanning-tree portfast
!
interface Vlan1
no ip address
!
interface Vlan73
ip address 172.22.73.5 255.255.255.0
!
interface Vlan173
ip address 172.22.173.5 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.73.1
ip http server
!
logging trap debugging
control-plane
!
!
login
line vty 5 15
login
!
ntp clock-period 36029488
ntp server 172.22.1.243
end
sw0-3#
Any Ideas how to get PXE working? Our Windows DHCP server hands out the PXE and bootfile information. On the Core 3750 it list all the vlans with the ip helper address.
07-22-2010 08:08 AM
interface GigabitEthernet0/41
switchport access vlan 73
switchport mode access
no mdix auto
spanning-tree portfast
!
spanning-tree portfastinterface GigabitEthernet0/44
switchport access vlan 73
switchport mode access
no mdix auto
spanning-tree portfast
try to use encapsulation on both ports
switchport trunk encapsulation dot1q
07-22-2010 10:18 AM
Just to confirm so it would look like this:
interface GigabitEthernet0/41
switchport trunk encapsulation dot1q
switchport access vlan 73
switchport mode access
no mdix auto
spanning-tree portfast
07-22-2010 10:46 AM
Hello BlueCube,
try to use
int gi0/x
switchport
swithcport mode access
switchport access vlan 73
spanning-tree portfast
you can use default interface gi0/x to remove all this stuff
default interface range gi0 / 0 x - y to erase config of a group of ports
or config t
interface range giga 0 / x - y
switchport
swithcport mode access
switchport access vlan 73
spanning-tree portfast
Hope to help
Giuseppe
07-22-2010 11:06 AM
Thanks for the response. The problem isn't changing them the problem is when using switchport mode trunk I can't get a pxe boot, when I try access mode I don't get an ip at all.
08-29-2010 08:06 PM
I have the same issue - Has anyone got an answer on this one?
08-29-2010 08:19 PM
Hello Bleucube,
Do you have a Layer 3 interface (interface vlan 73) on the 3750? Please try
the following on the leaf switch:
ip routing
interface vlan 73
ip helper-address
exit
service dhcp
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080
0f0804.shtml#pxe
Hope this helps.
Regards,
NT
09-30-2010 11:02 AM
If both PXE and DHCP services are on the same server, you only need an IP helper statement on the vlan interface of the client. This will help forward the Bootp request with option 60 (PXE) broadcast to your DHCP/PXE server. If PXE and DHCP services are on separate LAN segments, then you may need an additional IP helper statement for the PXE server as well. And in the DHCP scope, you need to list the PXE server as the "next server", so the client knows where to go for PXE boot files. Fun stuff.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide