cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1988
Views
25
Helpful
15
Replies
Highlighted
Beginner

iphone not connecting to 802.11ac

any idea why iphones and ipads are not connecting to 802.11ac? it is always connecting to 802.11n. even if i turn-off wifi off and then on, it is sticking with N. anyway i can configure the controller to allow these devices to always connect to AC?

 

2504 WLC 8.5, 3602i with AC modules

15 REPLIES 15
Highlighted
VIP Advocate

Are the AC rates enabled on the WLC? Wireless -> 802.11a/n/ac -> High throughput
What security/encryption settings are configured on the affected SSID?
Which exact version of 8.5?
Highlighted

yes, under high throughput - 11n and 11ac modes are enabled

security - wpa2 + 802.1x, FT adaptive

software version 8.5.131.0

Highlighted

The iPhone and iPad are newer devices that have 802.11ac NIC’s correct?  Test with an open SSID and see if the devices negotiate. If other devices negotiate to ac, you don’t have an issue with your configuration, just might be the device. 

-Scott
*** Please rate helpful posts ***
Highlighted

phones are iphone 7 and 8, ipads are a little older i think ipad air but shouldn't have any problem with their NICs as they used to connect through 802.11ac before.

 

tests done with open authentication have the same results sadly. i did try to change wireless-advanced-network profile-client network performance-default to throughput and test with my phone, it did connect to 802.11ac once but after turning off then on wifi it goes back to 802.11n. so something from the controller should have been configured wrongly i guess

Highlighted

Here is something that might not be related but may. We ran into an issue with devices not connecting to 802.11ac and it was due to uploading a configuration file that wasn’t in the proper format. Rebuilding the controller was the fix. This affected all devices, not just Apple devices however.

Bounce the the AP and or the controller and see if that fixes the issue. When I mentioned open, I really meant to create a new SSID and set it to open, don’t change anything else on the wlan and see if that helps. Might be a config issue but who knows.
-Scott
*** Please rate helpful posts ***
Highlighted

Just a follow-up, so I have solved this issue by moving my 7921g wireless phones from 5ghz to 2.4ghz and now all devices are able to connect to 802.11ac. Problem now is these 7921g phones is always disconnecting from wireless network "leaving service area" when in 2.4ghz and very unstable.
Highlighted
Hall of Fame Community Legend

What firmware is the 7921G working on?
Highlighted

firmware 1.4.6.3

Highlighted
Hall of Fame Community Legend

Can you please upgrade to 1.4(6)8?
Highlighted
Hall of Fame Community Legend

What is the settings for the SSID? Is both WPA & WPA2 enabled?
What happens if the the phone tries to connect using open authentication?
Highlighted

yes, wpa and wpa2 are enabled. i have tried with open authentication local web policy and the result is still the same.

 

i didn't have these problems before and i used to connect to ac just fine so it just surprised me that i can no longer connect to ac. last time i did some re-configuration was about 6 months ago so its hard for me to recall the last changes i have done.

Highlighted

Your channel width is 80 Mhz or only 40?
I assume you have NOT selected TKIP, right?
Highlighted

yes, channel width is 80 Mhz. No TKIP

Highlighted
Hall of Fame Community Legend


@rlaudiano wrote:

yes, wpa and wpa2 are enabled


Choose only one.  It is either WPA or WPA2.  Don't turn on both and "hope" the wireless clients can make the right decision.  The wireless clients won't.