cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15570
Views
63
Helpful
11
Replies

12.5 Finesse. Failed to load the gadget.

chuck47172
Level 1
Level 1
Cisco Unified CCX Administration
System version: 12.5.1.10000-31 (ES03-93)
Finesse
ANYONE SEEN THIS AND KNOW A FIX?
When user tries to open in Finesse My History, Team Data, Queue Data they get the following error...
'Failed to load the gadget. Either CORS is not configured or a problem has occurred in the Reporting Service. Please contact your administrator.'
 
I found this BUG and I'm wondering if it is the same issue...
CUIC Live Data 12.5 - Issue with 'agentproxy' user generates improper logging
CSCvv62955
11 Replies 11

Did this just start happening, has it ever worked, etc.?

Here's some of the options as far as the settings, maybe see if you make it wide open temporarily to try and resolve your issue?

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/finesse/finesse_1251/admin/guide/cfin_b_1251-administration-guide/cfin_b_1251-administration-guide_appendix_01111.html#reference_F298A59463A427B9D63A327832964A76

Jose Gomez
Level 1
Level 1

Hi, does anyone found out how to fix this issue?

 

the workaround just says "None".

Yasid.ramli1
Level 1
Level 1

Hi @chuck47172 

 

you should enable CORS on CUIC Publisher and Subcribber like below

 

On CUIC:

utils cuic cors enable
utils live-data cors enable
utils cuic cors allowed_origin add https://<finesse-FQDN>
utils cuic cors allowed_origin add https://<finesse-FQDN>:8445
utils live-data cors allowed_origin add https://<finesse-FQDN>
utils live-data cors allowed_origin add https://<finesse-FQDN>:8445

Restart the following services:

* utils service restart Intelligence Center Reporting Service
* utils service restart CCE Live Data NGINX Service
* utils service restart Cisco Finesse Tomcat (on Finesse server)

Hi,

Thanks!!! It works just as you post it!!!

Is this production impacting?  I am facing the same issue. 

When I encountered this issue it was only impacting specific users. I found out that the affected users were missing a permission in CUIC. Login to Unified Intelligence Center or the UCCX server that houses your CUIC. Navigate to Configure -> Users -> Search for the user using the search bar at the top. Click on the user and navigate to "Assign User Group" in the top right of the Edit User screen. The affected user is most likely missing the "ReportingUsers" group. Add that group, save, and have the user log out/log back in. This is what resolved the issue in my scenario.

worked for me - but i needed  to add the agent permissions as well - reporting did not do the trick. I dont know why  the agent persmission were missing in the firts place, but it was a new agent

I used same steps for CCE, only difference is running live data commands on your live data servers

Disprovable
Level 1
Level 1

I've just started encountering this issue as well. We are not running a standalone CUIC server. We're using UCCX to host the reporting side of things. Has anyone found any other fixes for this?

tsuntken
Level 1
Level 1

This resolved CORS error in Finesse for me in UCCX...

 

Go to CUIC --> Configure --> Permissions

 

on the top right Group Permissions should be selected.

 

In the select entity dropdown select Data Sources.   

 

Select Live Data Streaming Data Source. Tick mark AllUsers View, click Update 

 

Not sure if needed but I also did... Select UCCX. Tick mark AllUsers View, click Update 

 

In the Drop down select Reports and drill into the Live Data. I assigned "AllUsers" view access to everything possible I could and I finally got the reports to display in Finesse.

 

 

 

I found this bug that solved my problem after an upgrade - the bug says from 11.6 -> 12.5.1 but I confirmed with TAC that it applies from 11.x -> 12.5.x

CSCvx60122 : Bug Search Tool (cisco.com)

Workaround:

1. From the CCX Pub OS Admin > Security > Certificate Management, delete the CUCM self-signed tomcat-trust certificates

2. Verify if the same are deleted from the CCX Sub

3. Download the tomcat certificate from the CUCM OS Admin from each CUCM nodes used by CCX

4. Upload these CUCM tomcat certificates as Tomcat Trust certificates on CCX Pub

5. Verify if the same certificates are replicated to the CCX Sub

6. Reboot the CCX cluster