Showing results for 
Search instead for 
Did you mean: 

CCX 8.5 Agent Login Issue


I recently upgraded a customer from 8 to 8.5 to fix an issue and have run into a new one.

For three agents I've gotten the error message: "Login failed due to a configuration error with your phone and JTAPI or Unified CM. Contact your administrator."

For two of them, the fix was to un-associate and re-associate their device with the RmCm user. For the last fella, I've tried complete rips and rebuilds and I can't get him past the error message.

Any ideas?


40 Replies 40

I have this issue..

2. Login failed due to a configuration error with your phone and JTAPI or

Unified CM. Contact your administrator.2. Login failed due to a configuration error with your phone and JTAPI or
Unified CM. Contact your administrator.

Here is my details :


No shared line configured

Extension are not configure on other button than 1 and 2

The application user have the device or the device profile associated  and both same result.

I did a reset when the profile is loaded on the phone or when the profile is not loaded, same result.

I found that removing the devices and the device profiles from the RMCM user, saving the change, then re-adding all the device profiles, but not the devices themselves, to the RMCM user and saving the config prevented this error from occuring

Hi Philippe ,

Please access the Resource page from UCCX Admin->RmCm->Resources, and cross verify if the Agent ID and UCCx entensions are apperaing correctly.

Also try performing the directory Resync operation from the Cisco Desktop Administrator and try logging in one more time.

Hope it helps.


pls rate helpful posts !!

As a Cisco Partner, I've had to deal with this for about a dozen customers so far. And as listed earlier, there are several issues that can cause this same message. But if you are using Extension mobility, a combination of what "Adam Need" and "anchoudh" works for me.  For extension mobility users, who are UCCX agents, the physical device should be unassocaited with the RMCM user. And then the Device profile should be assocatied. Once its complete, then goto the Cisco Desktop Administrator and performing a Resync.

The bug in reference is CSCtx48427.

I know this has already been talked about, but sometimes people dont read the whole thread, especially when it's this long.

I find an old phone in the RMCM applicaton user,

i removed it, i think it work

I'm still seeing this issue quite frequently in CUCM and UCCX Occasionally, the steps that "eyeheartcisco" worked for me, however, I also found myself deleting all devices and device profiles and starting from scratch. Today, I had a case where none of these steps worked. Ultimately, I ended up digging through my notes to find what device last used the extension experiencing the error. Mind you, the extension was not associated with the old device, but it used to be several months ago. I had to remove the old device from the RMCM application user and that did the trick. I can imagine a case where I do not have notes if another engineer did the setup, so I guess I'll be going through manually and cleaning up the devices associated with RMCM user.

Cisco really needs to address this bug and publish/update an existing one so it's actually helpful. I followed the details in

CSCtx48427 however, it wasn't very helpful since the old device that I removed that wasn't even associated with the extension.

Hope this helps someone else in the future.

For anyone using  IP Communicator and this issue happens.. 

What worked for me was to go to RMUser (Application User) queue or any queue where the related phone/mac is associated with and remove the specific phone, save, and go back in again and re-add the same user.

Also, sometimes running  Agent as "Administrator" maybe help.



Pascal Thibodeau

Here what i found The RMCM user in CUCM must have the CTI profile you want to use. Here a little procedure that fixed my issue.

Anurag Siddhu

Hi David,

this is very common issue that has been going on for a long time with almost every 8.5 and 8.6 version of the call manager.

"this is a CTI manager issue" and as i see that lot of people have pointed it out as well.


there are multiple workarounds to this , easiest of them is associate\diassociate the phones with application user( this will fix the issue if you are really lucky ) ,2nd is restart the CTI manager which is difficult because lot of people use multiple CTI applications these days,

there are couple of combo issues (getting this error with EM , without EM and so forth )

i will recommend to upgrade the Call manager to higher 8.6 train if you wanna live a peacefull environment :)





Hi All,

I ran into this error when replacing an agent's phone. I'm running CUCM and UCCX Both of which, need updates. But, for anyone else seeing this issue, here's how I solved it.

I added the new phone.

I remove the device association from her account.

I deleted the old phone.

Then I added the associations for the new phone to her account.

.... I continued to get this error ....

After looking at the RMCM user, I noticed that her old phone was not in the associated list, but the new phone wasn't in there either. I added it manually and that fixed the problem for her and she could login.

I'm guessing a reset of the CTI would have also worked, but this worked for me without affecting other agents.

Hope this helps someone.


Thanks for the post, it showed me exactly where the issue was. I was able to just remove the old device association.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers