Showing results for 
Search instead for 
Did you mean: 



Morning All


Wonder if any of your fine folks could help me out with a UCCX 11.6  / Finesse / CUCM 11.5 issue.


We have 100+ agents on a new CCX deployment, 3 of those agents get Finesse error,




when they first login and try to change from Not Ready to Ready State.


The current work around I have in place is to lift the handset of the agent phone and then instantly the agent can change state until they logout again...


This affects agents if they login to a 7942 / 7962 or IP Communicator ( I don't have any other handsets to test at present)


The wiki below did not resolve issue.


any help much appreciated.





42 Replies 42

Ok, then I bet you are hitting this bug. I can see a bug with this error code as a generic error code for different Finesse Issues. Currently its an Enhancement with no workarounds mentioned. Please check this link.


failureCode:CF_RESOURCE_OUT_OF_SERVICE is a generic error code for different Finesse issues
Hope this helps!


***Please rate helpful posts***

Restart the CTI Manager on both Pub and Sub for the CUCM and that should resolve the issue.

Hi team,


I have same problem. But all agents are using Jabber and an intermittent case, I have already opened several cases in Cisco tac including for the callmanager and never found anything.

Daniel Sobrinho

Just logout and log back in.

Hi Guys.

I also had this exact issue and I managed to resolve it. The user had been given a new phone 8811 and the old phone 7962 had its associated number removed. The application users RMCM/IPPX user still had control over the old 7962 even though it didnt have a numnber associated with it. I removed it from being associated with the application users and then the phone worked as expected.




Thank you SuperAmp! Your solution worked fantastically!!!

What exactly are you referring to ? 

in CCM under Users > Device Information > Controlled Devices? 

Similar resolution for us. We found this issue with a new agent. It turned out they were assigned a CCX DN of a previous agent who'd left the company a while before. We ended up just assigning the agent a new DN that had never been used, and she was able to go into ready right away. 

I had a similar message when provisioning a smart phone in addition to the staff member's desk phone (remote due to Covid). The solution was to go into CM Admin --> Users --> Application User --> find rmcm user --> In device association, uncheck their SEP IP phone -->  then click, save selected changes.

Have the user log off and back into Finesse and they were able to toggle to Ready state with Jabber set to the Computer phone.

Obviously, the rmcm device association settings will have to be switched back to their IP phone when they come back into the office.


I could kiss you. This solution worked. Thanks!!!

Thanks a lot David, this fixed it for me.

This Helped me tonight after I moved a UCCX agent from Physical CPIC , agent was able to log back in to Finesse but was getting error when tried to get to ready state, Had to just off hook and on-hook the soft phone to be ale to get back to ready state in Finesse, Thanks to davidblair for the post.

This is works with us, amazing


Some of our call center agents work from home for part of the week using Cisco Jabber's soft phone functionality. I started getting reports that they were receiving this CF_RESOURCE_OUT_OF_SERVICE error when they were on-prem trying to change their state to "Ready". They had not selected the option to use their desk phones in Jabber which was preventing them from successfully changing their state to "Ready".


Specific use case, might not be totally relevant. 

Channing Merritt

I had a similar problem and found that even though I had the EM Profile under the FIPPA application user as a CTI controlled Device profile the fix was to add the mac address of the phone he was logged into as a controlled device in the same FIPPA created application user for Finesse.


I had an RMCM application user configured from back on the 10.5 days but since upgrading to 11.5 CUCM we created a new FIPPA application profile which was causing mix results for us having both the EM Profile and MAC under both applications in CUCM.


Maybe this will help

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers