Showing results for 
Search instead for 
Did you mean: 


Level 5
Level 5

Morning All


Wonder if any of your fine folks could help me out with a UCCX 11.6  / Finesse / CUCM 11.5 issue.


We have 100+ agents on a new CCX deployment, 3 of those agents get Finesse error,




when they first login and try to change from Not Ready to Ready State.


The current work around I have in place is to lift the handset of the agent phone and then instantly the agent can change state until they logout again...


This affects agents if they login to a 7942 / 7962 or IP Communicator ( I don't have any other handsets to test at present)


The wiki below did not resolve issue.


any help much appreciated.





45 Replies 45

Mark Swanson
Level 4
Level 4

Hmmm Ok. How many seat licenses do you have? This is unlikely the problem because if you exceeded this threshold, then it would've likely generated a different error message.

Do you know if the Publisher is the primary (M) server right now? If not, how long has the services been 'up'?

All of the agents located in the same area, or are they spread across multiple locations? If so, where is your system located (timezone)? And, where is the furthest agent(s) located at? What's the RTT between the system(s) and agents? FYI - the max RTT between UCCX and Cisco Finesse is 200ms.

Also, do agents have access to other devices besides the ones listed above? Are they CTI enabled? Do agents have User Device Profiles (UDP) as well, or login via Extension Mobility?



How many seat licenses do you have? 100 seat premium license.

Yes publisher is primary server.

Affected users are in the same area. They are only two users out of 50 that have the issue.

Agents have UDP to login using EM.


I am onsite today to do more testing

Check the following;

  • Login to CUCM Admin. Navigate to User Management > Application User.
  • Select the RmCm (RM-JTAPI) user account that you created for UCCX device management.
  • Under this App User account, there's two control types; Controlled Devices & CTI Controlled Device Profiles.

Which one is currently configured?

If you're using Extension Mobility (EM), then you should be identifying which devices will be managed/monitored by UCCX and list these devices as Controlled Devices.

Ideally, you want to eliminate any unnecessary dependencies the agent(s) may have listed under the End User profile; Related Links > Dependency Records. As you already know, agents can't login to Cisco Finesse while they're login to multiple devices via EM. Agents would notice a slightly different error message.

This error message is likely caused by configuring both Controlled Devices & CTI Controlled Device Profiles, or by not enabling CTI control on the End User profile, User Device Profile, DN, physical device or there's permissions [roles] problems.


Level 1
Level 1
Hi Kev,

Logically, that message usually comes from the peripheral (in this case CUCM) when device check is performed during the login sequence. However, it can also be that UCCX has a 'corrupted view' of the device's state hence it reports it. For any of above two reasons, that is why you can reset the state by lifting a handset since it initiates device state change from CUCM side which in turn over JTAPI resets UCCX 'view' as well.

Mark's questions are valid as understanding environment will assist better in addressing the issue. I would add few more:
- You mentioned 'when they first login'. Can u elaborate this part? is it that once you reset it first thing in the morning it doesn't happen during that day anymore? does it happen tomorrow or how long do you have to wait for it to happen again?
- If you associate some other user with one of those devices does it also happen for that user?
- If you associate one affected user with some other device does it still happen for that user?
- What about if you try to completely remove and re-add one of those users and his/her device - does it happen to that particular user+device anymore (leave other 2 to compare)?
- How many CUCMs do you have with CTI service running? Sometimes you need to stop all CTI servers (be careful, don't do it during the production hours) and once all are stopped then start one by one to resolve 'cti state corruption'.

I hope this helps,

Hi Goran


The issue happens at the start of every shift, daily. if the agent logs out of phone and finesse for a break the issue occurs again when they return.


I have tested UDP with other devices and the issue occurs which suggest issue with UDP.


I have deleted and recreated the user and UDP and the issue returns.


I will give CTI reset a go.


thanks for the reply




Hello Kecv,


Please follow these steps to fix the issue -

1. If you want to use extension mobility - If yes, then under rmcm user only associate the Device Profile and remove the IP Phone device association.

2. If you just want to use the IP Phone - Add the IP phone under device association under rmcm user.


Note - Assuming recommended configuration for jtapi and axl users.


Please remember to mark useful posts and discussions.


Kind regards,

Dinesh Rathi

thank you , this is very useful , 

I have the same issue today. I delete the user, the device profile and the extension. I recreate all of them, then I try to logging to Finesse and I got the same error. I restart the CTI Manager service and it solved the problem

Hello , I am having this issue as well , Restarting CTI Manager Service , what user outage will this cause ?

When did you restart the service ? 

Restarting the CTI Manager will drop JTAPI connectivity to any 2nd party / 3rd party servers, so it will drop your agents and ports (dropping queued calls) on CCX and then build them right back up.

I have this issue with a CCX 11.6 (base) customer and Goran's reply helped.

Intermittently, agents would receive the CF_RESOURCE_OUT_OF_SERVICE message when they tried to go Ready. All agents are using EM in this environment. The Finesse client itself would hold the corrupt information on the phone state, so we were getting led astray by some workstations working and others not.


The workaround to clear the error was:

-Have the agent log in to EM and Finesse

-Try to go Ready

- Click OK on the error message, but leave Finesse in the Not Ready - Phone Failure state

- Take the phone off-hook then on-hook

- Change the agent state to Ready


Currently checking to see if this is a known bug and if it's fixed in ES02 or not...

Hi, did you get anywhere with this? Is it a bug, we are experiencing the same issue. I’m just going to try the recommendations but curious to know if it is in fact a bug.

Cisco doesn't have it listed on their bug search tool, but it is a bug. Another customer on 11.6 contacted me over the weekend and stated that they are having the same issue. In both scenarios, everything is setup in a supported configuration (no shared lines).

We are also on 11.6 and experiencing this same issue. Was there a resolve for this Bug?  I already miss CAD.