cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
26336
Views
25
Helpful
20
Replies
Highlighted
Beginner

ATA 187 outgoing fax problem !!!

hi to all..

we've installed ATA 187 in CUCM 7.1(5) for fax services..

before ATA 186 EoS, our client used ATA 186 and now they've bought bunch of ATA 187's..

so, on ATA 187 we're receiving fax sucessfully, but we cannot send faxes towards PSTN..

since ATA 187 introduced device settings on CUCM admin page instead web page of device itself, we configured fax passthrough on CUCM admin page..we didn't touch other parameters..all gateways use fax passthrough..

so, the call is established but fax communication fails..

we're getting "communication error" on fax machine..

analog phones can make outgoing calls just fine..

we can also make local fax calls between ATA's  ( 187 & 186 ) but not to PSTN..

so, gateway to PSTN is h.323 gw ( AS5350 & 2821 )..and they use fax passthrough..

all the ATA186 in system do not have this problem..they work just fine..

any ideas before opening TAC case..

thanx..

regards..

Everyone's tags (2)
20 REPLIES 20
Highlighted
Cisco Employee

Re: ATA 187 outgoing fax problem !!!

Hello Sinisa,

                  I hope you are doing well, could you please ensure that the configuration on the gateway is fine


Please ensure that you have the following config in place:-


dial-peer voice 1 voip
  fax protocol pass-through g711ulaw  


Either on the outgoing dial-peer or if you wish you enable it globally you can have the config under the voice service voip config.


please also include the following command, if there are issues with transmission speed.


no fax-relay sg3-to-g3 

Could you please update me with the following :-


     1. Create a logging buffer

    logging buffered 5000000
    logging rate-limit 10000
    logging queue-limit 100000

Please enable the following debugs

1. Debug voip ccapi inout

2. Debug isdn q931 ( if pri)

3. Debug voip rtp session nse

4. Debug voip rtp session named events

Please ensure that you issue a "CLEAR LOG" before you make the test, once the test is made, please ensure that you follow this procedure

1. sh deb

2. u all

3. term len 0

4. sh ver

5. show run

6. show logg

Please ensure that you remove all ip/password details before posting on public forums.

I hope this helps.

Regards,

Amit.

   

Highlighted
Beginner

Re: ATA 187 outgoing fax problem !!!

hi amit..

..

thanx for reply..

we  staged the scenario in our lab ( although we used CUCM 8.0 instead  7.1(5)  at customer ) and we managed to solve the problem..

originally we had classic passthrough configuation on gateway ( incoming dial-peer form CUCM towards gateway )..

!

dial-peer voice 102 voip

modem passthrough nse codec g711alaw

voice-class codec 1

incoming called-number .T

dtmf-relay h245-alphanumeric rtp-nte

fax rate disable

no vad

!

since, there are a lot of ATA 186 which have POS terminals and faxes connected..

so, customer is using passthrough in entire network..

it turned out that ATA 187 doesn't "understand" modem passthrough nse codec g711alaw..or at liest we we think it is like that..

which may be expected behaviour..it likes fax protocol commands....

so, when we enabled t.38 on ATA 187 and gateways outgoing calls were successfull..

even when we forced passthrough in ATA 187 CUCM admin page it went t.38 ( and it succeeded ) until we disabled fax rate on gateway ( in that moment it used passthrough )..

in every single scenario fax succeeded except when we had above config which forces modem passthrough nse..

in that scenario, call is detected as simple  voice ( not fax or passthrough ) call and that is the reason it is  failing ( although it could work as well, but it ain't )..so, the final config is like this..

!

dial-peer voice 102 voip

modem passthrough nse codec g711alaw

voice-class codec 1

incoming called-number .T

dtmf-relay h245-alphanumeric rtp-nte

fax rate 14400

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

no vad

!   

as you may notice we left modem passthrough nse codec g711alaw as well..

the thing is we needed to provide all ATA 186 modem passthrough nse codec g711alaw..

or maybe we could use only:

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

maybe ATA 186 would catch on fallback passthrough..but i'm not shure in that..

we didn't test it..

without modem passthrough nse codec g711alaw..

but to be honest, we didn't had time or nerves to test it....

since we made it work..

also as already said,  interresting is that we couldn't force ATA 187 to do passthrough (  although forced in CUCM admin page ) until we issued fax rate disable  command on gateway..

anyway, maybe the final config to  have only passthrough in network would work with using only fax protocol  passthrough, but as said we didn't test it..

above mentioned config worked for us in ATA 186 & ATA 187 enviroment..

we decided that we're going to use t.38 for ATA 187 and passthrough for ATA 186 clients..

t.38 is anyway more "fancy"....

as tested so far it looks like it is working for all of them..

we'll see, what happens..

p.s.

i know about the "no fax-relay sg3-to-g3" "trick", but we didn't try to play we it at this moment..

thanx..

regards..

Highlighted
Participant

Re: ATA 187 outgoing fax problem !!!

Hi Amit,

I am facing the same issue with ATA 187, the difference is i am using MGCP gateway....Can you kindly sugegst what needs to be fine tuned so that i can send FAX using ATA 187??

Beginner

Re: ATA 187 outgoing fax problem !!!

Hi Sinisa,

Thanks for your post. It helped me a lot to make incoming fax working (ATA187 and T38).

However I can't make it work for incoming call.

Debug isdn q931 is giving this output for incoming fax test

CME_2811#
Feb 25 13:28:00.988: ISDN Se0/1/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0A84
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98394
                Exclusive, Channel 20
        Calling Party Number i = 0x0083, 'XXXXX'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0xC1, 'XXXXXX'
                Plan:ISDN, Type:Subscriber(local)
Feb 25 13:28:00.988: ISDN Se0/1/0:15 Q931: Received SETUP  callref = 0x8A84 callID = 0x0A7B switch = primary-net5 interface = User
Feb 25 13:28:00.992: ISDN Se0/1/0:15 Q931: TX -> SETUP_ACK pd = 8  callref = 0x8A84
        Channel ID i = 0xA98394
                Exclusive, Channel 20
Feb 25 13:28:08.944: ISDN Se0/1/0:15 Q931: RX <- INFORMATION pd = 8  callref = 0x0A84
        Sending Complete
Feb 25 13:28:08.960: ISDN Se0/1/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8A84
Feb 25 13:28:09.032: ISDN Se0/1/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8A84

So I get an Alerting during 40 seconds and then nothing (Disconnect/Release complete)


Is there something special to configure on the ATA187 or Voice Gateway ?

Thank you very much

Regards

Fabian

Highlighted
Frequent Contributor

Re: ATA 187 outgoing fax problem !!!

Hi,

I also face big problems with ATA187 and FAX.

We finally found an old ATA186 and replaced the ATA187 with it -> problem solved.

There is a serious issue with ATA187 and FAX.

I am using MGCP so I don't have dial-peers that I can modify AND I AM NOT GOING TO SWITCH TO H323!!

I changed on the callmanager page the FAX settings from the ATA187 to pass-thru, changed more parameters, result is that ATA187 and FAX don't work correctly.

Hope that there will be a solution since the ATA186 is not for sale anymore,

Jan

Highlighted

Re: ATA 187 outgoing fax problem !!!

Hi  all,

Same problem here,

We have an IP telephony network based on CUCM 7.1.3 and Cisco 2821 with IOS 12.4(20)T2. We had working properly ATA-I-186 with fax passthrough and a Rightfax IP Fax server using T.38 (by a SIP trunk).

Last week, we upgraded the cluster to versión CUCM 7.1.5 to support the new ATA-I-187. We found that outgoing faxes don´t work neither using fax passthrough or T.38. the incoming faxes work properly in both protocols.

Surprisingly we do a test sending an outgoing FAX to an inbox in the RightFax  using the internal LAN  (dialing directly to the inbox directory number routed to the RightFax without using the media gateways) and the FAX was delivered properly using T.38.

So my conclusión is that there is something wrong in the block CUCM + MGCP Gateway. From traces we found that in the fail outgoing calls, Cisco Media gateways are requesting to ATA-I-187 to switch to FAX mode using NSE packets and that is a Cisco propietary mechanism not covered by SIP´s RFC´s

Juan Manuel Munárriz

Highlighted

ATA 187 outgoing fax problem !!!

Hey,

Ive been facing loads of issues with ATA 187 too.

I have a small solution. Its not a 100%. We are still under monitoring stage.

ATA 187 - (MGCP)

Supports only T38

ECM mode - OFF

Fax Rate - 9600 or 14400 bps

Impedence - 600 ohms real

IOS - flash:c3900-universalk9-mz.SPA.150-1.M4.bin

Ive tried with a couple of other IOS and I always faced issues.

Please let me know if you guys have any workaround/solutions apart from this.

Regards

Shabeeb Mohammed

Highlighted
Beginner

Re: ATA 187 outgoing fax problem !!!

There's so many of us having ATA187 problems. I wish Cisco would do something about it. I'm lucky to have a bunch of 186s so I just replace 187s with 186s.

Highlighted
Beginner

ATA 187 outgoing fax problem !!!

We have had many issues trying to get fax working through the 187, Cisco 2811's running under MGCP

This has now been sorted out,

Cucm 7.1.

Put the latest 9.2.1 187 firmware on, upgraded the routers to minimum IOS 12.4 24 T2.

Sorted.

Rich

Highlighted
Beginner

ATA 187 outgoing fax problem !!!

Hi

Mind to share your MGCP gateway config?

Are you using T.38 on your ATA187 for fax?

Highlighted
Beginner

Re: ATA 187 outgoing fax problem !!!

Poštovani, u periodu od 01.08.2011. do 22.08.2011. ću biti na godišnjem odmoru, sa ograničenim pristupom elektronskoj pošti.

Molim vas da se za hitne poslove i intervencije obratite na e-mail adresu voip@mds.rs ili na telefon +381 11 2015 280.

Dear Sir or Madam, I will be on holiday between 01.08.2011. and 22.08.2011. with limited access to e-mail communication.

In case of any emergency, please use the following email address voip@mds.rs or phone number +381 11 2015 280.

Srdačan pozdrav/Kind Regards

Sinisa Djokic

Highlighted
Beginner

ATA 187 outgoing fax problem !!!

Hi,

We're using CUCM 8.6.2 and IOS 15.1 on 2921.

Using MGCP. 

FAX doesn't work outgoing, not in T38 and not in passthrough.  So I wouldn't say the problem's "sorted", at least not for our model of router.

If anyone has any ideas on how to fix this, I'd appreciate it.  And no, I'm not going for H323 on the gateway.  Next problem will be to get it to work with SRST ...  even in SRST there won't be any voip dial peers such as configurations pointed out earlier, to fix this.

Basically I'm experiencing the same problem as everyone else, even with latest versions of everything.

Anyone know something I don't - about this problem - ?

Highlighted
Beginner

ATA 187 outgoing fax problem !!!

Hi,

We have CUCM 8.5 and 3900 as MGCP gateway, we are also facing 'Transmission Error' with ATA 187. We have the following configured globally on the gateway:

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

We also upgraded to latest 9.2.3 firmware for ATA still the problem is there. Need help!!

Highlighted
Beginner

ATA 187 outgoing fax problem !!!

I had the same frustrating problem, but I finally managed to get my ATA187 faxing to work. The below is what I did:

EQUIPMENT:

CUCM 7.0.1 on MCS servers

Cisco 2901 Router configured as a H323 gateway

ATA187 (2 units)

ISDN PRI E1

PREREQUISITES:

Need to install the cop.sgn files for ATA187 in order for CUCM 7 recognize the devices

SOLUTION:

1) Ensure there is ringback tone. Also set fax protocol to pass-through. (for both publisher & subscriber)

dial-peer voice 203 voip

preference 3

destination-pattern 0...$

progress_ind setup enable 3 //Enables ringback

no modem passthrough

session target ipv4:172.16.28.102 //Subcriber IP

dtmf-relay h245-alphanumeric rtp-nte

codec g711ulaw

fax-relay sg3-to-g3

fax protocol pass-through g711alaw

no vad

!

Note: I noticed without the progress_ind comment, i will not receive a ringback tone when i make direct calls to any of the cisco phone endpoint.

2) Set fax protocol passthrough at "Service Voice VOIP"

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol pass-through g711alaw

!

3) Fax Mode needs to be set as "Passthrough". This option will be at ATA187 phone device under CUCM Administration. Max Fax Rate set as 14400bps.

4) I went to the fax machine and also set the fax speed to match the ATA187 setting. In my case, it was V.17 which supports 14400 speed.

RESULT:

Send/Receive fax to your hearts content

I hope the above settings will help you solve your faxing heartaches with the ATA187. Good luck

CreatePlease to create content