cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

530
Views
5
Helpful
6
Replies
Highlighted
Beginner

connecting multiple devices with same ip address which can't be changed

Hi everyone , 

 

i am quite new . I have been stuck up from quite few days . i have to implement a solution for the below requirement . 

 

1) i have 15 devices  with same ip address ( ip address is hard coded inside and can not e changed ).

2) each device need to communicate with a PC.  

3)  device don't need to communicate with themselves. they just need to communicate with PC. 

4) we are allowed configure PC to Static or dhcp ip . 

 

How to achieve this  ? any kind  of  recommendation  would be very helpful 

-------------------------------------------------------------

-> also  i was already  looking at nat solution but not sure which switch would be able to perform this job.

 -> also not sure which architecture would be good    without  router or with router Capture1.JPGCapture2.JPG

 

 

 

Hi ,

The customer devices have same ip.
What they want is to either recognise the device using the switch port to which it device is connected or to generate a maksing ip which can be used in place of device ip to connect to a device .
2) The pc is on the same network and we are free to select any ip static or dynamic to it.

 

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Engager

Re: connecting multiple devices with same ip address which can't be changed

Hi,

Below is the Which I have configured:
LAB1.png

 

 

 

 

 

 

Switch R1 is working as Layer 3 

R4 is performing NATing+VRF

A link between R1 and R4 is a trunk port.

 

Router R4 Configuration:

ip vrf PC-2
 rd 2:2
!
ip vrf PC-3
 rd 3:3
!
no ip domain lookup
ip cef
!

interface FastEthernet0/0
 no ip address
 duplex half
!
interface FastEthernet0/0.2
 encapsulation dot1Q 3
 ip vrf forwarding PC-2
 ip address 172.16.1.254 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
!
interface FastEthernet0/0.3
 encapsulation dot1Q 4
 ip vrf forwarding PC-3
 ip address 172.16.2.254 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
!
interface FastEthernet1/0
 ip vrf forwarding PC-3
 ip address 10.10.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip vrf forwarding PC-2
 ip address 10.10.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
!
!
ip nat inside source list 1 interface FastEthernet0/0.2 vrf PC-2 overload
ip nat inside source list 1 interface FastEthernet0/0.3 vrf PC-3 overload
ip nat inside source static 10.10.10.1 172.16.1.254 vrf PC-2 extendable
ip nat inside source static 10.10.10.1 172.16.2.254 vrf PC-3 extendable
ip route vrf PC-3 192.168.1.0 255.255.255.0 172.16.2.1
ip route vrf PC-2 192.168.1.0 255.255.255.0 172.16.1.1
!
access-list 1 permit any

Switch R1 Configuration:

!
IP routing ! interface FastEthernet0/0 no ip address duplex auto speed auto ! interface FastEthernet0/0.2 encapsulation dot1Q 3 ip address 172.16.1.1 255.255.255.0 ! interface FastEthernet0/0.3 encapsulation dot1Q 4 ip address 172.16.2.1 255.255.255.0 ! interface FastEthernet1/15 switchport access vlan 2 ! interface Vlan1 no ip address ! interface Vlan2 ip address 192.168.1.254 255.255.255.0

 

And here is the result:

PC-2 ping.png

PC-3 ping.png

 

Servers to Client Ping:

Pc-2 client ping.png

 

Regards,
Deepak Kumar

Regards,
Deepak Kumar,
Resume duty after a long holiday
6 REPLIES 6
Enthusiast

Re: connecting multiple devices with same ip address which can't be changed

Hi,

 

this is bit strange situation. i have few clarifications,

1 - how your application identifies each device separately if using same IP? (may be that is not a concern)

2 - what is the IP address of communicating common PC? is it in same network?

 

 

Beginner

Re: connecting multiple devices with same ip address which can't be changed

Hi ,

The customer devices have same ip.
What they want is to either recognise the device using the switch port to which it device is connected or to generate a maksing ip which can be used in place of device ip to connect to a device .
2) The pc is on the same network and we are free to select any ip static or dynamic to it.
Enthusiast

Re: connecting multiple devices with same ip address which can't be changed

hi,

Update 1 -

normally, you cannot duplicate L3 connectivity with IP addresses unless you use NAT. in this case you can use NAT for each device. this is only suggestion. 

 

you need separate router's for each devices and create Virtual NAT range (different networks which are not available on your network) for each device. 

connect all routers to 1 another router and do correct routing. in this case you need to have different IP range for main PC too. if you need to have same range with devices, you can do another virtual NAT in main router too.

this is possible technically, but not feasible for non branch network

 

Update 2- 

also you may be able to use VRF with 1 router. needs some good guidance. because i am not very good in VRF :)

 

 

Beginner

Re: connecting multiple devices with same ip address which can't be changed

Hi kasun... thanks for the help . I was also thinking to go with vrf . But i also not so good at it .

Nat capable l3 switches arequite expensive . Any suggestion is there any switch which can do the natting
VIP Engager

Re: connecting multiple devices with same ip address which can't be changed

Hi,

Are those devices offering the same services? If one device is getting the update will sync with all devices same like a database?

Only VRF is also not looking a good solution if all of the devices offering identical services and there is no sync between all devices. Because whenever PC will reply to the IP address then routing protocol, CEF, or ARP will take a decision and it may load balance or reply to the single system only.

 

You may archive your goal with NATing + VRF. Let me test in the lab and will come back.

 

Regards,

Deepak Kumar

 

Regards,
Deepak Kumar,
Resume duty after a long holiday
VIP Engager

Re: connecting multiple devices with same ip address which can't be changed

Hi,

Below is the Which I have configured:
LAB1.png

 

 

 

 

 

 

Switch R1 is working as Layer 3 

R4 is performing NATing+VRF

A link between R1 and R4 is a trunk port.

 

Router R4 Configuration:

ip vrf PC-2
 rd 2:2
!
ip vrf PC-3
 rd 3:3
!
no ip domain lookup
ip cef
!

interface FastEthernet0/0
 no ip address
 duplex half
!
interface FastEthernet0/0.2
 encapsulation dot1Q 3
 ip vrf forwarding PC-2
 ip address 172.16.1.254 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
!
interface FastEthernet0/0.3
 encapsulation dot1Q 4
 ip vrf forwarding PC-3
 ip address 172.16.2.254 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
!
interface FastEthernet1/0
 ip vrf forwarding PC-3
 ip address 10.10.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip vrf forwarding PC-2
 ip address 10.10.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
!
!
ip nat inside source list 1 interface FastEthernet0/0.2 vrf PC-2 overload
ip nat inside source list 1 interface FastEthernet0/0.3 vrf PC-3 overload
ip nat inside source static 10.10.10.1 172.16.1.254 vrf PC-2 extendable
ip nat inside source static 10.10.10.1 172.16.2.254 vrf PC-3 extendable
ip route vrf PC-3 192.168.1.0 255.255.255.0 172.16.2.1
ip route vrf PC-2 192.168.1.0 255.255.255.0 172.16.1.1
!
access-list 1 permit any

Switch R1 Configuration:

!
IP routing ! interface FastEthernet0/0 no ip address duplex auto speed auto ! interface FastEthernet0/0.2 encapsulation dot1Q 3 ip address 172.16.1.1 255.255.255.0 ! interface FastEthernet0/0.3 encapsulation dot1Q 4 ip address 172.16.2.1 255.255.255.0 ! interface FastEthernet1/15 switchport access vlan 2 ! interface Vlan1 no ip address ! interface Vlan2 ip address 192.168.1.254 255.255.255.0

 

And here is the result:

PC-2 ping.png

PC-3 ping.png

 

Servers to Client Ping:

Pc-2 client ping.png

 

Regards,
Deepak Kumar

Regards,
Deepak Kumar,
Resume duty after a long holiday
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards