Showing results for 
Search instead for 
Did you mean: 

Gila Wallboard UCCX 8.x

Level 1
Level 1

I have successfully gotten the Wallboard 2.4 and others working on 8.x but still have issues with the Gila Wallboard.  Does anyone have a modified version of this wallboard working on uccx 8.x?


13 Replies 13

Level 4
Level 4


I would also like this!

Does any one know what else is out there for 8.x?

I also used Wallboard 2.4.( which works fine.

However it would be really useful to get something that does specific CSQ’s and specific teams!


Wallboard 2.4 happily does specific teams, you just need to add in a couple of WHERE TeamID = x in the SQL queries.

This is kind of an old post, but if this help, I modified the gila wallboard to be used with UCCX 8.x, it is very simple, I just add to the "SQL Database Connector" module this line:

ElseIf IPCCversion = 8 Then

    WBConnect = "Dsn=acdDbRte; Host= " & DBsource & "; Server= "& DBServer & "; Service=1504; Protocol=onsoctcp; Database= " & DBdatabase & "; Uid= " & DBuserID & "; Pwd= " & DBpass

I am attaching the complete files.


Thanks for that, it works perfectly now!

One question, all of our CSQ's are seperate teams and as such want to only see their own CSQ's. The overall stats etc would ideally need to be for selected CSQ's.

Is that easy to achieve?


Level 1
Level 1

I can not for the life of me get this damn wallboard working on 8.5.  I've tried adding "

    WBConnect = "Dsn=acdDbRte; Host= " & DBsource & "; Server=  "& DBServer & "; Service=1504; Protocol=onsoctcp; Database= "  & DBdatabase & "; Uid= " & DBuserID & "; Pwd= " &  DBpass" with the DSN being the name of the DSN that connects to UCCX on the web server.

I've enabled the snapshot config stuff, although I'm not sure what it wants from the "server name" section so I added both the web server IP address and and UCCX address.

If I do a test connection in ODBC using the uccxhruser username it fails every time, although I know the password is correct because on my client PC I can access the database just fine using that username.  If I use uccxwallboard for the username it works when I test the connection but it does not work for the wallboard.

I've made sure that everything is in lower case.  This is what the first part looks in the parameters section.  The only part I'm unsure about is the DBServer name, I'm using what's defined in the Web Server DSN, I've tried putting the DSN name in their as well..

Const IPCCversion = 8

Const ServerURL = ""

Const DBsource = ""

Const DBServer = "ahv_servername_uccx"

Const DBdatabase = "db_cra" 

Const DBuserID = "uccxwallboard" 

Const DBpass = "12345"

Any ideas?


Have you got the ODBC infomix driver installed?

You will need a / in the URL or your refresh won't work.


Sent from Cisco Technical Support iPad App

As jon said, the server url needs a trailing slash, althought this sounds like the least of your problems.

You need to use the uccxhruser. the uccxwallboard user does not have permissions to some of the tables we like to get stats from.

your DBServer should be "servername_uccx", and the DBsource should be the same as you used in your ODBC connection (I use the servername in my environment, but you may not be able to resolve that in yours).

Ok, the webpage is finally coming up but there's no content.  I tried the default gila-wallboard.asp as well and no content shows up.  Any ideas?

It could be due to your timezone and the calculations the script does.

Easy way to check this is to try changing the parameter "intAgentStatsMaxDays" try 0 or 2 and see if you get results.

If you do get results, you'll need to adjust the CalculateStatusTime routine to add or subtract time to suit your timezone.

(What timezone are you in??)

Level 1
Level 1

I should have been more specific, I can get Agent stats just fine but I'm unable to get any CSQ information.  I can view what status an agent is in without a problem.  I've tried the default gila-wallboard, my bastardized version, and another version I found and I get the same results for each.  No CSQ data whatsoever, not even the names.  The webpages will display but with no content.

Anybody have any ideas?  I'm having a heck of a time trying to figure this out.  I've tried just about everything and I'm unable to view any CSQ data from any wallboard.


I'm facing the same issues.

Did you found a reason and/or solution for this happening?



Level 1
Level 1
What is the calculatestatustime value for UTC+8??
Any one know how to do average + longest talk/wait duration for the past 1 hour of now everytime the screen refresh?  My refresh timer is 15s
sqlGetICDstats = "SELECT * FROM RtICDStatistics"
Set rs2 = server.createobject("adodb.recordset")
Set cm2 = Server.CreateObject("ADODB.Command")
    cm2.ActiveConnection = cn
    cm2.commandtext = sqlGetICDstats
Set rs2 = cm2.execute
<p class="sideBarTitle">Average</p>
          <li><strong>Talk:&nbsp;<%= rs2("convAvgTalkDuration") %></strong></li>
          <li><strong>Wait:&nbsp;<%= rs2("convAvgWaitDuration") %></strong></li>
        <p class="sideBarTitle">Longest</p>
          <li><strong>Talk:&nbsp;<%= rs2("convLongestTalkDuration") %></strong></li>
          <li><strong>Wait:&nbsp;<%= rs2("convLongestWaitDuration") %></strong></li>
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: