cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
363
Views
0
Helpful
0
Replies
Highlighted
Beginner

NAT Hairpin on a 1700 router

Hi,

I've got a setup where a router has 2 connections to the public internet, 1 DSL (ethernet to a DSL modem) and 1 T1.

Clients want to use the upload of the T1 for certain services (since the DSL upload is 1/2 the speed).

Clients behind the router have static IPs for the T1 ISP, but the default route is currently going out DSL.

I'd like to figure out how I can make services be accessible by a staticly NATed DSL IP and their T1 IP at the same time.

With the current setup, only traffic from the DSL IP would work, because the default route sends all traffic back out the DSL.

It seems like I need some sort of NAT hairpinning to make sure traffic gets sent back out the same interface.

Is this possible on a 1700?

Here are relevant parts of the config:

interface Loopback0

ip address 10.1.1.8 255.255.255.255

!

interface Ethernet0

description DSL

ip address xxx.xxx.xxx.82 255.255.255.248

ip nat outside

ip virtual-reassembly

full-duplex

!

interface FastEthernet0

description LAN

ip address yyy.yyy.yyy.161 255.255.255.240

ip nat inside

ip virtual-reassembly

speed auto

!

interface Serial0

description T1

ip unnumbered Loopback0

ip virtual-reassembly

encapsulation ppp

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.81 10

ip route 0.0.0.0 0.0.0.0 Serial0 20

ip nat pool DSLPOOL xxx.xxx.xxx.84 xxx.xxx.xxx.85 netmask 255.255.255.248

ip nat inside source list 1 pool DSLPOOL

ip nat inside source static yyy.yyy.yyy.162 xxx.xxx.xxx.83 route-map dslstatic

route-map dslstatic permit 10

match interface Ethernet0

Everyone's tags (3)
Content for Community-Ad